10-16-2016 08:25 PM
29 12
  1. BB_Rookie's Avatar
    Upgraded to KitKat last night and now my RAZR HD will not display the correct time nor connect to Google. I can't fix either issue and haven't found an exact issue after several hours of searching on the internet. Not surprisingly, Verizon store dude has never seen the issue and has no clue.

    After the upgrade completed the date and time on the phone were February 23rd, 2014 about 3 PM (upgrade finished 5/25 around 9pm) and none of the Google related tasks, apps, functions would work. This includes the search at the top of the home screen, email wouldn't sync, search in Chrome would not work, could not switch over to my 2nd gmail account, Play Store would not work, etc.

    Time and date would not update manually nor via the system. I turn off the auto update and enter the time or date manually and it does not update. Current time and date stay. I have rebooted and did a factory reset with no change. When I try to add my existing Google account after the reset, I get an error message stating "Can't establish a reliable connection to the server. This could be a temporary problem or your Android device may not be provisioned for data services." I have a data services turned on.

    Before I cleared the cache and app data for Chrome, the message I would receive when I tried to do a search or go to any Google.com URL said something about the SSL and couldn't make a connection.

    Any ideas on how to fix these issues?
    Saleem Sherazi likes this.
    05-26-2014 05:18 PM
  2. BB_Rookie's Avatar
    Some more info...

    Getting a "Certificate is not yet valid" warning for any website using https. I am fairly confident that my Google service issues are related to the incorrect date and time causing certificate issues. Hopefully these will be resolved once date/time is correct.
    05-26-2014 06:12 PM
  3. lcol8548's Avatar
    My phone updated to 4.4.2 last Thursday. Exactly the same problem. Time/Date are wrong (time is about 2.5hrs ahead of actual time and date is Jan 2013). This is preventing data access, though phone and text still working. Not able to manually change them either. Phone is basically dead at this point. Verizon store also clueless. Downloaded clocksync app. Able to read correct time from NTP but not able to force time to phone without root access.

    Any clues?
    05-28-2014 10:27 PM
  4. lcol8548's Avatar
    I should also mention I have a Droid Razr Maxx HD
    Android: 4.4.2
    System Ver: 182.46.10.XT926.Verizon.en.US
    Build num: KDA20.62-10
    05-28-2014 10:29 PM
  5. metfan923's Avatar
    Hey, did you guys ever find an answer for this? I just took the update to 4.4.2, and am experiencing the EXACT SAME issue...

    I even tried rooting and installing clocksync, which can connect to the correct NTP server and get the right atomic time, but when i try to sync system time to atomic time, it actually changes the atomic time to the wrong system time, instead of correcting the system time.

    i have to tell you, ive never been so close to jumping the android ship. this stuff is just irritating.
    06-23-2014 08:00 PM
  6. 1droid2droid's Avatar

    Any resolution? This happened to me after i swapped out my screen. Thought it might be related to some issues getting out the SIM card or something like that... I even brought my phone back to factory and the issue still exists.

    Rigoberto Flores likes this.
    07-10-2014 01:48 PM
  7. ZordonsTorso's Avatar
    Bumping this too... just ran into this problem today, but upgraded to KitKat over a month ago. Galaxy S3 here.

    Phone is pretty much useless now, as it's primary functions for me (email, clock) no longer work.
    07-31-2014 08:28 PM
  8. Rigoberto Flores's Avatar
    I have the same problem with version 4.4.2 on my razr hd can´t change the date manually, it stays in 1970
    09-24-2014 12:44 PM
  9. mrsmumbles's Avatar
    Did you guys try resetting app preferences? Settings, Apps (App manager), all, Menu Button, Reset Preferences
    09-24-2014 01:14 PM
  10. Hornguy75's Avatar
    Yes. Still no luck. Phone thinks it's Feb 16, 1971. Nothing works and Verizon Wireless doesn't appear to understand what the problem is.
    10-23-2014 08:16 AM
  11. Brad Nagel's Avatar
    I am having the same problem. I have tried the factory reset and cleared the cache. Verizon's solution is to replace the phone.
    Everything works on the phone except for thing associated with google and the time and date being off. I can access other websites and use apps that don't use google. I can not download apps or do updated beacause everything is done through the play store.

    I would rather not have to buy a new phone since I am out of warranty and do not have insurance.

    Please let me know if someone knows a solution.
    11-08-2014 05:36 PM
  12. jb4653's Avatar
    version 4.4.2
    Was working perfectly until the battery failed and was replaced. Now, date is January 1, 1970 and time is not correct. Cannot connect to any network resources because of this date/time problem. Tried everything - Changed from automatic network, cannot manually set date or time (will not take it). Hard reset multiple times. Currently running in 'safe mode', still not updating, cannot manually change. Wi-Fi and Verizon network appear to be working, but "certificate errors" and "network servers not available".

    Has anyone found a fix for this?
    02-03-2015 04:24 PM
  13. laTORTA's Avatar
    I've got the same problem.
    Motorola Razr HD XT925
    I know my country is underdeveloped, but it's not 1970...
    Tryed airplane mode, disabling auto-update, restarting phone several times. Nothing works.
    02-13-2015 06:49 PM
  14. 4ndr01dpilot's Avatar
    Happened as well to me post OTA update, but I also lost my custom recovery & had some other issues, so could not really get a handle on what was causing the problem.

    At one point in time I actually got the time to reset, but it happened so fast I could not repeat or figure out what i did (essentially just modifying the date/ time settings. However the time settings eventually degraded to the wrong date/time again. Somewhere I did managed to get root access back & discovered that with this problem any of the clock/ntp sync programs do not work. All they do is collect the correct atomic time and when trying to get the app to change the system time, the apps then show the atomic time as the incorrect system time we're trying to change.

    Some of my initial research led me to believe it might be a sim card issue/ time&date from towers combined with something changed in the operating system. Tries to reinstall the sim did nothing for the problem. So gave up... for a time. I got pissed at my backup phone while trying to make a phone call, and I pulled the sim & put it back in the Razr HD. After the call I noticed the time was ok again.

    All was well for a week & the date was lost again. Time date restored itself after sitting all day on wifi,on airplane mode, no sim. with the settings still turned on to automatically apply

    So I have noticed even with the phone showing the correct time, TWRP recovery still thinks the time is the old way wrong time. at this point I had the time right I made sure that date time setting were not set to automatically adjust. I did reboot several times and it didn't change.

    So being brave I reinstalled a debloated version of the stock ROM and, sure enough I had the wrong time & date again.

    So I made sure the sim was pulled (no phone network) and then only connected to wifi. I put the phone in airplane mode, turned back on wifi let it set/ connect 30 seconds and then went to date & time settings toggled "Automatic date & time" and "Automatic time zone" and voila the time corrected itself!

    I believe this how I accidentally resolved it the first time. (Or was it the second time?)

    So it seems the phone has trouble with where its getting its time from. Maybe there is an issue with the way the latest update reads, interacts with the sim, or there's issues with some radios & the OS getting time from the towers.

    So my operating theory. power off, pull sim. Reboot. turn on wifi. Turn on airplane mode. Turn back on wifi and connect to your network. Go to date time setting, turn off automatically apply date & time and time. Turn them back on. Hopefully the time corrects itself.

    This has worked for me twice, but I am too chicken to break it on purpose again. (. I have automatically apply off, and will use clock sync to set it myself)

    I now it's been a long three weeks for me so I hope this resolves the problem, or gets somebody closer to their own answer.

    04-01-2015 11:00 PM
  15. Rebelllious's Avatar
    Well, I ran into that kind of issue a couple of days ago. In my case it was the upper flex cable that was not sitting firmly in its socket. I bought the phone with that issue and now after I have disassembled it and made the cable sit firmly, everything is fine.
    05-26-2015 09:17 AM
  16. hi bill's Avatar
    I have fixed my phone using your technique a few times so I decided to figure out what caused it. After much testing and trail and error I have concluded that when the phone is turned off and has under 5% battery the phone does this weird time slip thing. Not sure why, but that is what consistently causes it. I'm using a Droid Razr M
    05-30-2015 07:17 PM
  17. dokim2411's Avatar
    can you give a solution?please!
    my phone get that probem too
    08-02-2015 05:15 AM
  18. 2015CamAUS's Avatar
    Upper flex cable and its earth is the answer. I swapped a cracked screen last night and the time and selfie camera both failed to work or be changed in the case of the time. So I tried all the reboot, sim card etc options to no avail. Then I read rebellious' suggestion and bingo. The motorola razr hd also needs the upper flex cable to be taped down to the inner metal case. I noticed that it had two metal contacts on the back but failed to retape it down. After checking the cables and retaping the phone came back to life; all features working on the latest upgrade. Good luck
    11-11-2015 12:21 AM
  19. khan 11's Avatar
    Did you found an solution
    12-15-2015 09:05 AM
  20. tshef1's Avatar
    Yes!!!! Rebelllious you are my hero!!!
    02-05-2016 11:55 PM
  21. Jeff Hooker's Avatar
    The ground in the area of the upper flex cable (the one connecting the forward facing camera to the motherboard) is indeed the answer. Took the back off the phone and one of the screws holding down the shield was loose. Snugged it down and reassembled and indeed, my phone no longer thinks it's 1970.
    02-23-2016 01:00 PM
  22. swamper8's Avatar
    I would appreciate some additional instruction on this ground issue.

    I can say that I've had the EXACT same problem with date/time as described in this thread. I have tried all the easy options (WIFI/AIRPLANE/REBOOT etc) but that did not help. I actually also replaced my screen and that didn't help either. I DID replace my camera/speaker assembly a few months before I had this problem. THe speaker was all scratchy. It was working for a while and then started to occasionally lose date and time sync but it always came back. Finally it lost it and I can't get it back for anything.
    I've attached a photo of my phone. I thought the last few posts were referring to the pads on the BACK of the ribbon cable which touch the large ground plane. I cleaned the area under the ribbon cable with alcohol and then used electrical tape to hold down the ribbon cable. However this has not fixed the problem. I read that someone fixed the problem by tightening down several screws? The screws holding down my camera are tight, however I don't know if the metal shield over the camera is supposed to be touching the backplane of the LCD. I also noticed a small tang on the side of the camera that looks like it touches another shield on the base of the camera. I don't know if this is an issue either.

    At any rate, some additional info would be appreciated! I'd love to have my phone back and working.
    RAZR HD - Time/Date won't update, can't connect to Google-img_0078.jpg
    02-26-2016 05:40 PM
  23. Sean_R_user's Avatar
    swamper8: I just had the same problem with my XT926 (Razr Maxx Hd) and fixed it a few days ago.

    History: I had dropped my original phone, which somehow caused the problem (no date/time update possible, preventing accurate local time and thereby secure communications protocols). From descriptions in prior posts in this thread, I tried re-seating both of the flex circuit cables (both wide and narrow), and even went to great lengths to ensure that the grounding point on the narrow cable had adequate pressure applied to the sheet metal internal backing for the display (I also cleaned the sheet metal backing with alcohol, as well as the gold-plated contact on the flex cable). None of these actions had a permanent effect (although the grounding point effort did appear to very *briefly* work, but then failed again).

    Since these actions didn't fix the problem, I gave up and bought a refurbished phone, then promptly dropped that one too. The display was now damaged on the refurbished phone, but it was otherwise OK. I now had two damaged phones with which I could swap out parts. Swapping out the upper cable assembly (including forward camera, speaker, and proximity sensor) fixed the problem. During this part exchange effort, I finally realized that the proximity sensor appeared to have failed on my original phone, which may be the ultimate problem. The portion of the upper cable assembly can be removed if you have a T3 Torx to unscrew those tiny shallow screws that hold the sheet metal bracket in place.

    BTW, on my phone the black part of the socket on the motherboard that clamps down on the upper flex cable assembly would keep popping off of the white part. If you carefully align this black part in the "open" position and apply pressure down towards the microphone side of the phone, this black piece can be re-seated into the tiny metal fingers on that white part. I've done this at least 3 times now.

    One of the above posts mentions a cascade effect with a failed proximity sensor, and that appears to the be the root cause in my case.

    Good luck with your troubleshooting!

    Update: Below is a photo of what I've described above
    RAZR HD - Time/Date won't update, can't connect to Google-img_0261_zoomed_cropped.jpg
    03-01-2016 10:55 AM
  24. swamper8's Avatar
    Thanks for taking the time to respond. everything you say makes sense, especially since I had not long ago replaced the camera/ speaker assembly. I didn’t know there was a prox sensor in that assembly. I had come to terms that it was probably a cascading/sensor issue however I couldn’t even install a APP on the phone to check the health of the sensors! (couldn’t get on Google PLAY) So I gave up and just bought aused phone off EBAY a few days ago. Had your post come along over the weekend I probably would have first tried a new speaker/camera Assembly. I will probably do that anyway, if it fixes the phone I will report back here for everyone’s benefit and just keep one of the phones as a spare!

    I had trouble with the larger of the two ZIF connectors not really holding the flat flex cable as tight as I would have liked. Probably ok once the phone was assembled but I pulled it out a few times while trying to marry the screen to the guts of the phone. I've used ZIF connectors a lot at work; they can be sensitive. I'm surprised you were able to get yours back together once the two parts separated!
    03-01-2016 11:12 AM
  25. Sean_R_user's Avatar
    Sorry my post didn't make it in time to save you a new phone! At least you've got spare parts now, if nothing else.

    I was also really surprised that it was possible to put the ZIF connector back together. It's really touchy, of course, since if you've aligned the two parts with your fingers, you can't easily see what you're doing. It helps to have a stereo microscope and use a couple of pairs of tweezers to manipulate the parts.
    Attached Thumbnails RAZR HD - Time/Date won't update, can't connect to Google-img_0273.jpg  
    03-01-2016 11:41 PM
29 12

Similar Threads

  1. serious battery issue after latest android update!!!
    By themkman in forum Sony Xperia Z
    Replies: 5
    Last Post: 06-25-2014, 03:18 PM
  2. WidgetLocker, TeslaUnread & NiLS won't show Gmail label unreads
    By Jamie Pyper1 in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 06-08-2014, 03:34 PM
  3. Moto X suddenly won't focus for close images
    By chriscic in forum Moto X (2013)
    Replies: 4
    Last Post: 05-27-2014, 04:32 PM
  4. I can't put my phone in my pocket and listen to music!
    By Lei Dietz in forum Samsung Galaxy S4 Active
    Replies: 2
    Last Post: 05-27-2014, 12:19 AM
  5. Galaxy S4/JBL Micro Wireless Blue tooth connectivity issue
    By Miles Zemanek in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 05-26-2014, 04:11 PM