1. LimperGrunt's Avatar
    I've had horrible battery since the last update and its continued over this update as well. Even with GPS, led, Bluetooth and screen brightness turned off/down and closing apps so they're not running in the BG my battery is dying within a good two to three hours.

    It even appears to be discharging while plugged in and this is with original cords. I'm at a loss...

    Nexus 5

    Sent from my Nexus 5 using Tapatalk
    06-24-2014 04:27 PM
  2. Golfdriver97's Avatar
    I've had horrible battery since the last update and its continued over this update as well. Even with GPS, led, Bluetooth and screen brightness turned off/down and closing apps so they're not running in the BG my battery is dying within a good two to three hours.

    It even appears to be discharging while plugged in and this is with original cords. I'm at a loss...

    Nexus 5

    Sent from my Nexus 5 using Tapatalk
    Have you either cleared the cache in recovery or done a factory reset since updating? The cache clear is less intrusive. Here is how: http://forums.androidcentral.com/nex...-recovery.html
    06-24-2014 04:47 PM
  3. LimperGrunt's Avatar
    I've tried a factory to no luck which would constitute a cache clear itself anyways. My next step is to return it for a new one unless someone else has a better option. Sadly I have another month until my plan is eligible for a free upgrade. May change away from my beloved nexus if they can't provide decent updates

    Sent from my Nexus 5 using Tapatalk
    06-24-2014 04:50 PM
  4. LimperGrunt's Avatar
    Golfdriver97, I once again did a factory and cleared the cache and its seemed to work. At least its actually charging now so I'd assume that did the trick. Appreciate the help

    Sent from my Nexus 5 using Tapatalk
    06-24-2014 10:12 PM
  5. Golfdriver97's Avatar
    Golfdriver97, I once again did a factory and cleared the cache and its seemed to work. At least its actually charging now so I'd assume that did the trick. Appreciate the help

    Sent from my Nexus 5 using Tapatalk
    Sorry, first time revisiting the thread. Glad it helped. If you'd like, follow up in a couple days.

    From a Carbon M8 and AC Forums app
    06-25-2014 01:47 PM

Similar Threads

  1. app and web page loading issues via wifi
    By William in forum Ask a Question
    Replies: 4
    Last Post: 06-26-2014, 05:44 PM
  2. Galaxy S5 Storage Issue!
    By RedtheBlood in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-24-2014, 03:08 PM
  3. Samsung Note 3 lock screen issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 11:47 AM
  4. Where can I get my voice heard regarding Android update issues?
    By 1812dave in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 06-24-2014, 11:18 AM
  5. Galaxy S4 Active - Won't Charge and Killing Batteries
    By Miranda Freeman in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 10:18 AM
LINK TO POST COPIED TO CLIPBOARD