1. AC Question's Avatar
    I used the native 'Data Usage' function to set a limit for my data use. When I hit this limit 'Data Usage' informed me that data would be turned off, and it did. Further messages followed saying that data is turned off and that I should 'click here' to reactivate, but the time was not yet right for my data plan. Now that I am in a new cycle of my data plan I cannot activate it again. The 'Mobile Data' icon is green, and all settings tell me data is on, but it just won't activate - there is no little 4G icon in the very top notification bar. I have turned the mobile data limit off, but no change. I have set very high data limits - no luck. I have restarted phone - no luck.
    There seems to be a problem with the Data Usage function. It won't advance to the new data cycle/month, and even if I set the Data Usage Cycle to today's date it defaults to last month. Please help.
    04-01-2015 07:44 AM
  2. belodion's Avatar
    Welcome to the forums.

    Try a Cache Partition wipe. If that doesn't fix it, get back to us.

    Posted via the Android Central App
    04-01-2015 07:47 AM
  3. oliwally1's Avatar
    Thanks so much for your quick reply.

    Try a Cache Partition wipe.
    How do I do that?
    04-01-2015 07:55 AM
  4. oliwally1's Avatar
    I've manage to wipe the cache by following a youtube video

    However, the problem remains. Mobile Data icon is green but mobile data is inactive - no icon in very top bar. Naturally I've disabled Wi-Fi to test this.
    04-01-2015 08:20 AM
  5. oliwally1's Avatar
    Ok, my mobile data is working again, but I don't know why...
    Here are some of the things I 'played' with before it suddenly decided to kick in:

    -Wipe the cache as suggested above
    -Changed to a different APN (there were a whole bunch already set up with similar names) then rebooted, then changed back to the original APN
    -Using WiFi connection, I refreshed my Telco's mobile app to tell me how much data I've used. It still doesn't seem to be displaying the correct values (says I've got no data when in reality I have 1.5GB on the new monthly cycle I've just entered) - don't know why.
    -After that the 'Data Usage' function started behaving itself, now correctly displaying the current month rather than the previous month.


    And now, the mobile data works again. Would love to know which of those things actually fixed it in the end...

    Thanks very much for your help all the same. Much appreciate your time and thoughts.
    04-01-2015 09:42 PM

Similar Threads

  1. How can I get my Galaxy S5 to turn on?
    By AC Question in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-06-2015, 12:06 PM
  2. Can I get some help with my Androide device manager?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 04-02-2015, 12:14 PM
  3. Replies: 2
    Last Post: 04-01-2015, 10:00 PM
  4. Running android based garmin gps rom on old cellphone?
    By Beckerton in forum Software Development and Hacking
    Replies: 3
    Last Post: 04-01-2015, 01:11 PM
  5. Can Android Device Manager force login after factory reset?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-01-2015, 12:26 PM
LINK TO POST COPIED TO CLIPBOARD