1. sudeep ghimire's Avatar
    Hi,

    just come across this thread as I have the same issue! I woke this morning to 19% charge after 6 hours. Yesterday morning was 67%, it hasn't reached 100% for about a week. I have tried other chargers, removed the battery and place it back and right now, I have the phone turned off charging through the laptop.

    When I try to charge it through the mains whilst turned off, it just vibrates every 2 seconds and shows a line across the screen as though something was going to show but stopped. Kind of thing you would see with a knackered screen.

    Whilst I type this, I keep getting USB device not recognised as it connects and disconnects however the charge is still showing but doesnt seem to be putting anything into the phone.

    The phone knows the charger is in, and shows but nothing is going in.

    Would this be a phone or battery issue? Unfortunately I don't have a spare battery to try but have run out of ideas. The battery has been spot on since I bought the phone start of November until this charge issue started a week ago.

    Any advice appreciated.
    07-22-2016 02:18 AM
  2. ratsttam's Avatar
    Could be as simple as a bad cable. See if the contacts in the charging port look corroded too.
    How old is the phone/battery? The battery can "suddenly" lose capacity if a cell or two in the pack go bad.
    07-22-2016 06:08 AM

Similar Threads

  1. Bieber Broke my Phone
    By bbqbear001 in forum Samsung Galaxy S7 edge
    Replies: 8
    Last Post: 07-28-2016, 01:17 AM
  2. Replies: 2
    Last Post: 07-25-2016, 06:07 PM
  3. Why does my Ellipsis7 tablet say not in range?
    By AC Question in forum Misc. Android Tablets
    Replies: 2
    Last Post: 07-22-2016, 03:56 AM
  4. Replies: 0
    Last Post: 07-22-2016, 02:17 AM
  5. Replies: 0
    Last Post: 07-22-2016, 12:51 AM
LINK TO POST COPIED TO CLIPBOARD