07-02-2018 10:07 PM
102 12345
tools
  1. paulto's Avatar
    You can turn off the heads up notification and still get the notification by using android ADB command (no root needed).
    Here is the command:
    Code:
    adb shell settings put global heads_up_notifications_enabled 0
    YES! thank you! finally a working solution! you are my hero L_advent!
    07-01-2015 06:14 PM
  2. RedHotLava's Avatar
    Just an FYI, for WhatsApp, under notifications, I chose for both single and group notifications, only one screen "off". That stops the banner, at least for me.

    Posted via the Android Central App
    07-02-2015 12:46 PM
  3. j3nova's Avatar
    Guys, i came to this forum looking for a solution and i found it. Rahman man was right,

    go to Settings --> Lock Screen and Security --> Other Security Settings --> Pin Windows --> On

    PROBLEM SOLVED !
    07-10-2015 04:46 AM
  4. Faheem Rana's Avatar
    YES! thank you! finally a working solution! you are my hero L_advent!
    Kindly help I am not a geek where to put this code? And can i get back the banner if I dont like it after geting rid of it
    07-11-2015 02:37 AM
  5. adayoff's Avatar
    Kindly help I am not a geek where to put this code? And can i get back the banner if I dont like it after geting rid of it
    I don't quite understand either and am excited to try it. I need baby steps explanation, please. Ha!

    Posted via the Android Central App
    07-15-2015 05:28 PM
  6. Sami Manninen's Avatar
    I don't quite understand either and am excited to try it. I need baby steps explanation, please. Ha!

    Posted via the Android Central App
    I also wanna know, what program exactly to use for this ?
    07-21-2015 02:24 PM
  7. incidentflux's Avatar
    Just an FYI, for WhatsApp, under notifications, I chose for both single and group notifications, only one screen "off". That stops the banner, at least for me.

    Posted via the Android Central App
    Solid solution. Thank You!

    I was blocking all WhatsApp notifications on my Z3.

    Now, solutions pending for Facebook Messenger and Hangouts. Until then they're blocked by system.
    07-22-2015 06:49 AM
  8. JaeVee101's Avatar
    Hey everyone,

    Not sure if you guys have figured out a way to stop the pop-up notifications but I came across an app that helps sort this issue out (at least it did for me )
    "Step 1: Install HeadsOff
    Go ahead and install HeadsOff, Jawomo's app, from the Google Play Store for free. Obviously, you'll need to be running Android 5.0 or higher for this.

    Step 2: Enable the Service
    To get this application working, open it up and select "App is disabled," then enable Notification access. Once access is granted, heads-up notifications will be suppressed.

    Step 3: Apply It on a Per-App Basis (Optional)
    With the Pro version ($1.99), you can enable HeadsOff on a per-app basis so you don't miss out on the alerts you really want. There's also an option to select how notifications appear on your lock screen, but this can also be done natively through the stock Settings app."

    Hope it helps!
    quiverskeep likes this.
    08-25-2015 02:30 AM
  9. quiverskeep's Avatar
    I can't thank you enough for that. Works like a charm. I had Whatsapp notifications turned completely off and had to go check to see if anyone messaged me. Now I have notifications only in notification panel again! Thank you thank you!
    08-25-2015 07:58 AM
  10. wmichw's Avatar
    Same exact problem - first AT&T + Google forced updated my phone w/o asking anything and now whatsapp has this annoying floating popup that cannot be turned off! Extremely irritating! Stay away from AT&T guys as they do not let people choose what to put on your phone and this latest update screwed up all my settings and now I have to waste tons of time on changing the settings... really considering rooting my phone... From a nice cool tech company Google has turned into a monopoly-like monster corporation, just like AT&T is... hope new cool startup companies kick their *** at least in some small areas...
    08-27-2015 01:20 PM
  11. JannyMaha's Avatar
    They wouldn't be so annoying if they didn't briefly pause whatever app I'm on.
    09-24-2015 06:38 PM
  12. toka8's Avatar
    actually, for me it's not a question of the vibrate, but the sound. if you set it to silent, there's no pop-up. weird
    10-14-2015 11:22 AM
  13. Obriann's Avatar
    Settings, Sound and notification, Ringtones and sounds, Messages notifications, then you can turn off Preview message

    Posted via the Android Central App
    10-30-2015 08:40 PM
  14. Norbu Fnu's Avatar
    I think there is setting go to message from there setting then tap on notification then uncheck pop-up display

    Posted via the Android Central App
    11-03-2015 03:43 PM
  15. Lenaaa's Avatar
    Hi All,

    I have been searching for a solution all day long. Tried all the tips mentioned here but it didn't work. I don't want to turn off the notifications, I want to see a WhatssApp icon followed by sender name, no message preview, both when my screen is on and locked. Has anyone found any other solution for Android 5.0.2 and Whatsapp version 2.12.367. I mailed Whatsapp support but haven't heard back yet.

    Thanks a lot!
    11-24-2015 02:49 PM
  16. scholaryoshi's Avatar
    I came to this thread looking for help. Anyone still looking try out this app. It works perfectly for me on my note 5!
    https://play.google.com/store/apps/d...orks.noheadsup
    01-06-2016 11:45 AM
  17. Hans Bosma's Avatar
    I puzzled also and think I found a complete solution. I have a Samsung Galaxy Core Prime by the way.

    I think it is a bug in the Android OS.

    When you select the 'no popup' in the Whatsapp Settings for both group and direct whatsapps, you do not see any notification at all (not in the Whatsapp icon, nor in the Task bar). To change this, just set for example the Notification-LED 'ON'. Then you get no popups but still get the visual notification in the task bar and the Whatsapp icon!!
    03-02-2016 05:24 AM
  18. fitz1j's Avatar
    Sorry to resurrect this old thread, but I just got a new phone and this was driving me crazy, but I found an answer so if this helps anyone that lands here from googling like I did I feel like it will be worth it.

    The answer is in "Allow peeking" which is buried under settings-> Sound & notification -> App notifications -> <app name: LINE> -> Allow Peeking and turn it OFF!
    04-29-2016 10:45 AM
  19. Archydos's Avatar
    Sorry to resurrect this old thread, but I just got a new phone and this was driving me crazy, but I found an answer so if this helps anyone that lands here from googling like I did I feel like it will be worth it.

    The answer is in "Allow peeking" which is buried under settings-> Sound & notification -> App notifications -> <app name: LINE> -> Allow Peeking and turn it OFF!
    THANK YOU! Finally...
    04-30-2016 12:39 PM
  20. Snokat's Avatar
    Is there a way? They're kinda annoying. I don't want texts popping up while I'm watching videos.

    Posted via Android Central App on The Nexus 5
    Go to main text message screen in message app, click the upper right button and go to settings, at the bottom you'll see the option to turn of pop-ups. If you have any other apps throwing up pop-ups, check their individual settings, it's an app by app feature, not a general setting.
    05-14-2016 04:49 PM
  21. Snokat's Avatar
    Sorry, missed a step there, in settings go to notifications, then you'll see the option to turn of pop-ups.
    05-14-2016 04:56 PM
  22. Saiful Haris's Avatar
    I think i found the solution for this....

    Go to Setting > Sound and Notifications > App notifications > (find apps) > Block

    Settle
    05-18-2016 09:49 PM
  23. hotdogchilli's Avatar
    The first post helped me! Thanks a lot!!!
    05-20-2016 01:29 PM
  24. seanwilliam's Avatar
    This works for me. Using Samsung Galaxy S4. Instead of turning the notification entirely off, set the Popup Notification settings to "Only When Screen "off""
    05-21-2016 05:25 AM
  25. 12brother12's Avatar
    I found this thread probably like most of you- trying to fix this extremely annoying pop up thing! Absolutely horrible idea. However, a couple of things..

    There has always been a similar feature- the message text used to pop up, but it stayed enclosed in the notification bar. Now that I liked, because if I caught the message as it came in I could read it without even opening the app. Thus far I have found no way to get that back. I have, however, been able to keep the notification of whatsapp while disabling the annoying pop up. Oddly enough, you do it by turning it ON. Set it to show pop ups only if screen is off. Now, if your screen is on, you will only receive a icon in the notification bar along with your normal notification sound. Not sure about the other messaging apps, but it worked for whatsapp.

    Hope this helps!
    THIS. This is great. It works. THANK YOU! I had given up hope on this stupid thing and then months later I thought maybe someone has a solution now. And this is it.
    05-26-2016 01:05 PM
102 12345

Similar Threads

  1. What does the arrow symbol mean 7 app manager?
    By ycc in forum Android 4.4 KitKat
    Replies: 7
    Last Post: 11-24-2014, 04:20 PM
  2. For The Love Of God, Has Anyone Found A Case For This Thing?!
    By NotAnAppleGuy in forum Samsung Galaxy Note Edge
    Replies: 11
    Last Post: 11-24-2014, 07:24 AM
  3. Replies: 11
    Last Post: 11-23-2014, 07:30 PM
  4. Moving songs to Notification folder
    By lfd159 in forum Samsung Galaxy S5
    Replies: 8
    Last Post: 11-21-2014, 12:23 AM
  5. Replies: 5
    Last Post: 11-18-2014, 03:17 PM
LINK TO POST COPIED TO CLIPBOARD