1. jerrod6's Avatar
    Wifi problem

    My Nexus 5 was updated to Android 5 on November 18th. Since then the Wifi indicator in my status bar has had an exclamation mark after it. I read in another thread on this forum that it means that there is no data. I checked my Wifi setup and the connection is there with an excellent signal strength.

    Next I stood in front of my router and surfed the web. There was no data coming through the router at all...no activity. I turned cellular data off and surfed again. This time data streamed through the router with no problem, but the exclamation mark still displayed. So I can use my Wifi as long as cellular data is off. The phone recognizes when it is out of wifi range because the icon disappears.

    Today I went to the gym and used their Wifi...same problem. Got home picked up the phone to turn cellular data off and use Wifi...and the problem was fixed. No exclamation points data through router while cell data is on. Two hours later the problem returned.

    As I write this the problem is fixed again. So….anyone else experience this? What did you do? What can I do?

    Beside this problem I like the new operating system. It is smooth without lag, and as with any full version upgrade I know there are going to be issues that need to be addressed.
    11-21-2014 01:29 PM
  2. Kenneth Greene's Avatar
    I'm having the same problem. The only difference is, when I turn off my cellular data, my WiFi still doesn't work on the phone.

    It's weird, because when I first updated to lollipop, the WiFi connection was fine. Now, this problem, which started 2 days ago, is still going on, and I'm not sure what to do.

    For the record, my Nexus 7 (2013) WiFi tablet running KitKat, is able to pick up the WiFi signal no problem. Something tells me this is a software issue. Also, every other device in the house is able to connect to the router WiFi.

    Please help.



    Posted via Android Central App
    11-21-2014 02:21 PM
  3. modonnell77's Avatar
    Same problem here too. Says it has found WiFi even though it in theory was set and working fine 2 days ago. Read that turning airplane mode on and off made it work, but that has now stopped too.

    It has also now started forgetting the safe places under smart lock so I have to keep putting in the pin each time. Worked fine for a day.

    Posted via the Android Central App
    11-21-2014 05:49 PM
  4. Kenneth Greene's Avatar
    My WiFi problem disappeared, here's how.

    I noticed every time I tried to connect to WiFi, a message would pop up saying that it can't connect to network (this message would appear at the bottom of the screen). Then I asked myself, where is that message coming from? I then realized the message is coming from another application. It seems the McAfee security software was cutting the connection. Once I removed the app, I was able to connect to WiFi, no problem.

    I believe that some applications have not been updated to work on lollipop, so they may be causing some of the issues with the devices running properly....like connecting to WiFi.

    Hope this helps.

    Posted via Android Central App
    11-24-2014 09:34 PM
  5. jerrod6's Avatar
    Thanks kenneth.

    Today I took a look a look at the Nexus help forum and saw comments about McAfee also. I looked at all of the applications I had running which at the time was not many. Then I rebooted my phone into safe mode and took a look. The one thing that was not running was beautiful widgets. Now I only used this for the battery indicator and with the new indicator in lollipop I had removed the widget from the screen. When I tried to clear the cache for BW the entire phone froze and became unresponsive so I had to hold the power button for a minute before it would shut down.

    I restarted. The wifi problem was corrected...at least for now...so I uninstalled BW. I Will see what tomorrow brings but I hope this corrects the problem. Funny because I've gotten a "TON" of app updates to my applications this week, but none for this app.
    11-25-2014 04:18 PM
  6. jerrod6's Avatar
    Yeah well I spoke too soon.

    A few hours after I thought I fixed this problem I put my phone down on the Nexus wireless charger for 3 minutes, picked it up to look for something and found that the wifi icon in the settings was displaying ! Problem returned.

    I turn my phone completely off at night and charge it. Today I turned on the phone to find the same thing. I immediately held down the power button until the phone rebooted itself. It rebooted without the problem. I am beginning to think that my issue is a system problem and not anything caused by an app.

    One thing I remember is that this is a Nexus phone which means we get the updated versions first. I've developed software for worldwide corporate use, and anytime there is a major update from one version to the next higher one, the upgrade is NEVER without issues. As hard as we tried...we could never provide this because there were just too many variables. I HAVE found a work around even though it is a pain right now.
    11-26-2014 10:14 AM

Similar Threads

  1. Why won't wifi stay off?
    By japark in forum Samsung Galaxy S5
    Replies: 42
    Last Post: 01-26-2017, 01:31 PM
  2. Replies: 3
    Last Post: 11-24-2014, 09:26 AM
  3. Problem trying to order OnePlus One
    By davekr in forum OnePlus One
    Replies: 4
    Last Post: 11-24-2014, 07:04 AM
  4. Replies: 4
    Last Post: 11-21-2014, 04:38 PM
  5. LG optimus fuel (L34C) notification problem
    By Avidite in forum LG Optimus L
    Replies: 0
    Last Post: 11-21-2014, 11:52 AM