04-21-2016 06:40 PM
77 123 ...
tools
  1. DirtyHarree's Avatar
    Not sure if anyone else is experiencing this. On my N4, the screen will randomly go black except for the 3 soft buttons at the bottom and the notification bar up top. I can pull the notification bar down and see notifications, but a click on one that would normally open another screen just reverts the entire screen to black. I tried rotating the screen, hitting all the buttons available,etc, but the only fix is a reboot. I haven't determined what causes this, but last time it happened when I ended a call. Anyone? Any fix?
    researchmonster likes this.
    11-23-2014 07:16 PM
  2. nexus5km's Avatar
    Same thing (exactly similar symptoms) happening every now on then on my nexus 5 rooted. Triggered sometimes by pressing back from recent apps, all apps screen, chrome. Stabilizes for a while if I dont install new apps (disable Playstore auto-update) - appears (I know it sounds weird) to destabilize when a new app/update is installed. After a reboot or two and some usage, its more stable. No other clues/pointers found so far. And even the playstore one may be red-herring.
    11-24-2014 12:40 AM
  3. B. Diddy's Avatar
    Try a cache partition wipe yet? Reset: Google Nexus 4 | T-Mobile Support
    11-24-2014 12:47 AM
  4. Alberto Cacho's Avatar
    Same here, screen goes black randomly and I only can see the 3 soft buttons and the notification bar.
    I have a nexus 4 and I've updated it with factory image without wiping data. It happens with and without root.
    11-24-2014 01:15 AM
  5. DirtyHarree's Avatar
    I tried a cache partition wipe. I'll see if that helps the issue.
    11-24-2014 01:33 AM
  6. Roberto Moura's Avatar
    Same problem here... it is really annoying. If you guys have an clue about how to resolve this, please tell us..

    Thank you
    11-24-2014 07:53 PM
  7. nexus5km's Avatar
    Tried the cache wipe yesterday - did not resolve the issue. Am considering a factory reset - however, saw a suggestion on another forum where a black screen symptom was traced to a specific (unnamed app) - have asked the poster how they traced it to a specific app (that they later uninstalled) - awaiting response. Will be good to hear from google on this - whatever the suggestion may be. Overall happy with lollipop - but this black screen thing is frequent enough to be ridiculous.
    11-24-2014 09:38 PM
  8. B. Diddy's Avatar
    You could also boot into Safe Mode, which prevents all 3rd party apps from starting up. Then open apps one by one until the problem happens again. The last app you opened may be the culprit.
    daihard2008 likes this.
    11-24-2014 10:34 PM
  9. Alberto Cacho's Avatar
    Well, this is like windows blue screen of death... if an app crashes, that doesnt have to make your system crash. I dont know if this bug is already reported to google but seems like this is going to require a fix in google side.
    John Staples likes this.
    11-25-2014 02:07 AM
  10. DirtyHarree's Avatar
    I did the cache wipe. Full day and a half, and the problem may be gone now. I'm running Tasker, and disabled a couple of non functioning tasks, so that could've been the issue too.
    11-25-2014 04:11 AM
  11. Schonplayer's Avatar
    I'm running the Nexus 4 lollipop stock not rooted and go launcher ex as my main launcher. I disabled the upward swipe gesture in go launcher and that seems to have fixed the black screen issue.
    11-28-2014 02:30 AM
  12. Olaf Klischat's Avatar
    Same problem here on a Nexus 5 (stock, non-rooted, no strange stuff installed). Having this issue since I rebooted earlier today to enable the latest Google Play Services update -- maybe they are the culprit? I've had Lollipop installed for two weeks or so now, didn't have this problem until today. Today though, I've seen this TWICE so far.
    11-28-2014 03:39 PM
  13. Alberto Cacho's Avatar
    I was starting to think the launcher was the problem (I'm using nova) but since Schonplayer is using Go Launcher the problem seems to be a lollipop issue.
    12-01-2014 03:41 AM
  14. MadScientistUK's Avatar
    I'm having the same issue on my rooted but otherwise stock nexus 5. Sometimes when I close an app the screen goes black with only the notification bar active. Strangely if I turn off the bluetooth, and therefore remove my trusted device, the screen goes back to the lock screen and I can start again. I removed my pebble from the trusted devices (no other devices are trusted) thinking that was the problem but it continued happening and toggling bluetooth still seems to sort it. This has happened exiting from several apps so I think it's definitely a google issue. I have also wiped and formatted the cache a couple of times with no success, just hoping I don't have to do a factory reset. If anyone figures out what the problem is please let us know.
    12-01-2014 09:16 AM
  15. Bill Farquharson's Avatar
    Does anyone use Tasker? I have disabled mine and my black screen problem has settled down now.
    12-02-2014 05:53 AM
  16. Alberto Cacho's Avatar
    Does anyone use Tasker? I have disabled mine and my black screen problem has settled down now.
    Yes, im using it... And sometimes taskes goes crazy with profiles based on bluetooth connection
    12-03-2014 04:04 AM
  17. nexus5km's Avatar
    In case it helps:
    - nexus 5, rooted, with tasker
    These are the things I have tried - and still getting hangs:
    - wiped cache (multiple times)
    - was using Atom launcher - switched to Google Now launcher
    - Uninstalled bluelight filter (switched to Twilight filter)
    - bluetooth toggling didn't help
    12-03-2014 05:07 AM
  18. nexus5km's Avatar
    Regarding the pointer to boot in safe mode and start one app at a time: problem is that the issue does not reliably happen on startup - and all applications work fine at one point or another. All startup fine, no functional issues. (Except xposed module dependent functionality of course). Starting apps one at a time will not help isolate it in this case (though I like the pointer as well). The problem takes a few hours to day and a half to recur.
    12-03-2014 05:13 AM
  19. countrycowboy026's Avatar
    Does anyone use Tasker? I have disabled mine and my black screen problem has settled down now.
    So here is what I have found. Ever since they introduced smartlock in the developer preview on my nexus 5 I began getting these random black screens. Exactly as described above, notification bar, and nav bar and nothing else.
    As of 12-01-14 I now also have a nexus 6 stock rooted with the exact same tasker profiles transfered over. It too had the random black screens as previously described. So when I saw Bill's post about tasker it got me thinking. While I was in the middle of a black screen, I some how through a lot of persistence managed to get tasker to come up. I disabled my location based security profiles which enable and disable my lock screen, after all this is now part of the smart lock feature anyhow. It seems this immediately after turning my screen off and back on fixed my problems. I think it is a conflict of interest between the built in smartlock feature, tasker, and secure settings.
    If I get another black screen I will report back, but as if now I have not.

    Also as an FYI I use smartlock over Bluetooth with my pebble smart watch, and my bluetooth ear piece. And now I also use it with the location based profiles.
    12-03-2014 07:37 AM
  20. 1pixie1's Avatar
    hmm I have been having these black screens as well since some time now after upgrading to Lolipop. Exactly same symptoms when exiting an application I got the black screen of death. What I noticed is that it happens more frequently when I restart and I try to open an App and press the back button immediately. If i leave it there for some time idle it doesnt happen that often.

    After reading the posts here I tried clearing the partition cache yesterday. No luck , another screen just now.

    I suspected tasker as well and I do have a profile as well that locks/unlocks screen based on WiFi connectivity. I disabled Tasker from the settings --> Disable Tasker. Will monitor for a couple of days to see if it happens...
    12-03-2014 08:25 AM
  21. Bill Farquharson's Avatar
    The lock/unlock screen based on WiFi connectivity is very handy but I am now using Power Toggles which gives me a one click disable/enable lock screen on a notification bar. It will do till Tasker is sorted. So far its been nearly a week since I've had the frozen black screen.
    12-03-2014 09:16 AM
  22. Charles Butcher's Avatar
    I've had the same issue with stock Lollipop via OTA on an unrooted Nexus 4. I'm using Tasker and Nova Launcher. I did sideload the Play Services update. I have Trusted Places set to unlock the phone when I’m at home.

    I suspect Tasker, because when I have disabled Tasker I've so far not seen the problem recur, and IIRC it didn't happen in the few days between getting Lollipop and installing Tasker. There’s a post on Reddit in which some people are blaming Tasker, and specifically the “keyguard off” command, which I use. (As a newbie I’m not allowed to link).

    I've mostly been able to avoid rebooting by using the notifications pulldown to turn Wi-Fi off and then back on again, or toggle aeroplane* mode. Once the black screen is gone, everything seems fine until the next time.

    * Is it called "aeroplane mode" just because I'm a Brit? If so, I'm touched.
    12-04-2014 05:56 AM
  23. Ruben Kona's Avatar
    Same issue here Nexus 4 lollipop rooted. I don't use Tasker, but AutomateIt Pro.

    The only time my Nexus exit from Black Screen without reboot, was receiving a phone call, the screen show the call in screen and when I finish speaking, the phone was ok again.

    I have also an additional issue: when I reboot the phone, sometimes the thouch screen doesn't works very well, I have to tap with 2 or 3 fingers same time to produce a touch on the screen, very extrange. After other reboot works again.

    Ruben
    12-04-2014 07:40 AM
  24. Ruben Kona's Avatar
    I haven't mentioned that I am using Nova Launcher, I think it could be stone issue with it.

    I have received now in my Nexus 7 the 5.0.1 Lolipop update, but I don't sufer this problem on it. I anyone test it on Nexus 4, please report here.

    Ruben
    12-04-2014 03:17 PM
  25. nexus5km's Avatar
    ...I think it is a conflict of interest between the built in smartlock feature, tasker, and secure settings.
    .
    Disabled the Wifi-connect/around based profiles on Tasker (used in conjunction with Secure Settings) - and have been stable for over two days now. Will update if I get any black screens again. So far, the analysis above seems to have helped. Thanks.
    Bill Farquharson likes this.
    12-05-2014 12:27 AM
77 123 ...

Similar Threads

  1. No lollipop for nexus 7?
    By Tom Scott1 in forum Google Nexus 7 Tablet (2013)
    Replies: 30
    Last Post: 11-30-2014, 04:19 PM
  2. Editing photo spheres in lollipop
    By djkleric in forum Ask a Question
    Replies: 1
    Last Post: 11-23-2014, 09:45 PM
  3. help shattered screen on lg g2
    By sbctony in forum Verizon LG G2
    Replies: 2
    Last Post: 11-23-2014, 07:05 PM
  4. Why does my screen say System Software not authorized?
    By kbarry2323 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-23-2014, 06:42 PM
LINK TO POST COPIED TO CLIPBOARD