1. BruceWeber's Avatar
    I have Home and Work set up in Google Maps, but the option to enable them in Smart Lock is grayed out. I can enter them as custom places, which works fine. I'm just wondering why they I can't enable them as Home and Work. Thoughts?
    11-25-2014 01:27 PM
  2. gone down south's Avatar
    Same thing here...
    11-25-2014 01:51 PM
  3. vividrich's Avatar
    Odd. I can enable them, but the feature doesn't work really well for me. It's routinely requiring me to log in anyway.

    Posted from my Nexus 5 via Android Central App
    11-25-2014 02:20 PM
  4. daihard2008's Avatar
    I am using Home and Work as my two trusted places. It works well in both places for me. FWIW, I use a pattern to unlock the phone.
    Standroid43 likes this.
    11-25-2014 02:51 PM
  5. Paddy Landau's Avatar
    Yes, I have the same problem; it's greyed out.
    11-26-2014 04:03 AM
  6. digitalangel's Avatar
    I'm in UK and my Nexus 5 doesn't even have a an option for places.
    11-26-2014 06:20 AM
  7. Paddy Landau's Avatar
    I'm in UK and my Nexus 5 doesn't even have a an option for places.
    It's being rolled out worldwide (I'm also in the UK). The order of receipt appears to be random. It'll be with you soon.

    It's a silent update, so you have to check every now and then; I don't know if you have to restart your phone.
    11-26-2014 08:14 AM
  8. Paddy Landau's Avatar
    I have just been in a discussion with Google Support for this issue.

    Here is the response, summarised because I was with them for a long time!

    Method 1


    1. Go to Settings > Security > Clear credentials.
    2. Try again to set Home or Work as a Trusted Place.
    3. If that doesn't work (it didn't with me, because Clear credentials was greyed out), restart into Safe Mode and repeat. (To get into Safe Mode, hold down the power button until you see the "Power Off"; then press down on "Power Off" until you see the prompt to restart into Safe Mode; press OK. Get out of Safe Mode by restarting normally.)
    4. If that doesn't work (it didn't with me, because Clear credentials was greyed out), go on to Method 2.


    Method 2



    1. Report the issue to Google Maps (yes, really), as follows.
      • Go to the Google Maps Help Centre.
      • Select Fix an issue > Report a problem.
      • Follow the instructions under Report a problem with the map.


    I have not tried Method 2, because I don't have time right now. If you do, please let us know the response.

    Method 3


    1. Settings > Backup & reset > Factory data reset. Warning: This will do a Factory Restore and you will lose ALL of your data stored on the phone. Ensure that you have a complete backup of everything before you proceed. (Data on the cloud will still be OK.) If you use Authenticator, VIP access or any other two-factor protocol, you'll need to ensure that you can log in to your various accounts without the authenticator apps before you do your factory restore.


    I haven't tried Method 3, because I don't have time. Maybe over the weekend.
    11-26-2014 09:23 AM
  9. parkerhugh's Avatar
    I had same problem as described here, my Home and Work Locations were both greyed out and not available to select.

    But my home and work locations are the same. So I went to Google Maps > Settings > Edit home or work

    I removed my home address from Work and screen then said "Enter work address".

    I went back to Settings > Security > Smart Lock and my Home address was now available to select as trusted place.

    I think the reason both were greyed out and not previously available was because they were the same address and you couldn't enable one without the other.

    Hope this helps someone else.
    Paddy Landau likes this.
    12-14-2014 07:09 AM
  10. Paddy Landau's Avatar
    But my home and work locations are the same…
    So were mine.

    They were the same because, when I left the Work address empty, Android kept filling it in with random addresses (addresses that I'd never even visited!).

    However, I've copied what you have done and now it works. Thank you.

    I subsequently returned to Google Maps and re-entered my Work address (the same as my Home address), and restarted my phone. It still works (although Smart Lock thinks that my Work address is still empty).

    I have reported this bug; any reader who is affected by this should log in there and click the star.

    EDIT: See next post
    12-14-2014 10:39 AM
  11. Paddy Landau's Avatar
    It turns out that I posted the bug in the wrong place.

    I have re-posted it in the Google Product Forums.
    12-15-2014 06:32 AM
  12. Tom Matheney's Avatar
    For me the steps above (deleting home/work then adding them back) worked, thanks. Perhaps something to do with enabling smart lock after entering home/work addresses, as I did when I first set up my phone.
    12-25-2014 02:43 PM
  13. jefferai's Avatar
    I have a slightly different but maybe related problem: Trusted Places doesn't show up at all. I have Play Services 6.5.99 so that shouldn't be an issue. I've tried removing Home/Work and re-adding just one of them...no dice.
    01-06-2015 11:55 AM
  14. grover5's Avatar
    Odd. I can enable them, but the feature doesn't work really well for me. It's routinely requiring me to log in anyway.

    Posted from my Nexus 5 via Android Central App
    I have the same issue. If I leave home and return it doesn't remember home as safe and requires me to use my pattern password. But once I reboot the phone then it works again.

    Posted via the Android Central App
    01-06-2015 12:06 PM
  15. Svensk Smith's Avatar
    Same issue here, my home deactivates itself in trusted places. It works one unlock and the second is locked again, If I look in trusted places home is disabled. Work place is doing fine though. I have tried pin and pattern...
    01-08-2015 05:12 AM
  16. bilalsattar24's Avatar
    have you had any luck? I'm having the same issue on GPE M8

    Posted via the Android Central App
    01-08-2015 04:50 PM
  17. menawati's Avatar
    Another thing to check.
    Wasn't working for me either - I set Home as trusted in smart lock but still had to enter my passcode.
    Then I noticed that my home address is actually at end of street on maps - I live in a weird cul-de-sac type place and google maps seems to believe my address is about 200 metres away. That is why it wasn't working (it would have actually unlocked at the end of the street if I walked there).

    So, just reset your home address to it's actual geographical location or add a new trusted place at your current loc when you are at home (I did the latter and called it 'Home Loc' or something). Worked fine then.
    01-25-2015 04:47 AM
  18. spile1's Avatar
    Smart lock does not work for me when two user accounts are set on the device as the feature can only be turned on in one account.
    Attempting to turn on Smart lock in one account results in smart lock being turned off in the other.
    02-02-2015 02:04 AM
  19. Paddy Landau's Avatar
    Attempting to turn on Smart lock in one account results in smart lock being turned off in the other.
    My experience with Smart Lock is that what you put the main account applies whichever account is currently using it.

    Maybe you should report this as a bug.
    02-02-2015 03:27 AM
  20. mark_ck's Avatar
    I have a slightly different but maybe related problem: Trusted Places doesn't show up at all. I have Play Services 6.5.99 so that shouldn't be an issue. I've tried removing Home/Work and re-adding just one of them...no dice.
    I had the same problem, encrypt your phone and it should show up.
    02-25-2015 01:47 AM
  21. Paddy Landau's Avatar
    I had the same problem, encrypt your phone and it should show up.
    That shouldn't be necessary. I had Trusted Places before I encrypted. When I encrypted the phone, although Trusted Places was still there, the encryption slowed my phone badly. I did a factory-level reset, and Trusted Places is still present.
    02-25-2015 07:37 AM
  22. barry1964's Avatar
    I've just realised that the post code for location doesn't resolve to the actual physical location of the building. I've been basing home on my post code, bur if I go onto Google maps, find my actual building and rather than trying to add home add the building as a trusted place the unlock feature seems to work just fine. It's weird cos I've never had this problem before but if it fixes it I'm not complaining, and maybe before the location was just less accurate!

    Posted via the Android Central App
    02-25-2015 06:07 PM

Similar Threads

  1. Fitness bands with Notifications?
    By dirtyjudo in forum Connected Accessories
    Replies: 4
    Last Post: 03-01-2016, 09:52 PM
  2. How can I root my Sony Xperia M : ( Model C1905 )?
    By Nuno Seven in forum Sony Xperia M2
    Replies: 1
    Last Post: 07-14-2015, 02:03 AM
  3. Fitness Bands with Notifications?
    By dirtyjudo in forum Google Nexus 5
    Replies: 2
    Last Post: 12-08-2014, 07:31 AM
  4. Why does my Samsung galaxy s4 die so quickly?
    By kingg_reyes in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 11-26-2014, 01:13 AM
  5. Replies: 5
    Last Post: 11-25-2014, 06:10 PM
LINK TO POST COPIED TO CLIPBOARD