1. sudhanshu_s's Avatar
    HI everyone,
    I upgraded to latest Android Lollipop as it was pushed to my phone by Motorola. After Android L update
    my phone is not able to connect to 3g or 2g Cellular data. I am able to connect through Wi Fi though.
    My phone has two sim slots and sim slot 1 is damaged so my sim is in sim slot 2. I get an exclamation
    mark right next to the signal icon on the phone. I get that on wi fi too even though I am connected to Internet
    in Wi Fi with no problem.

    So after android lollipop update, My moto g 1st generation phone is not able to connect to cellular data at all.
    My phone has two sim slots out of which sim slot 1 is damaged so I am having the sim in sim slot 2.

    I am able to make phone calls and send texts. Before the Android L update I was able to connect to cellular data
    from sim slot 2 but not anymore.

    Please let me know how to fix it if anyone has encountered this and solved the problem.
    So far I have done cache wipe and done update for as many apps on the phone as possible through wi fi.
    Motorolla guys suggested cache wipe out on chat support and on call the girl asked me to do the factory reset !

    I will wait for more days before I do factory reset. Let me know if anyone knows how to fix it.
    Thanks.
    02-19-2015 02:52 PM
  2. Javier P's Avatar
    Take a look at this thread and see if some of the fixes there work for you.

    http://forums.androidcentral.com/sho...d.php?t=484781
    02-19-2015 03:01 PM
  3. sudhanshu_s's Avatar
    In that post one of the person has the same problem as I have described and solution he mentions is to put the sim in another sim slot but I can't do that as my sim slot 1 is damaged and I have only sim slot 2 active and in a working state.

    So I am unable to fix the problem. Even if I am able to after getting my sim slot 1 repaired or replaced with a new one this doesn't solve the problem. I may want to use the data from sim slot 2 as the carrier may give better data plan compared to the sim slot 1 carrier.

    So my problem remains: After updating my phone's Android Kitkat version to the latest Android Lollipop I am not able to connect to cellular data at all. I get exclamation mark next to the tower signal mark on the phone however my phone is able to make calls and send texts and have data on Wi Fi. Cellular 2g/3g data is non functional.

    How do I fix this? Anyone with similar problem and has solved it?

    I wonder why are they releasing the Android L with so many bugs !! They should have had asked for volunteers for beta or such tests !! I wonder if they did that !

    Anyways, any help will be appreciated.
    Thanks.
    02-19-2015 09:18 PM
  4. Javier P's Avatar
    Try this. Power off your phone, remove your SIM card and power on. Off again, put the card back and power on.

    Check your mobile settings just in case the update changed your defaults.

    If it doesn't work try with a different SIM card just to make sure that is not a card problem. Or test your card in another phone. Don't worry, the slot is not carrier dependant, just the SIM is.
    02-20-2015 03:28 AM
  5. sudhanshu_s's Avatar
    I followed the steps you mentioned and it hasn't helped. I used another sim to see if it works but then too it didn't connect.
    I have no other option I believe other than do factory reset and take the phone to service center. I also tried SAFE MODE to see
    if any third party app was creating this problem but to no avail. Disconnected since i got this lollipop !!
    02-25-2015 02:02 AM
  6. anuusk's Avatar
    i hav the same problem dude did u get the solution
    10-01-2015 04:38 AM

Similar Threads

  1. Replies: 1
    Last Post: 02-19-2015, 11:41 PM
  2. Replies: 3
    Last Post: 02-19-2015, 03:49 PM
  3. Replies: 1
    Last Post: 02-19-2015, 02:37 PM
  4. Replies: 0
    Last Post: 02-19-2015, 02:26 PM
  5. Replies: 0
    Last Post: 02-19-2015, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD