1. ajmclachlan's Avatar
    I suspect that my problem is a result of install of Lollipop hence the post here. HTC have no knowledge of the problem.


    Phone: HTC_M8
    Software: Android 5.0.1, 4.18.708.12
    Problem: Can't connect to internet via mobile data hotspot.
    I can access the internet from the phone. I can connect to the phone via phone's hotspot. I cannot access internet via hotspot, neither can others.

    I've tried to resolve including factory reset of phone. I've been to HTC support. I've confirmed that Telstra do not block hotspot connection.


    Any info to resolve appreciated.

    Andrew
    03-13-2015 05:10 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wireless & Networks>Mobile Hotspot, and select the option to set it up. See what happens if you change its security to None temporarily--can you now successfully tether?
    03-13-2015 11:34 AM
  3. ajmclachlan's Avatar
    Thanks for the suggestion. Tried this both before and after the hard reset and no joy. The problem remains that I can actually connect to the hotspot, but without internet access.
    03-13-2015 04:31 PM
  4. B. Diddy's Avatar
    Inform your carrier. They might have messed up their Lollipop update, resulting in this problem.
    03-13-2015 05:10 PM
  5. ajmclachlan's Avatar
    Thanks. Exploring with my Telco who have now escelated it to Android.

    Posted via the Android Central App
    03-21-2015 10:18 PM
  6. leonship's Avatar
    I to have the same problem since lollipop update 5.0.1. As I imported my m8 from Hong Kong they (HTC Hong Kong) say it appears it may be a hardware issue and ship it back to HTC Hong Kong for repair and at least 3weeks turn around. No loan available and I can not run my business without it so will have to buy a cheapie to use while this happens. Check out Motorola Moto G from Costco $238. My insurance excess if covered would be $250 so I guess this is my only option. My old phone (HTC Sensation) unfortunately does not work. Any other ideas?
    ajmclachlan likes this.
    03-23-2015 02:29 AM
  7. ajmclachlan's Avatar
    Thanks for your post. My phone too was from Hong Kong. Could be the vital element.

    I've now been to HTC, HTC USA, my carrier, Telstra (twice). HTC refer me to a phone repairer however I can't see how it could be hardware related.

    Posted via the Android Central App
    03-25-2015 08:27 AM
  8. syon16734's Avatar
    Hello,

    I'm having exactly the same problem (unlocked HTC one M8 on telstra). Similarly, I can connect via wifi or USB but cant use the internet on the computer. I've also done trouble shooting with HTC up to the factory reset with no luck. Wondering if anyone has come across a fix?

    To add to the complexity I've noticed if i set up the USB share with my phone connected to WiFi then my laptop can use the internet through the phone. Only have an issue when phone is on mobile data.

    Cheers!

    P.s Phone was purchase directly through HTC while I was in the USA if that adds anything to the Hong Kong line of thought.
    09-22-2015 01:16 AM

Similar Threads

  1. OTA Sideload update - adb problems on Mac OS X Yosemite
    By sp0tted in forum Nexus 6 Rooting, ROMs, & Hacks
    Replies: 3
    Last Post: 05-21-2015, 12:25 PM
  2. Why won't my HTC One M7 boot?
    By AC Question in forum HTC One M7
    Replies: 2
    Last Post: 03-13-2015, 01:29 PM
  3. why authentication problem occures while connecting to wifi
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-13-2015, 11:57 AM
  4. Replies: 0
    Last Post: 03-12-2015, 10:47 PM
LINK TO POST COPIED TO CLIPBOARD