01-03-2017 04:13 AM
26 12
tools
  1. Planehopr's Avatar
    I installed Lollipop on my Samsung Galaxy S4 yesterday. Now when I try to use my clock app for timers and alarms, I get the message "Unfortunately, Clock has stopped." Then I press OK and the app goes away.

    This is very frustrating to me because I use my clock app everyday. I downloaded another one from the play store but I would prefer to use the original factory clock.

    I tried clearing the cache and data per the advice on this and other websites. It didn't fix the problem. I tried doing a complete factory reset and it still doesn't work. Now I have to update all my settings all over again. I'm pretty pissed.

    I also called Verizon's tech support and they didn't know what to do either.

    I'm hoping they push through another update that fixes this. If anyone has any solutions, please let me know. I have been searching for something that will resolve this issue with no luck.
    05-09-2015 01:22 PM
  2. Planehopr's Avatar
    ***********Update*************POSSIBLE SOLUTION

    5/9/2015

    I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

    Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

    Before I tried clearing cache and doing a factory reset You don't have to do this if this "choose date format" works. Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!
    recDNA likes this.
    05-09-2015 02:39 PM
  3. df71's Avatar
    This worked for me. Thanks for sharing and keeping me from doing a factory reset!
    05-09-2015 06:13 PM
  4. onastyinc's Avatar
    Worked for me! Been fighting this issue for the last week. Very glad I didn't have to factory reset my phone!
    05-11-2015 07:50 AM
  5. Joe Dumaris's Avatar
    Worked for me! Thank you so much for sharing.
    05-12-2015 08:40 PM
  6. recDNA's Avatar
    Saved me from an agonizing night of setting everything up again after a factory reset. Thanks so much. This should be a sticky.
    05-15-2015 08:34 PM
  7. WillRM's Avatar
    Worked for me too. I too use the Clock app frequently, so this fix is a Godsend. Thanks so much.

    ***********Update*************POSSIBLE SOLUTION

    5/9/2015

    I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

    Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

    Before I tried clearing cache and doing a factory reset You don't have to do this if this "choose date format" works. Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!
    05-17-2015 02:19 PM
  8. recDNA's Avatar
    Just think of all the people who are needlessly suffering a factory reset because this solution is not well known.
    05-18-2015 12:02 PM
  9. Shawn Ishler's Avatar
    This worked! Thank you for sharing this fix.
    05-26-2015 01:26 PM
  10. shallett12's Avatar
    Hurray! Now I can turn off the alarm I set for 5:35 a.m.!!:
    05-30-2015 02:34 PM
  11. jeroenslemmer's Avatar
    worked for me. Thanks a lot.
    06-04-2015 04:24 PM
  12. MCOregon's Avatar
    Thanks for sharing the fix!
    This had been bugging me since the update.
    06-14-2015 05:36 PM
  13. C JayKay's Avatar
    None of it worked for me. The clock would stop working as quick as I fixed it. I downloaded a free alarm app. Problem solved for me.
    06-28-2015 09:29 PM
  14. Alfred Voon's Avatar
    None of it worked for me. The clock would stop working as quick as I fixed it. I downloaded a free alarm app. Problem solved for me.
    For those who still suffering from this issue:
    1.Go to Setting > Date and Time > Date format > Regional
    OR
    2.The alarm clock's glitch happened when you have your sound volume totally off , so simply turn on your sound volume and its all good.
    07-12-2015 08:11 AM
  15. desmaw's Avatar
    For those who still suffering from this issue:
    1.Go to Setting > Date and Time > Date format > Regional
    OR
    2.The alarm clock's glitch happened when you have your sound volume totally off , so simply turn on your sound volume and its all good.
    07-15-2015 05:06 AM
  16. desmaw's Avatar
    Yaay thank you just taking my phone off mite fixed it for me whoop whoop now I can set my alarm for work!! Much appreciated
    07-15-2015 05:07 AM
  17. Vaashanthirren Balakrishnan's Avatar
    Yes... It worked for me...Just that the phone was in silent and turn it back on what there you go...
    08-02-2015 12:40 PM
  18. recDNA's Avatar
    Worked perfectly for my but flixter app won't open. Always says my date is wrong even though it is not. Weird
    08-04-2015 12:18 PM
  19. capitalchimera's Avatar
    This didn't work for me. It's only started since the recent update to 5.0.2

    Though I have the s6 edge and not much seems to work...
    09-02-2015 08:13 PM
  20. capitalchimera's Avatar
    Neither of these work for me...I've had to factory reset the phone more than once (as per att tech support) and nothing works. this is one of many issues with my s6 edge
    09-02-2015 08:15 PM
  21. wanderend's Avatar
    Yes, it finally worked. Thank you so much for posting the solution! I hate how all Samsung does is suggest clear cache and factory reset. Once again, thanks so much.
    09-07-2015 09:58 PM
  22. ZhyonKross's Avatar
    This is good, worked for me thanks

    Posted via the Android Central App
    09-08-2015 11:38 PM
  23. Divya_Sharma2809's Avatar
    For those who still suffering from this issue:
    1.Go to Setting > Date and Time > Date format > Regional
    OR
    2.The alarm clock's glitch happened when you have your sound volume totally off , so simply turn on your sound volume and its all good.
    OMG.... This is unbelievable!! The volume thing worked for me Thanks a ton, never thought this would work.
    09-27-2015 06:27 AM
  24. Controlr's Avatar
    Settings--(MyDevice)--(More)--App Manager--Clock.
    Clear Cache, Clear Data, then click Uninstall Clock Update.

    (My son had the same problem and this seems to have cured it.)
    07-06-2016 12:22 PM
  25. Geetia's Avatar
    Neither of these work for me...I've had to factory reset the phone more than once (as per att tech support) and nothing works. this is one of many issues with my s6 edge
    It does not work for me on S5 whicheck started after the recent OS upgrade.

    Any other solution will be appreciated
    12-16-2016 10:20 PM
26 12

Similar Threads

  1. Replies: 4
    Last Post: 05-22-2016, 11:33 PM
  2. Replies: 7
    Last Post: 05-13-2015, 06:34 PM
  3. Replies: 4
    Last Post: 05-10-2015, 12:31 AM
  4. Why won't lolipop install?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-09-2015, 11:26 PM
  5. Where Do I Get Google Apps(Gapps) Package?
    By Jahanzeb Laghari in forum Ask a Question
    Replies: 1
    Last Post: 05-09-2015, 09:20 PM
LINK TO POST COPIED TO CLIPBOARD