1. 88Obz's Avatar
    At work we have guest Wifi that requires a username and password. In old Android you could sign on with whatever browser. If you use Chrome it stores your username and password so that you don't have to enter it every time.

    With my new zenfone 2 when I am in range of my work Wifi network the app CapitvePortalLogin keeps pushing the login screen at me. But it NEVER SAVES MY USERNAME AND PASSWORD. So i've got to enter it in again, and again, and again, and again.... and again.

    Is CapitvePortalLogin an android process or a crappy Asus Zenfone process? I can't stop it. Can't change settings. Have to connect through it, and enter my username and password again, and again...
    05-28-2015 01:56 PM
  2. Rukbat's Avatar
    Is CapitvePortalLogin an android process or a crappy Asus Zenfone process?
    It sounds more like the wifi router login program that's running in the router or on the corporate network. Talk to your network admin. (And install Chrome, so you can have it remember your login and password.)

    Have to connect through it, and enter my username and password again, and again...
    It sounds as if someone isn't too good at writing web software - not you, whoever wrote the website. The login isn't carried as a session variable, so each page thinks it's a new connection and you have to log in (which Chrome is doing for you behind the curtain). Everyone thinks he's a "web developer" (because he can push a few buttons on an application and have a web site) - few are.
    05-28-2015 02:55 PM
  3. 88Obz's Avatar
    I already have Chrome as the default browser. But that doesn't change the fact that CaptivePortalLogin has its own browser that doesn't remember login credentials. I can't see a way to force this CapitvePortalLogin process to use Chrome. I'll try contacting network admin but I work for a mammoth company with 200,000 employees worldwide. I'm just a cog in the wheel :-(
    05-29-2015 10:20 AM
  4. Crashdamage's Avatar
    I'm kinda confused. First you said that "if you use Chrome it stores your username and password so that you don't have to enter it every time.". Then you say you have Chrome as your default browser but the CaptivePortalLogin won't use it. So I'm missing just what you mean...Chrome works for some people but not for you?

    Anyway, Rukbat is right that the problem is very likely poor coding of the login. And you're right that the next step is to contact the IT department and make them aware of the problem.

    Android user since v1.0. Linux user since 2001.
    05-29-2015 11:23 AM
  5. N4Newbie's Avatar
    It seems that "there's an app for that."

    Perhaps even many.

    Here is one: https://play.google.com/store/apps/d...ifiwebloginapp

    And here are some others: https://play.google.com/store/search...:S:ANO1ljIwA9Y

    Let me know how you make out; I might want to use this myself.
    05-29-2015 12:07 PM
  6. pattipooter's Avatar
    I'm kinda confused. First you said that "if you use Chrome it stores your username and password so that you don't have to enter it every time.". Then you say you have Chrome as your default browser but the CaptivePortalLogin won't use it. So I'm missing just what you mean...Chrome works for some people but not for you?

    Anyway, Rukbat is right that the problem is very likely poor coding of the login. And you're right that the next step is to contact the IT department and make them aware of the problem.

    Android user since v1.0. Linux user since 2001.
    07-14-2015 01:48 PM
  7. pattipooter's Avatar
    It is not a browser. Captive portal login is used for Wi-Fi hotspots login and if it saved your login info one would think it would then only allow you to use that single hotspot. Turn hot-spot off and maybe it'll quit popping up everytime you're near a hot-spot. But then again I may be wrong. Best to go to Google Plus and check out the Android communities for help.
    07-14-2015 01:54 PM
  8. KingDonkeyKong's Avatar
    Hi friend. could you make a way to change the default app that Login at Captive portal? I have a ZenFone2 and it seems to have it´s own captive portal web app that really doesn´t save the user and password. If you could, how did you do it, without using any app? I know WebWifiLogin app, but it´s not free and I believe that it´s a way to change the configuration on Asus phone... can I?
    01-12-2016 04:49 AM
  9. KingDonkeyKong's Avatar
    At work we have guest Wifi that requires a username and password. In old Android you could sign on with whatever browser. If you use Chrome it stores your username and password so that you don't have to enter it every time.

    With my new zenfone 2 when I am in range of my work Wifi network the app CapitvePortalLogin keeps pushing the login screen at me. But it NEVER SAVES MY USERNAME AND PASSWORD. So i've got to enter it in again, and again, and again, and again.... and again.

    Is CapitvePortalLogin an android process or a crappy Asus Zenfone process? I can't stop it. Can't change settings. Have to connect through it, and enter my username and password again, and again...
    Hi friend. could you make a way to change the default app that Login at Captive portal? I have a ZenFone2 and it seems to have it´s own captive portal web app that really doesn´t save the user and password. If you could, how did you do it, without using any app? I know WebWifiLogin app, but it´s not free and I believe that it´s a way to change the configuration on Asus phone... can I?
    01-12-2016 04:50 AM
  10. washiGaming's Avatar
    Hi friend. could you make a way to change the default app that Login at Captive portal? I have a ZenFone2 and it seems to have it´s own captive portal web app that really doesn´t save the user and password. If you could, how did you do it, without using any app? I know WebWifiLogin app, but it´s not free and I believe that it´s a way to change the configuration on Asus phone... can I?
    Make sure you do not change the DNS settings to manual as this will stop the automatic redirect.
    01-13-2016 10:40 AM

Similar Threads

  1. Camera waves in light?
    By M3Stang in forum Samsung Galaxy Note 4
    Replies: 11
    Last Post: 10-23-2016, 10:36 PM
  2. Replies: 17
    Last Post: 08-21-2015, 08:59 AM
  3. Why aren't hyperlinks working in group text?
    By califrog310 in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 08-11-2015, 07:18 PM
  4. photos not visible in gallery
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-28-2015, 01:37 PM
  5. How to fix a frozen tablet?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-28-2015, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD