1. AC Question's Avatar
    I have looked on Google repeatedly for an answer to this and have checked out several topics on this web site, none of which have helped me.

    I have a Samsung Galaxy S4. When I had KitKat, I had "Do Not Disturb" mode. It worked fine.

    A few weeks ago, my phone finally received the Lollipop update (specifically, 5.0.1).

    "Do Not Disturb" is still there (and still titled that). I've set it up so only my favorite contacts are exceptions.

    I subscribe to a Twitter account because it gives info on a game series I like, and I have it set up to send me texts immediately for the latest news. For various reasons (including Japanese time difference), this can result in 40 tweets overnight.

    Twitter is NOT one of my favorite contacts (long pressing on the contact still gives me the option to add to favorites), but I'm still getting woken up by tweets from them.

    I've even tried changing my settings in DND to not allow messages, and I still get text message alerts.

    All I can find are either tutorials that talk about this "new feature," or people asking about it only to find out it's called something different on their phone, which isn't my problem.

    I would rather not get a third party app if I don't have to, and I especially don't want to pay for something that's supposed to be on my phone in the first place.

    If anyone else has experienced this bug and knows how to fix it, I would really appreciate the help.
    06-26-2015 10:56 AM
  2. N4Newbie's Avatar
    I don't know about Samsung's Lollipop skin, but stock Lollipop does not have a "Do Not Disturb" mode. It has been replaced by Notifications.

    See https://support.google.com/nexus/answer/6111295?hl=en
    06-26-2015 06:57 PM
  3. Tsunoba's Avatar
    (Sorry for taking so long to reply; the last few weeks were kind of busy).

    I actually do have "Do Not Disturb," rather than "Notifications."

    Why is Do Not Disturb not working since Lollipop?-screenshot_2015-07-10-16-59-35-1-.jpg

    I have gained a new clue, but it doesn't seem to fix the problem: In my settings, I made it so that my phone will repeat the notification sound if I don't acknowledge a text the first time. I've missed texts before without this feature, so I do need to keep it on. This is standard with my phone, not an app.

    It seems to be (haven't tested it for sure, I just happened to notice recently) that while the initial alert is silenced, the little reminder notification is not. This is the one that wakes me up at night.

    While previewing this message, I suddenly noticed that I do have "reminders" allowed through, but since it's linked with Events (I can turn both off, or neither), I assumed it had to do with the calendar, which I did want to keep on in case of a forgotten appointment. I'll ask my sister to send a text later tonight when she's available, and follow up on this.
    whitsey77 likes this.
    07-10-2015 07:15 PM
  4. jerryboomerwang's Avatar
    I am having a similar problem as you described. My Do Not Disturb mode was also fine in the past, but now with later phone models (and Lollipop), it really isn't useful to me anymore. Exceptions doesn't seem to work at all .

    I can't find a solution anywhere online. If anyone knows of a solution, please let us know! Thanks.
    01-30-2016 10:10 PM
  5. Robert Brooks5's Avatar
    Same issue, ever since update the DND works with calls but not with text messages. Only way I can correct it is to not allow exceptions which wont let me use my alarm..
    02-15-2016 12:31 PM
  6. trader4300's Avatar
    My Note4 is having similar problems. Was loving this feature. I could go to bed without anything annoying waking me up. Then all of a sudden I was getting notification sounds about calendar reminders and app updates. How did it start letting these notifications thru? These bugs need to be fixed, otherwise the feature is not working as described
    02-23-2016 06:52 AM
  7. Zellzoy's Avatar
    I am having the same problem but unlike you I: 1. Have no exceptions set up for favorite contacts, 2. Don't have a reminder notification set up if I don't acknowledge the first one, and 3. Have only alarms allowed during DND, not events and reminders. The problem is more recent than updating to lollipop though, I think there was another update since then that did it. I also have a Samsung Galaxy Note Edge that still has the feature and it works fine on it.

    Figured it out (I think): I had messages selected as "Priority" in sounds and notifications → application notifications to get them bumped to the top of the notification queue. Apparently while Samsung still calls it "do not disturb mode" it's still tied to Android's Priority mode.
    03-22-2016 09:04 AM

Similar Threads

  1. Samsung Galaxy Note 3, Lollipop Update?
    By Francis Macdonald in forum Samsung Galaxy Note 3
    Replies: 11
    Last Post: 07-01-2015, 04:59 AM
  2. Replies: 3
    Last Post: 06-29-2015, 02:51 PM
  3. Why isn't my Play Store working on wifi on my Galaxy S3?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 06-29-2015, 12:41 PM
  4. Replies: 1
    Last Post: 06-26-2015, 12:41 PM
  5. Replies: 1
    Last Post: 06-26-2015, 12:17 PM