1. Trudat's Avatar
    About a week ago I upgraded my Nexus 6 32GB to Lollipop and I didn't notice for a while but it seems to have broken the stock Gmail app's sync. The only way for me to get new mail is to manually refresh the inbox from inside the app. I have checked all the account sync settings and everything is enabled. I've also just tried a factory reset as a last resort and my mail still won't sync. The only reliable solution I can find is an app called Force Gmail Sync that does the manual inbox refresh for me. Has anyone else got the same problem? I'm thinking about using a different mail app instead of Google's Gmail app - can anyone recommend one that they know for sure works with Lollipop and supports Gmail push notifications?
    06-26-2015 08:05 PM
  2. omegastu's Avatar
    I am on a Galaxy S4 that was recently upgraded to Lollipop and I am having the same problem. I have waded though all the settings and am having no luck. I found this in the Gmail help forums....

    If you're having some issues with Gmail sync, try some of these techniques to see if you can fix the problem:
    Try Unsyncing your Gmail account temporarily. Try this a few times.
    Settings> Accounts> Google> Select your account> Uncheck Gmail> Check Gmail
    Remove Gmail Account and setup again
    Phone Setting> Accounts> Google> Select your email account> "Remove account"
    Re-establish account.
    Clear your App's cache and data
    Open Phone settings> Select Application manager> Swipe to "All"> Choose Gmail> Clear cache and data
    Decrease the days to sync.
    Open the Gmail app>>Settings>>Select your account>>"Days too sync">>Try limiting it to 30 days or less.
    Make sure that Background data is enabled
    Phone settings> Data Usage> Scroll down to Gmail and make sure that "Restrict background data" is not selected.
    Try Syncing over WIFI only( Airplane mode) or Over your network only.


    I tried all that and it didn't help. I then found this posted in the Gmail help forums....

    I then cleared the cache and data of the "Google Play Services" app, which I'd read had caused similar issues a few months ago. After restarting the phone, apart from an initial sync, Google Inbox still wasn't getting new emails pushed to it so I uninstalled it. I then went back into the Gmail app, which displayed a warning that notifications were turned off, so I turned that back on. I also enabled Gmail sync again (I think the Gmail app warned me about that too, or I could have imagined this - memory like a goldfish, sorry!).

    After I did the second set of steps, I sent myself a test message and got an immediate notification. Time will tell if this works. Good luck.
    06-26-2015 11:02 PM
  3. Trudat's Avatar
    Thanks for all the tips. Unfortunately they didn't help. I'm certain that I've got all the settings right and clearing app data just seems to clobber my privacy settings which is super annoying.

    I have the same problem on both Wi-Fi and data. My Nexus 7 (not upgraded) has no trouble syncing on the exact same networks so I have to assume this is a Google bug. Odd that this hasn't had more publicity because it's a pretty serious fail.

    I've read through most of the forum posts I can find on the topic - if anyone has a new idea I'd love to hear it. In the meantime I'll keep using Force Gmail Sync (which has been a godsend) and wait for a fix from Google. I'm also still interested in other mail clients if anyone can suggest one that "just works" like my Gmail app used to.
    06-27-2015 05:57 PM
  4. Phoneguy108's Avatar
    Note 4 and Galaxy S6 users are also reporting issues with Gmail. I myself periodically do not receive notification of new mail in my Gmail box. I'm running Android 5.0.2
    06-29-2015 01:27 AM
  5. omegastu's Avatar
    By the way, my push notifications are working fine now. I think the clearing cache and data of the Google Play Services fixed it for me.
    Phoneguy108 likes this.
    06-30-2015 07:35 PM
  6. Trudat's Avatar
    That's fantastic omegastu! I'm so jealous. It sounds like you must be in the lucky minority based on all the forum posts I've been reading. Before factory resetting my device I tried clearing the entire cache partition from the special system/boot menu. It managed to blow away ALL my settings but the push sync problem remained.

    Have you also been experiencing the randomly appearing exclamation mark next to your Wi-Fi icon? Mine has been "disconnecting" occasionally (despite showing full reception) but the data connection hasn't been kicking in automatically like it used to, leaving my phone without any internet at all! Apparently this is also related to the Lollipop upgrade. A lot of netizens have been accusing their data service provider but because my un-upgraded Nexus 7 still works on the same networks (and my Nexus 6 pre-upgrade used to work fine on the same networks) I'm ruling that out.
    07-02-2015 04:29 PM
  7. omegastu's Avatar
    I haven't had any wifi problems but i use an app called Smart Wifi Toggler. It may be unnecessary but I got tired of my phone wanting to connect to every wifi signal it came into contact with.

    But as far as the notifications, everything seems to be working fine now for me. I had no problems pre-lollipop so I am fairly certain the issue arose because of the upgrade.
    07-03-2015 11:09 AM
  8. askomsky's Avatar
    Add me to the list with Gmail sync issues.

    I have tried all of the above numerous times and the only one that worked briefly was deleting the account and re-installing it. It stopped working a little while late and i have to manually push the sync through.

    They need to fix this, or allow an option for us to set how often it should auto sync.
    07-07-2015 06:28 AM

Similar Threads

  1. Replies: 37
    Last Post: 07-22-2015, 10:31 PM
  2. Replies: 8
    Last Post: 07-20-2015, 01:53 PM
  3. Kies 3 Outlook Sync
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2015, 08:28 AM
  4. Replies: 1
    Last Post: 06-30-2015, 08:14 AM
  5. Replies: 1
    Last Post: 06-26-2015, 09:10 PM
LINK TO POST COPIED TO CLIPBOARD