1. Jarod Boyd's Avatar
    A couple days ago, I connected to my home WiFi and it connected fine, but I couldn't actually use is, like It was disconnected, but it worked fine with everything else. I tried again with another network and same thing happened. Well, I got the idea to try it in safe mode, and sure enough, the WiFi worked fine with it on. So, is the problem an app I have installed (I tried in uninstalling the apps I downloaded before it started doing this), and if so, is there a way to detect which one it is?
    07-27-2015 08:07 AM
  2. Crashdamage's Avatar
    Yes, if WiFi works in safe mode then the problem must be something you installed. Unfortunately, there's no way to pinpoint the guilty party except common sense and trial and error. For the troubleshooting described below, the phone should be started normally, not in safe mode.

    First, do the obvious thing and go through the app's you've installed and uninstall or Disable anything that uses a data connection. You can skip apps that came on the phone such as the default email app browser, etc. They're not the problem.

    Second, if you have installed any, uninstall ALL task killers, RAM memory optimizers/boosters, battery savers/repairers, cache cleaners, etc etc. None of that stuff is necessary. Such apps are actually counterproductive and some are just plain evil. They actually waste power and disrupt critical system processes and degrade performance. Many are so poorly coded that they cause trouble in unexpected places not even related to the app's actual function so they're potentially guilty of causing WiFi gremlins. You should uninstall these apps even if you don't have a WiFi problem.

    If you still have trouble it gets harder to find the problem. You might try installing System Panel and looking through the process listings, then killing any that have any possible interaction with the WiFi.
    Note: I do NOT advocate killing tasks! But in this case it could be necessary for troubleshooting.

    Of course, if the problem is still not found, there's always the nuclear option - a factory reset. Don't forget to do backups!

    Android since v1.0. Linux since 2001.
    07-27-2015 09:02 AM
  3. Jarod Boyd's Avatar
    Thank you! I found the problematic app, thankfully. It was BTmono, I guess I'll have to find another app like it that doesn't break wifi :/
    Crashdamage and Javier P like this.
    07-27-2015 09:30 AM
  4. Javier P's Avatar
    Thank you! I found the problematic app, thankfully. It was BTmono, I guess I'll have to find another app like it that doesn't break wifi :/
    Hello Jarod, welcome to Android Central! Thanks for the follow up, it will be helpful for other people with the same problem.
    07-27-2015 05:20 PM
  5. Srichandra's Avatar
    Thank you very much. I too had the same problem and found that antivirus app blocked my network
    09-12-2017 11:59 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-29-2015, 08:44 AM
  2. Replies: 0
    Last Post: 07-27-2015, 07:28 AM
  3. Wifi using my tablet in France?
    By floise in forum General Help and How To
    Replies: 1
    Last Post: 07-27-2015, 07:14 AM
  4. How can I block my phone (S5)..it has just been stolen
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-27-2015, 07:09 AM
  5. Replies: 0
    Last Post: 07-27-2015, 06:56 AM
LINK TO POST COPIED TO CLIPBOARD