1. wobstar's Avatar
    Long time reader, first time posting

    Sorry if this is not the right category, I have been looking to find one better suited to post this subject but couldn't find one.
    As stated above, I'm having issues with controlling music from my Bluetooth headset. I've already done some troubleshooting but am currently at a loss and hope to find some help here.

    Let me first describe the problem first:
    When I connect my Bluetooth headset (Philips SHB7150) to my Xperia Z3 tablet compact I can not control my music. If I start playing music from the app, it plays fine through the headset but I don't have control. This used to work before, unfortunately I can't pinpoint when the issue started but it's possible it happened after upgrading from Lollipop 5.0.2 to 5.1.1.

    Now on to my troubleshooting results:
    - When I turn off the BT headset and turn it back on, it connects to the tablet without hassle but I have no music controls.
    - When I turn off the tablet and turn it back on, it connects to the BT headset without hassle but I have no music controls.
    - When I pair the headset again using NFC, it connects to the tablet and I have music control
    - When I turn off BT on the tablet and turn it back on it connects to the BT headset and I have music control
    - When I connect the BT headset to the tablet and go into BT settings, open the settings for the BT headset + uncheck 'media' + confirm + check 'media' + confirm and I have music control
    - When the tablet connects to BT in my car, it starts playing after the play command from the receiver.
    - In these last 4 cases, the solution is only good until next time the BT headset is turned off and connects again. Then there is no music control until I repeat one of those 4 steps.

    Things I have tried:
    - Use another application to play my music (stock Xperia music app, Google music, Rocket Player, Shuttle+, ... are all experiencing the same issue. So I don't think it is due to the music playing software
    - Tried an application (headset button controller) to try and change the button behaviour but it does not receive the command from the headset (no beep)
    - Connect my BT headset to another device (Sony Xperia S, MacBook Air) and it works fine (both after pairing and after turning BT headset off and on again)
    - Factory reset my tablet using Sony Bridge for Mac -included wipe of internal data-, still the same issue.
    - I tried to find some ADB command to reset everything BT, but all I could accomplish was using the command to start BT (due to lack of knowledge on ADB commands)
    - I deleted all app data and cache for 'Bluetooth sharing' in application manager + restarted and connected again (no success)
    - I re-paired the headset once more but this time without adding it as a smart-lock unlocking device but had no luck controlling music when I connected it again

    To conclude:
    The headset is working fine with other devices, I can't pinpoint if this is a software/hardware issue because it appears to be only for this BT headset/laptop combination and with all music software AND continues after factory reset...
    Other BT devices (=car stereo, I don't have another BT headset to test with) are working fine to control music on my tablet
    Restarting BT on the tablet or re-autoring the use of media in BT settings on the tablet permanently resolves the issue until the next time the headset is connected.
    So it looks like either something hijacks my device as soon as it connects to the tablet OR the media-authorization gets revoked in the BT settings for that device. Perhaps I'm saying stupid things, but I'm really hoping that you, the more knowledgeable Android developer/enthousiast/... would be able to make more sense and to give me a hand in order to fix this issue.
    I currently am dependent on my tablet for playing music during my daily train commutes since my beloved Xperia Z1 Compact is in for warranty repairs

    ANY help would be appreciated !
    08-28-2015 07:05 AM

Similar Threads

  1. Replies: 2
    Last Post: 10-18-2015, 08:53 PM
  2. Linux tools to root LG G3 Lollipop?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-27-2015, 09:05 PM
  3. Replies: 1
    Last Post: 08-27-2015, 08:36 PM
  4. lollipop
    By 8taylor8 in forum Samsung Galaxy S6
    Replies: 2
    Last Post: 08-27-2015, 08:00 PM
  5. Replies: 1
    Last Post: 08-27-2015, 06:51 PM