1. Snappy Phoenix's Avatar
    I just did a factory restore on my Samsung Galaxy S6 edge+, signed in with my Google Account but not with the Samsung account.

    When I go to the Play Store, I see many updates are available, I tried updating them all at once but they all fail. Then I tried one by one and they also fail. I tried with both my WIFI connection at home and using the cellular data only but no luck.

    Any help?

    PS: This phone is not and was never rooted.

    Example of the error message:

    update for "android system webview" could not be downloaded due to an error. (Error retrieving information from server [RPC:S-7:AEC-7 DQCU-QSXS-ONF6K])
    10-02-2015 10:01 AM
  2. Snappy Phoenix's Avatar
    Just did another factory reset but this time I signed in with my Samsung account and the apps are downloading fine.
    10-02-2015 11:39 AM

Similar Threads

  1. I have a S5 Sport and running CM 11 why can't I download CM 12
    By theoneanronly in forum LineageOS (formerly Cyanogen)
    Replies: 3
    Last Post: 10-12-2015, 09:58 AM
  2. Replies: 0
    Last Post: 10-02-2015, 09:54 AM
  3. Looking for an app that will read SMS aloud
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2015, 09:53 AM
  4. Anyone know where I can download the S5 Sport Stock ROM?
    By theoneanronly in forum Ask a Question
    Replies: 0
    Last Post: 10-02-2015, 09:43 AM
  5. Has anyone else's phone died after updating to the new Android OS?
    By AC Question in forum Android 6.0 Marshmallow
    Replies: 0
    Last Post: 10-02-2015, 09:41 AM