1. AC Question's Avatar
    I just buy new android one phone running android lolipop version 5.1.1
    My old phone running ice cream sandwich.
    With my old phone when I plug my phone usb to pc I just choose usb storage and I can move or copy my files between phone & pc.
    Now with lolipop the choice are mtp, ptp, and cdrom.
    i have tried all 3 choice with no success.
    My phone simply not show in windows explorer ( I use Win XP)
    Please help

    Thank you
    10-11-2015 09:36 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone do you have? Check the manufacturer's website to see if they have the latest USB driver to install on your computer. You can also use a wireless solution like AirDroid or Wi-fi File Explorer.

    As a side note, you should really consider upgrading to a more recent version of Windows. Microsoft no longer supports XP, so that leaves you vulnerable to more malware attacks.
    10-11-2015 06:14 PM
  3. xynd's Avatar
    My phone is infinix x510.
    It's android one so it runs stock android lollipop 5.1.1
    10-12-2015 06:58 AM
  4. N4Newbie's Avatar
    Personally, I think the easiest way to move one or thousands of files from phone to desktop PC is to install the free version of Airdroid ( https://play.google.com/store/apps/d....sand.airdroid ) on your phone.

    Start up the Airdroid app and it will give you an IP address. On your desktop PC, open any browser and point it to that IP address. Back on the phone, tap to accept the connection.
    B. Diddy likes this.
    10-12-2015 10:11 AM
  5. xynd's Avatar
    So basically Airdroid use both pc and phone internet connection?
    10-12-2015 04:25 PM
  6. B. Diddy's Avatar
    Airdroid uses your home wi-fi connection. Wi-fi File Explorer works the same way.
    10-12-2015 07:18 PM
  7. xynd's Avatar
    Thats the problem. I don't have Wi-fi at home. So if I use airdroid I use both my home and phone connection?
    Something like airdroid where I can control my phone from pc just by plugging usb cable would be perfect.
    10-13-2015 07:06 AM
  8. B. Diddy's Avatar
    Have you already tried a different cable? USB cables can fail, so it's worth trying different ones. Also try different USB ports on the computer.

    See if you can transfer via Bluetooth: http://forums.androidcentral.com/sam...ml#post4472646
    10-13-2015 11:41 AM
  9. xynd's Avatar
    Nothing to do with cable.
    The problem lies with lollipop as I have no problem with ice cream sandwich.
    10-13-2015 01:14 PM
  10. B. Diddy's Avatar
    Hmm. The problem may be more with XP, and how outdated it is. In any case, are you able to try the Bluetooth solution?
    10-13-2015 02:22 PM
  11. xynd's Avatar
    You maybe right the problem may lies in XP.
    I'll try looking for driver
    B. Diddy likes this.
    10-14-2015 06:45 AM
  12. Numitor's Avatar
    I have the exact same problem, but It's on XP Home, XP Media, Vista, and three different Win7 machines. This is trying about 5 different USB cables. I can't find anywhere in the droid settings that has anything to do with USB other than tethering, and that's asking the phone to be the host to a device, not be a device to the host computer. I doubt the problem is XP related.
    02-23-2016 03:07 PM
  13. SnowyRa1n's Avatar
    Here is a driver for your phone - gsmusbdriver.com/infinix-x510
    02-23-2016 10:29 PM

Similar Threads

  1. FYI: ES File Explorer Chromecast
    By dianehelen in forum Google Chromecast
    Replies: 5
    Last Post: 10-14-2015, 07:59 AM
  2. How can I fix the Google servers error?
    By AC Question in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 10-11-2015, 06:20 PM
  3. Replies: 2
    Last Post: 10-11-2015, 09:59 AM
  4. Replies: 1
    Last Post: 10-11-2015, 09:41 AM
  5. Replies: 0
    Last Post: 10-11-2015, 08:47 AM
LINK TO POST COPIED TO CLIPBOARD