1. AndyWoolford's Avatar
    I have just bought a brand-new CTRONIQ SNOOK C70R with Android 5.1 Lollipop, as present for my young cousin. It came with facebook pre-installed. It downloads and installs other apps just fine from Google Play store, but it refuses to install Messenger. I tried uninstalling the stock Facebook app, and now it won't install Facebook either.

    It downloads fine, but installation fails with "Unknown error -505". I have tried clearing data and caches from Google Play and Google Play Services. I have tried Recovery mode and cleared the Cache partition and rebooted. I also removed the google user account and reinstalled, still no luck.

    As a last resort, I tried sideloading the current facebook apk (and a few earlier versions) from apkmirror.com but installation still fails with the simple message "Application not installed". I also cleared and restarted Download manager.

    This does not look like a google play error, but an error with the apk itself as it is ONLY these two facebook apps which are failing to install. I am lost as to why this is happening.

    Any help would be appreciated.
    11-07-2015 05:10 AM
  2. Golfdriver97's Avatar
    It might be a server error. Have you tried installing through WiFi?
    11-07-2015 08:10 AM

Similar Threads

  1. Problems with Twitter App on Samsung Galaxy Tab 10.1
    By mawallace in forum Samsung Galaxy Note 10.1
    Replies: 2
    Last Post: 11-30-2015, 05:51 PM
  2. System apps keep reappearing after being deleted
    By gcdedf114 in forum Samsung Galaxy S6
    Replies: 4
    Last Post: 11-08-2015, 08:21 AM
  3. Replies: 1
    Last Post: 11-07-2015, 07:57 AM
  4. Problems with Twitter App on Samsung Galaxy Tab 10.1
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-07-2015, 03:59 AM