1. Solo88's Avatar
    So ever since several months ago I noticed that whenever I added a google account (from the gmail app) it adds a google account that automatically syncs EVERYTHING without giving me the option to first decide what gets sync'd like before. I can't believe a huge company wih billions could be that dumb to all of a sudden leave that out for those of us with separate google accounts.
    It does not work to go back into settings and de-sync everything except gmail. All the contacts from the separate google account will get downloaded immediately into my phone and the only way to delete them would be to remove the account.
    I tried adding a gmail (imap) account and it can't even connect to the server with the default settings.
    I tried to first un-check the "auto-sync" setting in accounts and while it worked when adding my 2nd gmail account from adding contacts automatically there was no way to sync gmail without syncing EVERYTHING again. Before, I used to be able to add 1, 2, or more google accounts and before signing in have a list of things I wanted to sync before they were sync'd. Any ideas on a work around for this? I don't want to only show contacts for a certain account. I just want to avoid syncing anything except gmail.
    I just can't believe google is foolish enough to ruin a perfectly efficient process of adding different accounts in a customizable way like it used to be with early kitkat and jellybean. It's becoming increasingly frustrating since it's something that hasn't changed in many months.
    Any help would be greatly appreciated by me and many others who seem to be having the same problem without a clear solution. Thank you!
    12-15-2015 08:38 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Sorry for the frustration. What device do you have? I'm wondering why you're having difficulty adding the Gmail account to your stock Email app, because that would be the ideal solution.
    Laura Knotek likes this.
    12-15-2015 11:31 PM
  3. Solo88's Avatar
    Thanks for the reply, B Diddy. I use the Droid Turbo 2 as of yesterday but was using the Droid Turbo and Droid Maxx before that. 6 months into my Turbo 1 ownership android lost this ability. It was perfect before then. I would add a good account and before it would even try to sync anything it would give me a checklist of things I would like to sync. I would only check gmail and bam, perfect. Now, they removed it! Any ideas on the workaround other than unchecking contact syncing after the fact amd manually deleting many contacts?
    12-16-2015 08:04 AM
  4. Crashdamage's Avatar
    Am I correct that you're saying that there is no page for choosing sync items at:
    Settings > Accounts > Google > Select your account > Sync
    ..like this or similar:

    12-16-2015 11:29 AM
  5. Solo88's Avatar
    No actually there IS a screen like that the problem is that screen doesn't show up when adding any google accounts like before. I add an account, it syncs things I don't want, then when I go to that page to turn off the syncs they have already been sync'd and I can't remove the information! See before you could add a google account then it would give you that screen to sync whatever you wanted. Now, it just syncs everything first! Why would google do something dumb like that? It makes zero sense. It syncs everything without even giving you the option to choose what you want sync'd. It worked perfectly in previous android versions.
    Crashdamage likes this.
    12-16-2015 11:59 AM
  6. B. Diddy's Avatar
    Let's back up a bit and talk about adding your Gmail account to the stock Email app. What happens exactly when you try to add it? Do you get an error message? Does it go through an automatic process of adding your Gmail account, or do you have to manually enter the IMAP settings?
    12-16-2015 08:24 PM
  7. Solo88's Avatar
    Actually it runs smoothly when I try to add a google account. When I try to add an IMAP gmail account it says it has an error connecting to gmail. Would adding an IMAP gmail account prevent it from automatically syncing the contacts from that particular google account? When I tried adding an IMAP gmail accout all the settings (port, server) were already there. When I input my gmail info for my 2nd google account it tries to connect then in red letters says "Couldn't open connection to server". The server in the settings is "gmail.com". So that's strange too?
    I usually just go to gmail, settings, add account, and add an account that way. Unfortunately there is no longer a way to check the boxes of what I want sync'd BEFORE it actually syncs it. Very weird and strange for google to change that.
    12-17-2015 08:29 PM
  8. Solo88's Avatar
    LOL This is so stupid. I went into my gmail app, clicked on my gmail account I already had there and from the dropdown clicked on "add account". I hadn't tried it this way. Well, I figured if I added a GMAIL account only it wouldn't sync the contacts into my phone. It sync'd the contacts again! wtf? I added a gmail account NOT a whole google account so why would it automatically sync these contacts when I do NOT want them on my phone?
    Sonu K likes this.
    12-17-2015 08:49 PM
  9. Solo88's Avatar
    The only way I can think of to force google to NOT sync my contacts is by backing up the contacts online then deleting them. Then adding the google account to my phone, won't sync contacts because there aren't any, then restore the contacts online after I turn off the contact sync on my phone. It turns out Google really IS that stupid to not figure out how to re-add the syncing options BEFORE adding an account to your phone.
    12-17-2015 10:23 PM
  10. B. Diddy's Avatar
    When I try to add an IMAP gmail account it says it has an error connecting to gmail. Would adding an IMAP gmail account prevent it from automatically syncing the contacts from that particular google account? When I tried adding an IMAP gmail accout all the settings (port, server) were already there. When I input my gmail info for my 2nd google account it tries to connect then in red letters says "Couldn't open connection to server". The server in the settings is "gmail.com". So that's strange too?
    Adding a Gmail account to the stock Email app shouldn't sync your contacts--I just tried it on the stock Email app of my ZenFone 2. When you try to add your 2nd Gmail account to the stock Email app, does it give you an automated option to add a Gmail account? Also, is this Google account secured with 2-step authentication? If it is, turn that off temporarily, then try to add the account again to the Email app.
    12-18-2015 12:28 AM
  11. Solo88's Avatar
    B. Diddy, when I go to settings, accounts, add account, there is a list of options of types of accounts. Is the stock email app the one that says "Email" or "corporate"? There is a choice for Google and Personal (IMAP and POP3). If I choose "Email", the choices are AOL, Corporate, Verizon.net, Outlook, Yahoo, Other providers, and Gmail........but if I try Gmail it says "You cannot setup Gmail here. Use the Gmail app to add your account.
    The problem is if I use the gmail app and go to "add account" from gmail it wants to add a gmail account as a full google account not just gmail by itself (without syncing contacts). Is there a step I'm missing? It used to be super easy--add any google account and choose what you wanted to sync BEFORE it synced it automatically. Now it feels like jumping through hoops. Thanks for your help!
    12-18-2015 01:04 AM
  12. Solo88's Avatar
    Adding a Gmail account to the stock Email app shouldn't sync your contacts--I just tried it on the stock Email app of my ZenFone 2. When you try to add your 2nd Gmail account to the stock Email app, does it give you an automated option to add a Gmail account? Also, is this Google account secured with 2-step authentication? If it is, turn that off temporarily, then try to add the account again to the Email app.
    B. Diddy, when I go to settings, accounts, add account, there is a list of options of types of accounts. Is the stock email app the one that says "Email" or "corporate"? There is a choice for Google and Personal (IMAP and POP3). If I choose "Email", the choices are AOL, Corporate, Verizon.net, Outlook, Yahoo, Other providers, and Gmail........but if I try Gmail it says "You cannot setup Gmail here. Use the Gmail app to add your account.
    The problem is if I use the gmail app and go to "add account" from gmail it wants to add a gmail account as a full google account not just gmail by itself (without syncing contacts). Is there a step I'm missing? It used to be super easy--add any google account and choose what you wanted to sync BEFORE it synced it automatically. Now it feels like jumping through hoops. Thanks for your help!
    12-18-2015 01:05 AM
  13. Solo88's Avatar
    I FINALLY figured out a workaround!

    The problem is you can't choose what to sync until AFTER it already synced everything to your phone on any google account you're adding. Obviously by then it defeats the purpose since it's already done.
    Disabling the "auto-sync" box works in that you could add a gmail account and it won't sync anything. The problem with that is when you go into the list of things you want synced you can't choose anything! It's an all-or-none deal. You have to turn on the auto-sync box from the accounts page in your setting THEN it allows you to pick what you want synced. Well, here is the fix:
    Disable auto-sync from the accounts page in settings. Then add all the google accounts you want. Once they are added nothing is getting synced of course since it's disabled. What you do then is turn OFF all data. In fact, turn off all data and put it in airplane mode just to be sure you disabled ANY data transfer. Once data is disabled return to the accounts page in settings and re-enable "auto-sync". Nothing will be synced but the check boxes in the list of what you want synced will reappear! Finally! Simply un-check anything you don't want synced (in my case I only wanted gmail to sync) then turn on data and turn off airplane mode. Voila! Works perfectly.
    Since google screwed this up in their latest versions of lollipop you have to force android to not sync what you don't want to.
    Thanks very much for your replies B. Diddy I hope this thread helps many others! Years ago others were running into the same problem. Take care!

    Posted via the Android Central App
    12-18-2015 01:40 AM
  14. M3Rocket's Avatar
    My wife's S6 Edge was just updated to Marshmallow (finally) and I ran into this problem! I have apps that were purchased under my account from years ago, and that's the only thing we need installed on her phone. But every time I delete and create an account, it auto-syncs everything! And it is a waste of memory! I just need the apps for the account to sync and nothing else. I tried your workaround, but even with Auto-Sync off, as soon as I add the account it seems to sync everything? [Edit: Got your workaround to work. I restarted the phone after turning Auto-Sync Off. Then I turned off Wi-Fi so that if it started syncing, it would be a lot slower. Thanx for the workaround!]

    I really need a workaround. This used to be so trivial in Kit-Kat. When adding a new account, you get to choose right away what you want to sync. Why was this removed???

    I FINALLY figured out a workaround!

    The problem is you can't choose what to sync until AFTER it already synced everything to your phone on any google account you're adding. Obviously by then it defeats the purpose since it's already done.
    Disabling the "auto-sync" box works in that you could add a gmail account and it won't sync anything. The problem with that is when you go into the list of things you want synced you can't choose anything! It's an all-or-none deal. You have to turn on the auto-sync box from the accounts page in your setting THEN it allows you to pick what you want synced. Well, here is the fix:
    Disable auto-sync from the accounts page in settings. Then add all the google accounts you want. Once they are added nothing is getting synced of course since it's disabled. What you do then is turn OFF all data. In fact, turn off all data and put it in airplane mode just to be sure you disabled ANY data transfer. Once data is disabled return to the accounts page in settings and re-enable "auto-sync". Nothing will be synced but the check boxes in the list of what you want synced will reappear! Finally! Simply un-check anything you don't want synced (in my case I only wanted gmail to sync) then turn on data and turn off airplane mode. Voila! Works perfectly.
    Since google screwed this up in their latest versions of lollipop you have to force android to not sync what you don't want to.
    Thanks very much for your replies B. Diddy I hope this thread helps many others! Years ago others were running into the same problem. Take care!

    Posted via the Android Central App
    06-08-2016 01:50 AM
  15. vijayetc's Avatar
    I FINALLY figured out a workaround!

    The problem is you can't choose what to sync until AFTER it already synced everything to your phone on any google account you're adding. Obviously by then it defeats the purpose since it's already done.
    Disabling the "auto-sync" box works in that you could add a gmail account and it won't sync anything. The problem with that is when you go into the list of things you want synced you can't choose anything! It's an all-or-none deal. You have to turn on the auto-sync box from the accounts page in your setting THEN it allows you to pick what you want synced. Well, here is the fix:
    Disable auto-sync from the accounts page in settings. Then add all the google accounts you want. Once they are added nothing is getting synced of course since it's disabled. What you do then is turn OFF all data. In fact, turn off all data and put it in airplane mode just to be sure you disabled ANY data transfer. Once data is disabled return to the accounts page in settings and re-enable "auto-sync". Nothing will be synced but the check boxes in the list of what you want synced will reappear! Finally! Simply un-check anything you don't want synced (in my case I only wanted gmail to sync) then turn on data and turn off airplane mode. Voila! Works perfectly.
    Since google screwed this up in their latest versions of lollipop you have to force android to not sync what you don't want to.
    Thanks very much for your replies B. Diddy I hope this thread helps many others! Years ago others were running into the same problem. Take care!

    Posted via the Android Central App
    Can't thanks you enough for this workaround!!
    Solo88 likes this.
    06-09-2016 04:21 PM
  16. plaidsportcoat's Avatar
    Nope. It did not work for me. Instead, following your advice caused me to lose all my contacts. And when I tried to add a new contact after following your steps, I was still told that my contact would be synced with the gmail account I entered while autosync was disabled. I tried several times - just to make sure I was following your steps correctly. I was. So it overrides my choice of not syncing Contacts whether I like it or not.
    If anyone has another idea, I'd like to know what it is. I have read on several fora that the current version of Android now takes away your ability to not sync one's Contacts with google. I think they may be correct. I hope they are not. I don't want to do developer level tweaking to my phone, like most people don't. Here's a business opportunity for someone? Lots of folks would not like to share their contact list with Google.
    06-26-2016 03:07 PM
  17. plaidsportcoat's Avatar
    By the way, in case it's germane:
    I have a Moto G 3rd Gen, bought in June 2016 as a "bring your own phone".
    I have T-Mobile with Android 6.0 also bought in June 2016.

    Thanks!
    06-26-2016 03:09 PM
  18. Solo88's Avatar
    That makes no sense. You are not touching your contacts nor manipulating anything that has to do with the contacts on your google account or phone. All you are doing is stopping any of your information from getting synced from the google cloud onto your phone while getting the phone to allow the checkboxes of what you want synced to be enabled. You must've done something different because you aren't even touching the google cloud at all so your contacts aren't even disturbed with this method.

    You have to be sure you first disable auto-sync then add the google account. Then, without touching anything else disable data AND put the phone into airplane mode (to ensure absolutely no data from your google cloud is transferred to your phone). As you can see, you're only stopping your contacts (which are stored on the cloud) from coming onto your phone but the contacts are still there. They are not touched at all. Then you simply check the boxes of what you want synced (including contacts if that's what you want) and THEN your contacts will come into your phone from the cloud. Contacts being deleted are a totally separate issue and there may be something else going on with your account or phone. Be sure your contacts are stored on THAT google account. Many people are surprised to see many contacts deleted because they never were synced to their google account in the first place. Usually they are only stored on the phone or even sim card which can be deleted if you restore or mess with the phones memory. If your contacts were on your google account they will still be there using my method. I've tried it on several phones and it works fine.
    07-03-2016 12:42 AM
  19. SADIE127's Avatar
    thank you this worked been trying to do this for months
    07-05-2016 07:17 AM
  20. yhbrooklyn's Avatar
    Bless you for this! It's been driving me nuts forever.
    12-02-2016 10:14 AM
  21. ram216's Avatar
    I FINALLY figured out a workaround!

    The problem is you can't choose what to sync until AFTER it already synced everything to your phone on any google account you're adding. Obviously by then it defeats the purpose since it's already done.
    Disabling the "auto-sync" box works in that you could add a gmail account and it won't sync anything. The problem with that is when you go into the list of things you want synced you can't choose anything! It's an all-or-none deal. You have to turn on the auto-sync box from the accounts page in your setting THEN it allows you to pick what you want synced. Well, here is the fix:
    Disable auto-sync from the accounts page in settings. Then add all the google accounts you want. Once they are added nothing is getting synced of course since it's disabled. What you do then is turn OFF all data. In fact, turn off all data and put it in airplane mode just to be sure you disabled ANY data transfer. Once data is disabled return to the accounts page in settings and re-enable "auto-sync". Nothing will be synced but the check boxes in the list of what you want synced will reappear! Finally! Simply un-check anything you don't want synced (in my case I only wanted gmail to sync) then turn on data and turn off airplane mode. Voila! Works perfectly.
    Since google screwed this up in their latest versions of lollipop you have to force android to not sync what you don't want to.
    Thanks very much for your replies B. Diddy I hope this thread helps many others! Years ago others were running into the same problem. Take care!

    Posted via the Android Central App
    Thank you so much! I was struggling with this from a long time, and your solution have worked great!
    12-15-2017 08:25 AM

Similar Threads

  1. I was trying to root my Samsung note 10.1 GT- N8013 and the screen is struck on downloading
    By AC Question in forum Samsung Galaxy Note 10.1 Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 12-18-2015, 08:58 AM
  2. how do I get the video calling
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-16-2015, 02:31 AM
  3. Why does my Tab S 10.5 fail to charge?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-15-2015, 10:55 PM
  4. how do I get the video calling
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-15-2015, 10:52 PM
  5. Replies: 1
    Last Post: 12-15-2015, 08:02 PM
LINK TO POST COPIED TO CLIPBOARD