1. harslanhafeez's Avatar
    Hi Everyone,

    I have Huawei Ascend G7 having Lollipop 5.0 android version. Everything was going well. Accidently I dropped some water on mobile, I quickly dry it out and check everything was working but phone was not charging.
    I tried everything other charging cable, charger, charging with laptop but still not charging. Now I shut it down and now its charging but while power on I tried everything(rebooting,clearing cache, clearing junk,phone accelerator, battery safe mode) it does not charging.
    Only while mobile is powered off it is charging.
    It seems some software issue, what should I do?
    Thanks
    05-22-2017 09:37 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did any of that water get into the USB port? It doesn't take much to make it malfunction. You may have to get the USB port replaced.
    05-23-2017 02:15 PM
  3. harslanhafeez's Avatar
    Thanks for reply. I'm not sure about water get into usb port. It wasn't enough water. But Why it is charging when phone is powered off. and not charging when it is power on.

    Even some times I attach charging cable and reboot the phone it start charging when phone starts turning on and keeps on charging until I detach power cable. But for second time, when I re-attach charger it does not charge.

    It seems some software issue?
    05-24-2017 04:25 AM
  4. harslanhafeez's Avatar
    Can someone please help how can I fix this software issue?
    05-24-2017 02:20 PM
  5. B. Diddy's Avatar
    Does this happen in Safe Mode as well? How to turn on safe mode on Huawei Ascend G7
    05-25-2017 08:34 PM
  6. harslanhafeez's Avatar
    Yes, check on safe mode. Same behaviour.
    05-31-2017 12:22 PM
  7. B. Diddy's Avatar
    I think your options at this point are to look into reinstalling the firmware, or taking it to a repair shop to see if the port needs to be replaced. I'm not sure how easy or hard it is to reinstall the firmware -- check the forums at xda-developers.com, which is a good resource for this kind of thing.
    06-03-2017 01:41 PM
  8. harslanhafeez's Avatar
    Upgraded firmware to Android 6.0.1. But Same result. I think now I have to replace charging port. :|
    06-06-2017 07:48 AM
  9. B. Diddy's Avatar
    Yes, I think that's unfortunately the next step. Let us know how it turns out!
    06-06-2017 10:55 AM

Similar Threads

  1. Verizon Galaxy S8 [HELP] Wifi Issues on S8 (internet may not be available)
    By J_Five in forum Samsung Galaxy S8 & S8+
    Replies: 17
    Last Post: 07-15-2017, 03:10 PM
  2. Block Phone Number Wild Card
    By hockey9592 in forum Samsung Galaxy S7
    Replies: 2
    Last Post: 05-23-2017, 09:00 PM
  3. my phone Samsung note5 locked how can i open
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 2
    Last Post: 05-23-2017, 06:48 PM
  4. Why is the Google Play Music stream sound not clear?
    By tech_fan in forum Samsung Galaxy S8 & S8+
    Replies: 5
    Last Post: 05-23-2017, 10:03 AM
  5. Replies: 0
    Last Post: 05-22-2017, 09:09 PM
LINK TO POST COPIED TO CLIPBOARD