1. amitkatti's Avatar
    I tried to follow the instructions given on google's website. Downloaded the factory image, unzipped files and folders as told. The OEM is unlocked.

    When I ran the flash-all script, I got the following messages.

    target reported max download size of 518205818 bytes
    sending 'bootloader' (2898 KB)...
    OKAY [ 0.215s]
    writing 'bootloader'...
    (bootloader) Device State : Unlocked
    (bootloader) zip header checking...
    (bootloader) shift signature_size for header checking...
    (bootloader) zip info parsing...
    (bootloader) checking model ID...
    (bootloader) start image[hboot] unzipping for pre-update check...
    (bootloader) start image[bct] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[mts_preboot_prod] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[mts_prod] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[hboot] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[nvtboot] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[nvtbootwb0] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[tos] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[sp1] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[gp1] unzipping & flashing...
    (bootloader) ...... Successful
    (bootloader) start image[pt] unzipping & flashing...
    (bootloader) ...... Successful
    OKAY [ 5.518s]
    finished. total time: 5.734s
    rebooting into bootloader...
    OKAY [ 0.031s]
    finished. total time: 0.031s
    archive does not contain 'boot.sig'
    archive does not contain 'recovery.sig'
    failed to allocate -1995847632 bytes
    error: update package missing system.img

    After this, I cannot use my OS. Tried going into recovery, still does not help.

    The only screen that is accessible is the Bootloader screen.

    Device State is now unlocked.
    10-06-2015 01:23 PM
  2. matthew2926's Avatar
    I have never flashed any Android systems, but I know that this is a very common and can be fixed by manually flashing each individual file using commands in the Android sdk rather than running the flashall script.
    10-06-2015 11:07 PM
  3. TheStratMan's Avatar
    You need to update your SDK. They fixed the missing system.img error in rev. 23 several months ago.
    10-09-2015 02:04 PM

Similar Threads

  1. How is themer able to be free? Does it read information from my phone?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 12-08-2016, 02:58 PM
  2. Huawei software in the Moto X Style's body? How?
    By OneOffCharlie74 in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2015, 04:14 PM
  3. Who has pre-ordered the Nexus 6p?
    By bpe4 in forum Moto X Pure Edition
    Replies: 5
    Last Post: 10-06-2015, 03:00 PM
  4. October Security Update OTAs -- Project Fi & T-Mobile
    By quelquehomme in forum Google Nexus 6
    Replies: 0
    Last Post: 10-06-2015, 01:19 PM
  5. Why I can't download from the Play Store to my phone Sony ?
    By AC Question in forum Google Play Store
    Replies: 1
    Last Post: 10-06-2015, 01:18 PM