1. spud101's Avatar
    Last weekend I upgraded my Nexus 5 to Android 6. Looks like a minor upgrade from the outside but some nice under the hood changes and impressive battery life improvement.

    2 issues however:
    - A minor one: Phone doesn't detect well enough anymore when I take the phone from my ear, i.e. screen stays off some of the times

    - Big issue: I use two Exchange accounts. In Lollipop I could lookup contact details in the Exchange Global Address List (GAL) both in the dialer and contacts app. I.e. these contacts I don't have in my private contacts, but are in the overall enterprise address book (not synced to phone, just queried). This does not seem to work anymore in Android 6???!!

    Am I doing something wrong, does it require an additional setting? Anyone has any ideas?

    Thanks!!!
    10-12-2015 01:45 PM
  2. Lee_Bo's Avatar
    Same issue here on Nexus 6 running 6.0. GAL works fine on Nexus 5 running 5.1.1. I've looked at all the permissions and it doesn't appear to be a permissions issue.

    I guess we're one of the few who use their Android device for work.
    10-16-2015 11:07 AM
  3. spud101's Avatar
    Yes, still nobody else with the same issue, or even better, a solution Is there a way to verify with Google themselves?
    10-19-2015 10:59 AM
  4. N4Newbie's Avatar
    What email app are you using for your Exchange accounts?
    10-19-2015 12:29 PM
  5. spud101's Avatar
    It's not just email. I and I assume Lee_Bo as well make use of the Android built in Exchange functionality. In Android 5 an exchange account also searched for contacts in the GAL when typing in contacts in the Dialer, Contacts and I guess Gmail app (never tried it in gmail myself). And now in Android 6 these apps only search in the Contacts you have explicitly added to your personal contacts in Exchange.
    10-20-2015 02:54 PM
  6. bbgolf's Avatar
    I use Nine for my work Exchange account and don't have issues with searching against the GAL from the dialler, contacts, composing an email. I removed the account from Nine and added it to Gmail and experienced the same problem as you. I am using a Nexus 5 with Marshmallow.
    10-20-2015 06:57 PM
  7. Lee_Bo's Avatar
    I'm using the Gmail app for my personal and work emails. I also have two Nexus 6 devices, one with 5.1.1 and one with 6.0. GAL works fine on 5.1.1 and not on 6.0.

    UPDATE 10/22/15
    Seems to be a Gmail app issue. GAL is working with other apps, just not with Gmail.
    10-21-2015 07:59 PM
  8. cowpen's Avatar
    I kinda hate the way the Gmail app looks and works. But I'm having no luck adding my Exchange account to the "Email" app as an alternative. Nothing's working, and if I try manual setup I'm only offered POP or IMAP - no EAS. Does the email app still support EAS? I chose "Corporate" when starting from settings / accounts.
    10-23-2015 05:58 PM
  9. Lee_Bo's Avatar
    I did install the Outlook app, for testing, and GAL works, so this looks to be a Gmail app issue in 6.0.
    10-24-2015 08:22 AM
  10. spud101's Avatar
    No it's not just gmail. It doesn't work with Dialer and Contacts either. I assume the Outlook app installs its own Exchange account for mail & contacts and I guess this account gives you the GAL access, maybe even in Dialer and Contacts app.

    I'm not allowed for my office mail to use the Outlook app as it saves all mail in the cloud.
    10-24-2015 02:41 PM
  11. N4Newbie's Avatar
    No it's not just gmail. It doesn't work with Dialer and Contacts either. I assume the Outlook app installs its own Exchange account for mail & contacts and I guess this account gives you the GAL access, maybe even in Dialer and Contacts app.

    I'm not allowed for my office mail to use the Outlook app as it saves all mail in the cloud.
    One of the many reasons that I use Nine for my work Exchange account.

    And, I don't know if that has anything to do with it, but I can search the GAL using the phone app just fine (Nexus 6, Android 6.0).
    10-24-2015 05:05 PM
  12. spud101's Avatar
    Yes, That's because Nine implements its own Exchange account and does not use the default Android one.

    The issue we face has been reported to Google BTW (can't post links yet): code . google . com / p / android / issues / detail?
    id=189195&q=GAL&colspec=ID%20Type%20Status%20Owner%20Summary%20Stars
    10-26-2015 10:18 AM
  13. KGTG's Avatar
    FYI: This has been resolved with 6.0.1
    All you need to do after you have 6.0.1 is to remove and re-add your Exchange account. (no reboot required)
    On my N6P, I did this and GAL lookup works in the gmail app again. Yay!
    Here is a Googler's response on the Issue Tracker page:

    Hi again all,
    As some of you may have noticed, we released a fix for this issue in 6.0.1. If you are still experiencing the problematic behavior with GAL lookup, removing and readding the Exchange account should resolve the issue and restore the intended behavior.

    Please be sure that you finish sending any locally-saved drafts before doing this, as you will lose them upon deleting the account.

    I apologize for the pain and inconvenience this issue has caused. Please continue to leave feedback here as it is helpful for our team.
    01-16-2016 11:38 AM
  14. DGrand's Avatar
    I've updated my galaxy s6.edge to 6.0.1 and GAB works even after removal only on standard email app, but neither on standard calendar app nor standard contact app (incl. dialer). Any news about this issue?

    Posted via the Android Central App
    03-15-2016 01:02 AM
  15. DGrand's Avatar
    Look at
    http://forums.androidcentral.com/sho...d.php?t=657665
    Most of troubles occur by battery optimisation... deactivate completely function or partially on corresponding apps.

    Posted via the Android Central App
    03-27-2016 06:01 AM
  16. Lobna H's Avatar
    FYI: This has been resolved with 6.0.1
    All you need to do after you have 6.0.1 is to remove and re-add your Exchange account. (no reboot required)
    On my N6P, I did this and GAL lookup works in the gmail app again. Yay!
    Here is a Googler's response on the Issue Tracker page:

    Hi again all,
    As some of you may have noticed, we released a fix for this issue in 6.0.1. If you are still experiencing the problematic behavior with GAL lookup, removing and readding the Exchange account should resolve the issue and restore the intended behavior.

    Please be sure that you finish sending any locally-saved drafts before doing this, as you will lose them upon deleting the account.

    I apologize for the pain and inconvenience this issue has caused. Please continue to leave feedback here as it is helpful for our team.
    Did the GAL lookup in the contacts and phone apps also work after you removed and added the exchange account? Or did that just fix it for the Gmail app?
    08-02-2016 07:05 PM
  17. CalgaryTech's Avatar
    I have the same issue and yesterday I RESET the entire Samsung S6 back to factory, then readded everything carefully leaving as many settings at default as I could.

    The Exchange GAL is being queried and returning results using the integrated MAIL app but it is not in CONTACTS or MESSAGE (texting) apps.

    I have confirmed that SYNC CONTACTS is on for that Exchange account and that CONTACTS > MORE > SETTINGS > CONTACTS TO DISPLAY is set to ALL CONTACTS.. I have removed that Exchange account, rebooted and then re-added the Exchange account but still have the same issue.

    This was not a problem under Android 5 but the device is now running Android 6.01.

    Other suggestions would be appreciated.
    08-08-2016 06:18 PM
  18. watson023's Avatar
    I use BlackBerry Hub, but I don't pay the monthly fee, so I can't use the BlackBerry contacts app. If anyone else is in a similar situation and doesn't use Gmail as their primary account, this might help.

    I have an LG G4, so this is how mine works, not sure if this is the same for all Android 6.0. Please see steps below that worked for me.

    1. Open contacts app.
    2. Click menu key (3 dots) at the top right and choose "Contacts settings."
    3. Click "Accounts & Sync" and go to "Microsoft Exchange" (not "Exchange" with Gmail thumbnail).
    4. Put in your account info (I have to go to manual settings to put "outlook.office365.com" as the server and change the domain, but not sure if all have to do this or if you can just put username and password).
    4a. For me, it popped up a "Remote security administration" screen stating that my server must be able to remotely control security features of my phone. I clicked Yes to continue.
    5. I unchecked everything other than "Contacts," changed sync schedule to "Manual," and have email sync period as 1 day since I'm using this only for remote (GAL) contact search.
    6. Click NEXT and change account name if you want (I set mine as Company GAL, but this really doesn't matter).
    7. Click DONE.
    8. Go back to Contacts settings (instructions 1-2 above) and click the checkbox for "Online search."

    I then went into my contacts again and started to search and it worked!
    I also went into Blackberry Hub and created a new email and started typing a name there too - it worked there too!
    I use Textra app for text messaging, and when I go into the app and start typing a name, it does NOT search Microsoft Exchange - to get around this, I got into contacts and then choose to text message from there - it works!

    I also got a notification at the top that said an update is needed - this opened the stock email app where it asked for Exchange to be a phone administrator. I don't think this is necessary since you're not using it for email (I did the tests above before opening this notification), but I clicked Activate just in case. Since I did this, I then went into the stock email app's settings for this account and unchecked Signature and Notifications. Again, probably not necessary.

    Really hope this helps some people (I tried to install about 7 different contacts apps hoping to fix it, then finally uninstalled all of them and did the steps above).
    10-17-2016 11:48 AM

Similar Threads

  1. Samsung S6 Aux/media volume level won't stay in max
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 10-12-2015, 03:11 PM
  2. Replies: 0
    Last Post: 10-12-2015, 01:21 PM
  3. Replies: 1
    Last Post: 10-12-2015, 01:03 PM
  4. Help android os sucking data keeps getting worse
    By miya lynn in forum Ask a Question
    Replies: 0
    Last Post: 10-12-2015, 12:06 PM
LINK TO POST COPIED TO CLIPBOARD