08-06-2017 08:28 AM
60 123
tools
  1. Hilary Lucero's Avatar
    I installed that latest upgrade for my S7, and have gotten the "screen overlay detected" message so many times, with many different apps, that it is making the use of my phone difficult.

    I searched for "Twilight" and don't have it installed. I don't know what to disable!

    Please help!
    I've the same message about the overlay. I cannot do anything with my s7 hardly because of this issue. It really sucks. Is there a way to get rid of the overlay issue without messing us anything else on the phone? I don't like the s7 anyway.
    12-07-2016 08:40 PM
  2. Sunflo80's Avatar
    I tried all the ways that you guys gave, but none worked for me...

    I have a galaxy s7 edge. This morning i downloaded Walmart app and then i got "Screen overlay detected" message. After i turned off all the apps in the "Draw over other apps" list, the app still did not work. Also, all the apps which used to work fine are now asking for "Screen overlay detected" .

    I even tried to download Task killer, but still did not work..
    Sunflo80.. Wants to know if any figured it out???? ,, I am having same prob
    01-07-2017 09:31 PM
  3. TickM's Avatar
    As Sunflo80 above said it isn't working for me either (S7) I cannot move the toggle switches in application manager, and to put it simply that is the cause. Many applications that detect screen overlay redirect you to the application manager and it's there that nothing can be checked/toggled for the given application that asks for this overlay settings to be changed. No task Killer seems to help anyway.
    03-24-2017 11:23 PM
  4. ManiacJoe's Avatar
    Give this thread a try for more apps to look for.
    http://forums.androidcentral.com/sam...ly-select.html
    03-25-2017 04:58 AM
  5. n777lt's Avatar
    Unfortunately for me on a Samsung S6 it appears to be EITHER setting the brightness to Automatic (with built-in settings, no app) OR ES Task Manager's Quick Access feature that allows you to set a custom menu that pops-up (!) with a swipe from the corner...EVEN IF YOU DISABLE ITS OVERLAY PERMISSION FROM SETTINGS/APPLICATIONS. Turned off automatic brightness AND uninstalled ES Task Manager, and problem seems to be solved. Another 1/2 hour of troubleshooting should let me know which was the culprit, but I don't have time for that right now.
    04-30-2017 09:23 AM
  6. lallolu's Avatar
    Hi, i found a great solution.
    I had the same problem.
    1) download TASK KILLER app.
    2)go in Setting -> General -> Apps -> Configure Apps -> "your app" -> Permissions
    3)Start TASK KILLER
    4)Press Kill Selected button
    5)Come back to Apps permission pressing the square button on the Home touch button on your telephone
    6)Now you can set any permissions because all the other applications are killed and they cannot be in conflict with the permissions
    I had to find my password so I can log in and say, thank you!'
    This is the only method that worked for me although I used another task killer.
    05-08-2017 06:55 AM
  7. Mohamme01805771's Avatar
    I didn't have any of those programs mentioned I did have Omni swipe which puts a small dot on the screen so I disabled it and had no problems after that
    Superb dude...

    Omni swipe or du swipe disable it or uninstall the app that f**


    Thank you Mark for your suggestion.

    It really works...try it
    07-10-2017 01:25 AM
  8. mattklaus's Avatar
    Hey everyone, this error really troubled me for a while. I search for help online, but they didn't seem to work for me.
    Well, I went deep. I realised that something (app(s)) is probably writing over the screen - overlay (my case were system apps), so don't feel like your case is different.
    I own a Techno mobile W2, running Android v6.0. I tried restarting my phone and granting permissions immediately it boots, but I realised these apps probably ran automatically when my device boots. This is what I did then;
    1. Settings->Auto-start management
    2. I then disabled all the apps (removed them from the auto-start list). I couldn't get the exact app which overlayed the screen - because they were too many.
    3. Reboot my device
    4. Went to Settings->Apps and selected the app (which demands permissions).
    5. Granted the app permission(s).
    (6). You may want want to re-enable some of the apps (if not all) on auto-start. In my case, my keyboard didn't pop-up (because I disabled the app on device start-up. So I need to enable it and restart my device).

    Well, your device may not be designed as mine (it may not have the Auto-start manager directly in settings), but see how to get to the apps which start automatically on system boot (and follow the instructions above (2)).

    Thanks to all the replies above, they really helped me. Hope this is helpful (I signed up for this reason).
    Tim1954 likes this.
    07-30-2017 04:50 PM
  9. Theo Donacik's Avatar
    I got this app and it bypasses this so now I can use screen overlay apps without any hassle, with only a minor inconvinience of having an ad popup every few times it is use (and no I'm not just a bot to promote this app) https://play.google.com/store/apps/d...buttonunlocker
    08-04-2017 06:14 PM
  10. J Dubbs's Avatar
    Good G*d I get a headache just reading about all the time you guys have to invest in this os to get things working.

    NO phone os should need this much effort put in to get simple things working. This is exactly why I only use my marshmallow phone as a phone, and use my phablet running kit-kat for everything else..... including posting this lol.
    I'm running twilight on it as I type problem free ;-)

    In some ways I think Google has lost the plot abit with Android lately :-(
    08-06-2017 08:28 AM
60 123

Similar Threads

  1. Samsung S5 blank screen after Android update
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 12-29-2015, 03:21 PM
  2. [FREE][GAME][2.3+]Crash and Run
    By MaximGorbunov in forum Android Games
    Replies: 2
    Last Post: 12-29-2015, 08:16 AM
  3. Replies: 1
    Last Post: 12-27-2015, 10:36 PM
  4. Replies: 1
    Last Post: 12-27-2015, 09:14 PM
  5. Replies: 1
    Last Post: 12-27-2015, 09:10 PM
LINK TO POST COPIED TO CLIPBOARD