1. bharatagal's Avatar
    Hi,

    My Phone (Samsung S6 edge+) recently got updated to Android 6- Marshmallow and since then Gmail has stopped syncing automatically on my phone .

    I have to open the app and swipe down to sync the latest changes/ to receive new mails.

    I checked the account settings in the gmail app and it is set to sync mail.

    Please advise

    Regards,
    Bharat
    (email address removed by Moderator
    03-24-2016 03:41 AM
  2. dpham00's Avatar
    Please do not post your email address on this public forum.
    03-24-2016 07:49 AM
  3. Ingo Thomas's Avatar
    Had the same problem after upgrading to Marshmallow with my work e-mail (Exchange server to stock e-mail client). The problem was not in the application settings, but in the energy saving mode settings.
    I always have energy savings mode on, restricting data access to selected applications, no matter what that app settings are. Kept flipping synchronization settings, nothing changed. Turns out, it was automatically update-applied battery saving options, restricting background data.

    Solution:
    Settings >> Battery(!) >> More >> Optimize Battery Usage >> All Apps >> Turn off e-mail clients (or whatever app needs permanent data flow)

    Hope this helps, it's a curve ball. It's not a data or synchronization setting.
    04-09-2016 03:56 PM
  4. gwynn06430's Avatar
    Had the same problem after upgrading to Marshmallow with my work e-mail (Exchange server to stock e-mail client). The problem was not in the application settings, but in the energy saving mode settings.
    I always have energy savings mode on, restricting data access to selected applications, no matter what that app settings are. Kept flipping synchronization settings, nothing changed. Turns out, it was automatically update-applied battery saving options, restricting background data.

    Solution:
    Settings >> Battery(!) >> More >> Optimize Battery Usage >> All Apps >> Turn off e-mail clients (or whatever app needs permanent data flow)

    Hope this helps, it's a curve ball. It's not a data or synchronization setting.
    BRILLIANT! I tried everything. Checked all my settings, removed accounts, added accounts, nothing worked. THANK YOU! I use my phone so much and need to keep it in power saving mode almost all the time. And I was missing very important emails because of this change... and now it's fixed!

    THANK YOU!!!!!
    11-22-2016 07:14 AM

Similar Threads

  1. How do I turn on the url?
    By christie76 in forum General Help and How To
    Replies: 2
    Last Post: 06-14-2018, 12:43 PM
  2. Google Play Services problem after Marshmallow upgrade, how do I fix it?
    By AC Question in forum Android 6.0 Marshmallow
    Replies: 8
    Last Post: 01-03-2017, 06:06 PM
  3. Why can't I install Google Play?
    By AC Question in forum Google Play Store
    Replies: 1
    Last Post: 03-24-2016, 03:15 AM
  4. Replies: 1
    Last Post: 03-24-2016, 02:33 AM
  5. Why is my usb connection on my S3 mini not showing in the pc?
    By AC Question in forum Samsung Galaxy S3 Mini
    Replies: 0
    Last Post: 03-24-2016, 02:29 AM
LINK TO POST COPIED TO CLIPBOARD