1. AC Question's Avatar
    Hello,

    I have a difficult one for hard core troubleshooters and Android experts

    Last weekend I let my Samsung Galaxy S6 upgrade to 6.0.1 and I have lost mobile connectivity (Proximus - Belgium)

    The phone is operating in roaming (not in Belgium at the moment) and roaming is enabled. The phone was operating in roaming before for several months and in different countries, never a problem, And to complete the roaming picture, the phone was sitting in the same country for a week before the Marshmallow upgrade: mobile data was perfectly working. ONLY after the upgrade it stopped working.

    Concerning all other phone functions: everything is working as usual, only mobile connectivity (any: 2G, 3G, 4G) is affected. I can make and receive phone calls, I have wifi connectivity, et cetera.

    Now another peculiar symptom: if I leave the Network Mode in LTE/3G/2G (auto connect) the phone won't connect at all to mobile data.

    Let me explain:

    If I check the SIM (About Device>Status> SIM cart Status) it shows:

    Mobile Network type HSUPA
    Mobile network state: Connecting
    Service State: In service
    Roaming: Roaming

    If I manually select the Network Mode to 2G everything looks good:

    Mobile Network type EDGE
    Mobile network state: Connected
    Service State: In service
    Roaming: Roaming

    But even in this case I still have NO MOBILE DATA connectivity.

    I performed a network reset, a factory reset; I reconfigured the APN, problem is still there.

    I swapped my Proximus card with another: I have mobile connectivity in both devices!

    In other words my Proximus card works in another phone (I have mobile data) while at the same time another SIM card works in my Galaxy S6 (I have mobile data)

    A possible incompatibility with the latest baseband release and Proximus ? That would be hard to believe and easy to find on internet forums… but nothing.

    I went to a Samsung specialized shop and the situation became even more puzzling.

    We tried my Proximus SIM in another Samsung S6 (edge) with 6.0.1 : it did not work either. The same Proximus SIM however worked (there was mobile data) in an iPhone 5s

    The only additional hypothesis we could formulate is that my SIM might be too old and incompatible with the latest (baseband) release?

    The SIM is however not too old (from 2014).

    Has anyone had the same problem? Alternative ideas?

    Thank you!!!

    Michele
    04-01-2016 05:44 AM
  2. michelemmarco's Avatar
    Hello,

    I see many views and no reply... no guess?

    In the meantime I received a new SIM from Proximus. The problem stayed the same. So I phased out also the possibility that the issue is related to an old SIM.

    At the moment (I have just tried) I have:

    My Proximus SIM card would not work (no mobile data) on my Galaxy S6 with the latest Marshmallow Samsung upgrade (it worked until the minute before the upgrade). I tried a local provider (I am in roaming) SIM card on the Galaxy S6 and I have mobile data.

    My proximus SIM card would work on another phone (iPhone 4s)

    And I am stuck.

    The Samsung shop says it's not a problem with the phone since it worked with their SIM
    My phone company (Proximus) sent me a brand new SIM which works in another phone, hence it's not their problem either.

    What to do??????????????

    Any help really appreciated.......

    Michele
    04-04-2016 10:26 AM
  3. michelemmarco's Avatar
    really? no one attempting an answer?

    Disappointing.... I am sure there are plenty of smart people out there....
    04-08-2016 05:09 AM
  4. Pieter Deschuytter's Avatar
    Hello Michel,

    I just found your post and I'm having a similar problem with my wife's phone. Did you found a solution for this problem?

    Kind regards,
    06-28-2016 03:19 PM
  5. Marnik Aerts's Avatar
    I've had the same problem with Proximus (Belgium). But it's solved.

    Solution found on [FIX] US991 mobile data doesn't work after… | LG G4
    Settings for Proximus : https://www.proximus.be/support/nl/i...-3g-of-4g.html

    What I did :
    - Settings
    - Mobiele Netwerken
    - Namen toegangspunten
    - Bestaande toegangspunten verwijderen
    - Toevoegen
    - Naam : Proximus
    - APN : internet.proximus.be
    - Meer > Opslaan

    And the dataconnection was back !!!
    badcat likes this.
    08-13-2016 03:48 PM

Similar Threads

  1. Return to stock launcher from Google Now?
    By lan4 in forum Verizon LG G2
    Replies: 1
    Last Post: 04-07-2016, 03:26 PM
  2. My network connection doesn't wanna work after the new update?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 04-01-2016, 05:31 AM
  3. Replies: 1
    Last Post: 04-01-2016, 04:59 AM
  4. How do I unlock my Samsung Galaxy S4?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 04-01-2016, 04:58 AM
  5. What device do I need to root?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 04-01-2016, 04:58 AM
LINK TO POST COPIED TO CLIPBOARD