1. g1142932's Avatar
    I thought i was mad, but today i realized i am not. When i went to sleep i turned off WIFI and any mobile data connection (NOT Airplane mode, just turned off everything).
    This morning i woke up and connections were as i left them (all turned off: no mobile data, no wifi, no Bluetooth, nothing, just plain "voice" line) and i found Whatsapp notifications of messages sent me at 7am.
    08-24-2016 12:28 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone do you have? Does it have any sort of "Smart" manager app for network connections?
    08-24-2016 02:07 AM
  3. g1142932's Avatar
    Hey there!
    Yep, sorry... :-P
    Motorola Moto G (2nd edition)
    Android 6.0, security patch level 1 Jan 2016, kernel version

    3.4.42-gef77327 hudsoncm@ilclbld53 #1
    Wed Jan 6 12:29:54 CST 2016


    No, no funny app/app store installed
    08-24-2016 05:41 AM
  4. B. Diddy's Avatar
    Hmm, not really sure how that can happen. As a general step, try wiping the cache partition: https://motorola-mobility-en-hk.cust...p/30,6720,9151
    08-24-2016 10:27 AM
  5. g1142932's Avatar
    Thanks Mate!
    Done that, didn't worked: today it happened again :-(
    08-31-2016 02:16 AM
  6. B. Diddy's Avatar
    Go to Settings>Wi-fi, tap Menu>Advanced, and make sure any option about Wi-fi Scanning is off. It might also be in Settings>Location​, in the Advanced menu there.
    08-31-2016 03:22 PM
  7. simba mudondo's Avatar
    I'm currently using a Sony Xperia Z3, but the smart network switching on my previous phone, Huawei Mate 7 was the best. Intelligent switching mode, they call it. I'm my opinion, Huawei is one of the best players in the industry.
    09-01-2016 04:26 PM
  8. g1142932's Avatar
    Hi Diddy!
    Thanks for your answer!

    It happened today again. Turned off pretty much anything, and this morning i had notification of unread whatsapp messages; those messages -evidently- where not there when i turned off wifi/3g connections.

    Nope Diddy, wifi is OFF, SIM data connection is OFF.
    No GPS either.

    I double-checked anyway right now, and i can confirm: those options you say are off.
    09-14-2016 01:32 AM
  9. B. Diddy's Avatar
    Not sure what to try next, sorry! I recall seeing another post about this, also with WhatsApp. I wonder if the app is somehow turning on the connection long enough to get messages?
    09-14-2016 03:52 PM
  10. Javier P's Avatar
    Very strange issue. I wonder if Whatsapp turns connections on to perform an scheduled backup. I'm just guessing here, but just in case open Whatsapp - settings - chats - chat backup and see what's checked in there.
    B. Diddy likes this.
    09-14-2016 04:07 PM
  11. g1142932's Avatar
    Hey there! Sorry for late answer.
    Nope, Whatsapp does not activates wifi for backup, since last backup date is (way) in the past.

    This is *still* happening, i think Android is to blame, which is scary. Who does Android talks to? What does it tells? Why? With no consent? Deliberately opening connections?!?
    Scary
    10-18-2016 02:38 AM

Similar Threads

  1. Android Nougat Battery Issues
    By TheWillOfSon in forum Nexus 6P
    Replies: 29
    Last Post: 10-21-2016, 07:23 PM
  2. Factory reset with no restore is manadory for 7.0 Nougat.
    By tonyr6 in forum Android 7.0 Nougat
    Replies: 10
    Last Post: 08-24-2016, 04:30 PM
  3. Moto G (2014) Android Nougat update
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2016, 02:44 AM
  4. why music player stops at high volume in ear phones.?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2016, 02:41 AM
LINK TO POST COPIED TO CLIPBOARD