1. slamminfan's Avatar
    Just bought a new RCA Galileo 11 tablet with Android 6.0 OS. Everything works fine, except I can't get the doggone thing to open files on USB thumb drives. I've tried everything I know with no luck. The tablet has both micro-USB and regular USB connectors. All the USB settings are good in the developers' options, including the debugging. It shows the thumb drive as connected thru the regular slot, and shows what files are on the stick, but it will NOT open the files so they can be read. I even installed ES File Explorer, but get the same thing.....shows what is on the stick, but won't open them so they can be read.

    Does anyone have any ideas? BTW, tablet is not rooted. Any help is appreciated.
    12-30-2016 10:20 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What kind of files are you trying to open? Are you sure they're files that Android apps can read?
    01-03-2017 01:21 AM
  3. bdavis123's Avatar
    I have the exact same issue with 10 LG Gpads 8.3x.

    The tablet sees the thumbdrive, and the PDF in the thumbdrive. When I try to open the PDF from the thumbdrive, it gives me this error:

    Cannot display PDF ( filename.pdf cannot be opened)

    I have factory data reset the device.

    I have used different thumbdrives.

    This seems to be an update that was pushed because my company owns 10 of these and they all have the same issues.

    I have tried using 4 different pdf file readers. I have tried verifying over usb in developer options. I have tried turning on permissions for USB devices, but with no success.

    The file CAN be downloaded to the internal storage, but I need to be able to read from the thumbdrive due to the large pdf file sizes im using.

    This was all working until a month or two ago.
    02-07-2017 07:22 PM

Similar Threads

  1. Moto voice driving mode won't stay on
    By cb2367 in forum Moto Z Force
    Replies: 9
    Last Post: 01-24-2017, 01:49 PM
  2. How can I cast my android phone desktop to a chrome cast?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-31-2016, 01:37 PM
  3. Does the z580ca have hdmi output via the usb c?
    By spb37 in forum ASUS ZenPad S 8.0
    Replies: 1
    Last Post: 12-31-2016, 07:53 AM
  4. My HTC one m7 won't access Facebook.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-30-2016, 06:48 PM
  5. My HTC one m7 won't access Facebook
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-30-2016, 06:46 PM
LINK TO POST COPIED TO CLIPBOARD