1. Scivias's Avatar
    I have a new BLU Advance 5.0 HD which runs Marshmallow 6.0. I have a security app (Qustodio) that requires Accessibility Services to be turned on. This app is also set as a device administrator and has usage access permission. But no matter what, Accessibility Services won't stay on. It switches off by itself, which disables the security app! This happens to other apps that use Accessibility Services, too (have tried it with MacroDroid, McAfee Security, and MMGuardian). Here is what I have tried without success:

    * Uninstalling and reinstalling the app
    * Hard reset of the phone
    * Disabling "battery optimization" for the app
    * Turned off Settings > Battery: Standby intelligent power saving
    * Turned off Settings > Battery > Battery saver, and switched "Turn on automatically" to "Never"
    * Contacting BLU customer service (they were of little help)

    What should I try next?



    EDIT: Thanks for responding, virxbmc. The closest thing to Battery Management on this phone is Battery Optimization. I switched it to Not Protected status, meaning Battery Optimization should ignore it.

    Could this be a defective device? BLU tech support claimed they have never heard of this problem before, which is hard to believe if this is "normal" for this phone. Many apps use Accessibility Services, not just parental control apps! Not even the pre-installed McAfee Security app works because of this problem...
    07-29-2017 05:33 PM
  2. virxbmc's Avatar
    Did you add it to Protected Apps under Battery (Management) ?
    07-31-2017 12:55 PM
  3. J Dubbs's Avatar
    Honestly marshmallow is an unpredictable, buggy os..... for the most part it gets the job done, but there will always be frustrating issues that pop up depending upon what you're doing with your phone.

    I just use my phone for the basics because I avoid a lot more issues that way. But I do use Bluetooth and there's no excuse for how badly Google screwed that up.... it's actually mind boggling.
    08-06-2017 08:03 AM
  4. robcom98's Avatar
    I am having the same exact issue. I have a parental control app that requires Acc. turned on. Sometimes when I go to the list on the Acc. page it says the app is off. When I go to the toggle screen to turn it on it says it's on but when when I go back one screen it says it's off. When it does confirm it's on it ends up shutting it off own it's own pretty quick.

    Have you found a solution??
    08-21-2017 10:55 AM
  5. Mitchmilo's Avatar
    I am having the same exact issue. I have a parental control app that requires Acc. turned on. Sometimes when I go to the list on the Acc. page it says the app is off. When I go to the toggle screen to turn it on it says it's on but when when I go back one screen it says it's off. When it does confirm it's on it ends up shutting it off own it's own pretty quick.

    Have you found a solution??

    i have that same problem with a fingerprint quick action and it is really annoying and i have know idea what to do.
    04-18-2018 09:34 PM

Similar Threads

  1. Replies: 41
    Last Post: 08-19-2017, 06:39 PM
  2. Galaxy S5 to Windows 10 Smart Switch Problems
    By Wayne2049 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 08-09-2017, 08:10 AM
  3. Replies: 0
    Last Post: 07-29-2017, 04:51 PM
  4. Help me fix this problem please!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-2017, 03:42 PM
LINK TO POST COPIED TO CLIPBOARD