1. ML Skieys's Avatar
    My battery drops from 60% to 0% then i plug the charger for like 14 seconds and i saw at the screen it says I have 58% help please I tried to calibrate my phone but I cant get it to drain.
    01-15-2019 02:42 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! The battery is probably failing. Which phone? If it's user-removable, try a different battery. Otherwise, bring it to a repair shop.
    01-15-2019 09:54 AM
  3. Rukbat's Avatar
    That sounds very much like a dendrite (Lithium Battery Dendrite links) which, like Alzheimer's not being diagnosable in a live patient, can't be absolutely diagnosed in a battery without cutting it in half. As B. Diddy said, the battery has to be replaced. (Technically it's a manufacturing defect, but the manufacturers won't replace the battery for free.)
    B. Diddy likes this.
    01-15-2019 11:59 AM
  4. Afflospark's Avatar
    Hey MLSkleys,
    When I see your problem that your battery discharge too early.
    It's because of you overuse your phone or you use your phone with your plugin with your charger.
    There are some reason
    1. your phone is too old and your battery is almost dead.
    2. overuse your phone as I early mention
    3. overcharge is also a problem for some phone
    so if you want to overcome this just follow these steps
    1. you have to fully discharge your phone.
    2. Then plug it with your charger and when its full charge (don't use it when it's in the charging process )
    3. Then you have to fully discharge it
    do these steps 4-5 Times and you see your battery will work smoothly
    If these steps not work then you have to change your battery or buy a new one.
    04-10-2019 11:46 PM

Similar Threads

  1. how do i get my galaxy s5 out of kernal mode screen
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-15-2019, 06:03 AM
  2. How do i view what my girlfriend is hiding on her Galaxy 9s plus
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-15-2019, 01:36 AM
  3. Google apps unable to connect to network (Works fine on WI-FI)
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-14-2019, 11:46 PM
  4. Unable to restore from old to new G5s Plus
    By Johnha1980 in forum General Help and How To
    Replies: 0
    Last Post: 01-14-2019, 09:37 PM
  5. Why is my phone not recording sound
    By Emilie Edwards in forum General Help and How To
    Replies: 0
    Last Post: 01-14-2019, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD