10-10-2017 06:50 PM
29 12
tools
  1. N4Newbie's Avatar
    I'm not sure if this is an Android N thing or something totally separate of that...

    I use the Nine app ( https://play.google.com/store/apps/d...inefolders.hd3 ) for my work Exchange email account. Typically, while sitting at my desktop PC running Microsoft Outlook, I see an email arrive on my desktop and hear my phone's notification tone for the same email received in Nine within several seconds of each other.

    Lately, however, my phone picks up the email many minutes (perhaps as many as 10-15) after the same email hits my PC. I can't swear that this is directly related to N, but I think it is. I am currently on Preview 4, having started with Beta-N (Preview 3?) 24 hours or so after it became available.

    Anyone else?
    06-17-2016 01:33 PM
  2. adev25's Avatar
    Is it possible your sync settings for your Nine account are set to every 15 minutes or something like that. If you are using Push settings it should come relatively simultaneously
    06-17-2016 02:40 PM
  3. N4Newbie's Avatar
    Is it possible your sync settings for your Nine account are set to every 15 minutes or something like that. If you are using Push settings it should come relatively simultaneously
    No, always was and still is set to "Sync frequency: Automatic(Push)".
    06-17-2016 02:48 PM
  4. SpookDroid's Avatar
    I'm using it on Marshmallow and it works fine as long as it's set to Push and my Sync toggle is active. Haven't tried N, but at least that should tell you that it's probably not the app.
    06-17-2016 02:49 PM
  5. N4Newbie's Avatar
    I'm using it on Marshmallow and it works fine as long as it's set to Push and my Sync toggle is active. Haven't tried N, but at least that should tell you that it's probably not the app.
    Yeah, like I said above, it always worked fine; only recently have I noticed the very significant lag and the only thing that has changed is that a) I am running Android N and b) I think there has been at least one, maybe two, recent Nine updates.
    06-17-2016 02:52 PM
  6. Don_Henry's Avatar
    I am running N Preview 4 on my Nexus 5X - Nine is working flawlessly for me - in fact on N, Nine is faster in GUI and overall response than it was on MM.

    And I have not noticed any difference in delay of receiving emails compared to MM.

    NEXUS 5X on AT&T on N Beta
    06-17-2016 04:22 PM
  7. N4Newbie's Avatar
    Okay; it could possibly be our (in house) Exchange server which is responsible.
    06-17-2016 05:56 PM
  8. Clocks's Avatar
    I also use Nine, on Android n DP4, my phone gets alerts before my laptop sees the email.
    06-26-2016 09:21 PM
  9. zetachi's Avatar
    running 7.0 on my Nexus 6P and have run into the same issue. Reported it to Nine Support. Lets see what they say.
    12-01-2016 09:23 AM
  10. N4Newbie's Avatar
    running 7.0 on my Nexus 6P and have run into the same issue. Reported it to Nine Support. Lets see what they say.
    I am the original poster, now using a Google Pixel XL with Android 7.1 (not 7.1.1) and still having the same issue. Sometimes emails hit my phone within seconds of appearing on my desktop PC; other times not for many minutes.

    I think it is due to Android 7's battery conservation measures. I just now disabled battery optimization for Nine (I swear I had already done that...); will see if it makes a difference. Settings -> Battery -> Battery optimization.
    12-07-2016 04:17 PM
  11. zetachi's Avatar
    So nine support looked at my logs and told me my calendar issues were caused by company server I replied that that nice for that but that didnt explain the no push issue. Have not heard back from them after that.
    12-07-2016 04:33 PM
  12. Don_Henry's Avatar
    I am the original poster, now using a Google Pixel XL with Android 7.1 (not 7.1.1) and still having the same issue. Sometimes emails hit my phone within seconds of appearing on my desktop PC; other times not for many minutes.

    I think it is due to Android 7's battery conservation measures. I just now disabled battery optimization for Nine (I swear I had already done that...); will see if it makes a difference. Settings -> Battery -> Battery optimization.
    Hey N4N - I also posted a while back that everything was fine on DP4. However, ever since moving to DP5, I am experiencing similar delays as you are - settings are all correct, and no issues on the Exchange server side.

    I have found Nine support to be hit and miss - seems like if it is something that they can quickly solve, you get good response and support. But if it is something that they can't solve quickly, I never hear anything further after their first suggestion does not work.
    12-07-2016 10:24 PM
  13. zetachi's Avatar
    Hey N4N - I also posted a while back that everything was fine on DP4. However, ever since moving to DP5, I am experiencing similar delays as you are - settings are all correct, and no issues on the Exchange server side.

    I have found Nine support to be hit and miss - seems like if it is something that they can quickly solve, you get good response and support. But if it is something that they can't solve quickly, I never hear anything further after their first suggestion does not work.
    Thats fine for a free app but when you have to shell out $$ you expect some level of support
    12-08-2016 08:56 AM
  14. N4Newbie's Avatar
    I am the original poster, now using a Google Pixel XL with Android 7.1 (not 7.1.1) and still having the same issue. Sometimes emails hit my phone within seconds of appearing on my desktop PC; other times not for many minutes.

    I think it is due to Android 7's battery conservation measures. I just now disabled battery optimization for Nine (I swear I had already done that...); will see if it makes a difference. Settings -> Battery -> Battery optimization.
    Perhaps it is to early to be certain, but this does seem to have resolved the problem.

    On the other hand, I also installed the 7.1.1 OTA update this morning on my Pixel XL.
    12-08-2016 03:00 PM
  15. zetachi's Avatar
    so I switched back to Touchdown and have no issues. Calendar syncs and my emails are push. Nine still does not work. So it's not my office server but the nine app.
    01-10-2017 03:22 PM
  16. neo905's Avatar
    so I switched back to Touchdown and have no issues. Calendar syncs and my emails are push. Nine still does not work. So it's not my office server but the nine app.
    Yup. You are correct. Even after a couple updates the past few days. Nine still doesn't push emails right away. How is touchdown on the battery compared to Nine?
    01-13-2017 08:07 AM
  17. N4Newbie's Avatar
    Yup. You are correct. Even after a couple updates the past few days. Nine still doesn't push emails right away. How is touchdown on the battery compared to Nine?
    I resolved my Nine problem by disabling battery optimization for the Nine app.
    01-15-2017 04:03 PM
  18. badcat's Avatar
    I resolved my Nine problem by disabling battery optimization for the Nine app.
    I've tried this as well and it does seem to improve things. I've noticed a hit in battery life (which I suppose is to be expected). Have you seen a noticable decease? I probably should disable battery optimization for a week or so and take a more in depth look at it.
    01-17-2017 07:17 AM
  19. N4Newbie's Avatar
    I've tried this as well and it does seem to improve things. I've noticed a hit in battery life (which I suppose is to be expected). Have you seen a noticable decease? I probably should disable battery optimization for a week or so and take a more in depth look at it.
    Not enough of a change to be troublesome; I still go to bed most nights with very substantial remaining charge.
    01-17-2017 09:17 AM
  20. badcat's Avatar
    Not enough of a change to be troublesome; I still go to bed most nights with very substantial remaining charge.
    Thanks for the info. I should probably try it again.
    01-17-2017 05:10 PM
  21. KKenna's Avatar
    Brilliant! I have had this issue with Nine on my 6p since upgrading to Nougat. I thought disabling battery saver would do it, but no. Had to dig a little further to find this setting. I'm certain this has to be it as it's the background sync that is killed off when the screen is off.

    I have the same problem with Simple Radio - dies in the background while screen is off (and in my pocket and on the motorcycle, so many, very quiet rides). I'll bet this fixes that one as well.

    Although battery life is much improved in Nougat, I'm still in the habit of charging my device whenever I stop and am approximate to an outlet, so battery life hit will not matter to me at all.

    Thanks!
    02-02-2017 11:04 AM
  22. zeek_11's Avatar
    I'm not sure if this is an Android N thing or something totally separate of that...

    I use the Nine app ( https://play.google.com/store/apps/d...inefolders.hd3 ) for my work Exchange email account. Typically, while sitting at my desktop PC running Microsoft Outlook, I see an email arrive on my desktop and hear my phone's notification tone for the same email received in Nine within several seconds of each other.

    Lately, however, my phone picks up the email many minutes (perhaps as many as 10-15) after the same email hits my PC. I can't swear that this is directly related to N, but I think it is. I am currently on Preview 4, having started with Beta-N (Preview 3?) 24 hours or so after it became available.

    Anyone else?
    I am experiencing the exact same issue. I never had the issue with Marshmallow, but ever since installing N a few weeks back, no routine push happening. It's sporadic and it seems that the app once opened (if I haven't opened in a bit) starts to push as it should, but when it hasn't been opened, it's not pushing to the second as it did. I've checked the power management for the Nine specifically and it's allowing the app to run. I am going to email Nine Support this concern. They've been fantastic getting back to me on other concerns. It's hands down the best 3rd party email client. Hope to get an fix.
    03-27-2017 08:57 AM
  23. TimSuds's Avatar
    I'm having the same issue since upgrading to Nougat.

    Setting it to unmonitored in the battery settings did not solve it for me.
    03-27-2017 05:24 PM
  24. Vasil Popov's Avatar
    I'm having the same issue since upgrading to Nougat.

    Setting it to unmonitored in the battery settings did not solve it for me.

    Hello,

    I think I solved it. There is hidden setting in Nougat:
    Battery -> Battery usage (the button) -> Optimize battery usage (the 3 dots in the upper right corner) - All apps (from the drop-down menu).

    You will see that Nine is activated, even though it is not listed in the "Optimized" list of the initial Battery menu, under Device optimization.

    Deactivate it and it should work.


    Good luck!
    badcat likes this.
    06-30-2017 08:36 AM
  25. BWB8771's Avatar
    TL;DR: 1) I have a considerable email-arrival delay despite disabling battery optimization anywhere/everywhere on the phone, 2) individual VIP contacts will not trigger notifications, but who email domains will.

    I found my way to this thread because I installed Nine on my Galaxy S7 that came with 7.0/Nougat. I rooted it because I HAVE to have/use Titanium Backup - if Google and/or phone mfgs would give us most of the capabilities of TiBu, I likely would not need to root my phones. Rooting this S7 was more of a pain than all of the times I rooted my S3 and S6 *combined*

    Anywho.. I too have that annoying issue with the mail taking it sweet time showing up on my phone. I have my old S6 connected via WiFi, its version of Nine is up-to-date, and it still get email from both of two, different Exchange servers darn near instantaneously.

    THE REAL REASON I took to the Internet to Google "Nougat Nine Folders" (no quotes) was to see if anyone else is having problems with their VIP contacts not sounding the notifications. If I configure entire email domains instead of specific addresses, the notifications alert as expected/designed.
    08-02-2017 09:10 PM
29 12

Similar Threads

  1. Can't install big apps.
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 06-25-2016, 12:14 PM
  2. Replies: 1
    Last Post: 06-17-2016, 04:41 PM
  3. Unable to upload the photos in my app
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-17-2016, 01:16 PM
  4. How do i use. Microphone to add contacts?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-17-2016, 01:15 PM
  5. What is the best selfie app?
    By OliaYouRDangeR in forum Android Apps
    Replies: 0
    Last Post: 06-17-2016, 01:14 PM
LINK TO POST COPIED TO CLIPBOARD