1. maqzee's Avatar
    I have tried so many options/blogs/scripts to install GooglePlay for Emulator (running through Android Studio) but it never works. I have seen so many different errors

    3. No space left on /system

    Why is it so hard to install GooglePlay on Emulator, can someone provide steps or GApps that work with Marshmallow/Noughat.

    Here's the gist of what I have tried :

    1. Copy GApps from The Open GApps Project [ Platform: x86_64; Android: 6 & 7; Variant: full ]
    2. Extract the zipped file to temporary folder and then extract following apks from it to another folder
    * gsfcore-all/nodpi/priv-app/GoogleServicesFramework/GoogleServicesFramework.apk
    * gsflogin-all/nodpi/priv-app/GoogleLoginService/GoogleLoginService.apk
    * gmscore-x86_64/nodpi/priv-app/PrebuiltGmsCore/PrebuiltGmsCore.apk
    * vending-all/nodpi/priv-app/Phonesky/Phonesky.apk
    3. Try pushing these apks through this script

    IMAGE_NAME=Nexus_5X_API_24 #Nexus_5X_API_23
    emulator @${IMAGE_NAME} -no-boot-anim -writable-system &
    adb wait-for-device
    adb root
    adb shell stop
    adb remount
    adb push PrebuiltGmsCore.apk /system/priv-app/
    adb push GoogleServicesFramework.apk /system/priv-app/
    adb push GoogleLoginService.apk /system/priv-app/
    adb push Phonesky.apk /system/priv-app/

    I would really appreciate any help !!
    08-29-2016 12:09 PM

Similar Threads

  1. Best Music App for Androids
    By briannamarie91 in forum Samsung Galaxy S7 edge
    Replies: 16
    Last Post: 09-01-2016, 11:59 PM
  2. Replies: 0
    Last Post: 08-29-2016, 10:54 AM
  3. [DEV] [BETA] Testers for a new Tower Defense Game
    By Tom Bradburn in forum Developer Beta Testing
    Replies: 0
    Last Post: 08-29-2016, 10:41 AM