1. jnak00's Avatar
    My Xperia X Performance got Nougat a few weeks ago. Since then, I've noticed the location services icon is constantly on, which naturally toasts my battery. I believe it to be Google Maps, because if I force stop Maps, the icon disappears. I tried clearing the cache and memory used for Maps, which also makes the icon disappear, but within a few hours it's back. I don't want to turn location services off, because I sometimes use it in the truck with Android auto and don't want to be toggling it while driving.

    In the last few days, I've noticed location services is almost always on at home, and almost never at work. Not sure if that's a time of day thing, or location thing. There is a definite sharp drop in battery once I get home from work.

    Any help? Maps is using upwards of 20% of my battery on bad days, and around 10-12% on "normal days". This is without opening or using Maps at all.
    03-02-2017 10:01 PM
  2. B. Diddy's Avatar
    Go to Settings>Location, and make sure it's set to Battery Saving. Also, tap the Menu button there and look for a Scanning option Tap that, and make sure Wi-fi Scanning is turned off. This can be in different locations in the system settings, depending on the phone, so if you don't see it there, look for a Improve Accuracy option. It might also be in Settings>Wi-fi, after tapping Menu>Advanced.

    When you open Google Maps, it might ask you if you want to improve accuracy. Don't say yes. Saying yes will set Location to High Accuracy (which turns on GPS) and also turns on Wi-fi Scanning. After the first time you decline this prompt, it shouldn't keep asking you.
    badcat likes this.
    03-02-2017 11:01 PM
  3. jnak00's Avatar
    Go to Settings>Location, and make sure it's set to Battery Saving. Also, tap the Menu button there and look for a Scanning option Tap that, and make sure Wi-fi Scanning is turned off. This can be in different locations in the system settings, depending on the phone, so if you don't see it there, look for a Improve Accuracy option. It might also be in Settings>Wi-fi, after tapping Menu>Advanced.

    When you open Google Maps, it might ask you if you want to improve accuracy. Don't say yes. Saying yes will set Location to High Accuracy (which turns on GPS) and also turns on Wi-fi Scanning. After the first time you decline this prompt, it shouldn't keep asking you.
    Thanks. I have tried setting it to Battery Saving but Android Auto doesn't like this. The map application in Auto won't run unless it's set to high accuracy. I haven't tried turning the scanning options off, so I'll give that a shot.

    You'd think this would be easier. Why does my phone constantly need to update the location when it is just sitting idle at home?
    03-06-2017 09:00 AM
  4. ptkelly's Avatar
    I haven't seen any other threads about the maps app draining the battery so I'd suspect it might be peculiar to your vendor's version of Nougat. Perhaps there's a forum for that vendor.
    03-06-2017 10:10 AM
  5. jnak00's Avatar
    The vendor being Rogers, or Sony?
    03-06-2017 03:30 PM
  6. LeoRex's Avatar
    If that icon is popping up... That's more than just location services. That's an app polling​ for high accuracy location, I.e. GPS.

    Maps won't poll the GPS unless it's active. If you go into settings-location, what apps are listed? Google Location Services is a service, not an app... If it's being called constantly, it's not doing so in its own.
    03-11-2017 08:48 PM

Similar Threads

  1. Google Assistant Update for S7 (where is it?)
    By left4dead in forum Samsung Galaxy S7
    Replies: 157
    Last Post: 05-18-2017, 05:20 PM
  2. Replies: 19
    Last Post: 03-07-2017, 09:44 PM
  3. Replies: 3
    Last Post: 03-03-2017, 06:52 PM
  4. Replies: 1
    Last Post: 03-02-2017, 09:53 PM
  5. Replies: 0
    Last Post: 03-02-2017, 09:33 PM
LINK TO POST COPIED TO CLIPBOARD