1. Mitchell Osias's Avatar
    Ever since my phone upgraded from 6.0.1 to 7.0.0, I can't access my phone's files from my computer when I plug it in. I set it to MTP and I know it is not the USB cable because my phone still charges when I plug it in. Is there any fixes or work-arounds?
    07-02-2017 01:44 PM
  2. PJRed2008's Avatar
    Have you made sure you still have developer options enabled after the upgrade? You may also need to upgrade the USB drivers on your computer.
    07-02-2017 04:49 PM
  3. Mitchell Osias's Avatar
    Yes I enabled developer options but I haven't updgraded my USB drivers. I'll try that now.
    07-02-2017 11:26 PM
  4. Mitchell Osias's Avatar
    I updated my drivers but it still doesn't work.
    07-02-2017 11:40 PM
  5. metafnord's Avatar
    Ever since my phone upgraded from 6.0.1 to 7.0.0, I can't access my phone's files from my computer when I plug it in. I set it to MTP and I know it is not the USB cable because my phone still charges when I plug it in. Is there any fixes or work-arounds?
    Same problem here.

    Windows 10 Professional -- all up to date. It has received the 2017 "Windows 10 Creators Update" a few weeks ago. Maybe that is part of what changed, I don't know. Always is set to automatic updates. System is pretty clean, Windows was last reinstalled just a couple of months ago.

    Nexus 5X running Android 7.1.2 -- also up to date, and always receives automatic updates. Was last factory reset about two months ago.

    I have tried:
    * Different USB cable... no, have tried many, all of them worked before for MTP file transfers, none of them work now. They did not all break at once.
    * Different USB port... that's not it either. All of my computer's USB ports work perfectly with other devices.
    * Look for the drop-down notification of USB connection mode in Android: IT'S NOT THERE. Google Nexus phone support agents were surprised by this and acted as though they had never heard of the problem.
    * Try (as one other post or comment suggested) tapping the battery charge status icon: no, on my Android 7.1.2 and Nexus 5X this does not lead to any USB connection mode options.
    * Safe Mode: I have restarted the phone in or out of Safe Mode, with or without any of these other attempts, and it has not helped or made any difference to the problem.
    * Developer Mode: I made sure Developer Mode was both enabled and turned on.
    * In Settings > Developer Settings I do not have USB debugging enabled (but it has not mattered whether I did or not, so far).
    * In Settings > Developer Settings > Select USB Configuration -- maybe this is a big hint about a possible regression or bug in Android 7.1.2? -- I found that the mode was defaulting to "Charging" (as in, charge only, no file transfer, do not have the phone appear as a device to Windows computers). I opened this menu and clicked the "MTP (Media Transfer Protocol)" option. My click was reflected there within the menu, in that the right selection is displayed, but as soon as I close that menu and I am back at Developer Settings, the setting for this was still shown as charged! << THIS SEEMS LIKE A MAJOR RED FLAG.
    * So I persisted with the previous item, tried turning Developer Mode on and off, enabling it and disabling it, and repeatedly opening the settings and selecting MTP. Finally, after I don't know which combination, I finally got the MTP setting to "stick" and now it shows as the correct selection when I am in the general Developer Settings menu. But... that still did not help.

    * I called Google Nexus 24-hour support. I was disappointed with the quality of both support calls that I made, they were far less expert than the people I dealt with last time about a year ago. It felt like the support line has been contracted out when it used to be in-house. The help agents were reading from troubleshooting scripts. They were professionally courteous and kind, but the scripts were very obvious. They often did not respond or conduct the conversation in ways that showed they had heard and understood my response to the previous action that they suggested. They would tell me to do something that I very clearly told them I already had done. They seemed to have no personal familiarity with the particular functions that this problem deals with. They suggested every step that I have already tried.

    * Google Support also had me install Google's own USB drivers, which made no difference.
    * They also had me install the Microsoft Media Feature Pack, which also made no difference.
    * Safe Mode and reboots on the Windows 10 PC have made no difference after these installs either.

    * There is no indication of the phone appearing in Windows Explorer under My Computer or Network. Windows 10 no longer has a "Devices" section, they've changed it. But there is of course still Device Manager. Under Device Manager there is almost no indication that the phone exists, except I see, under HID Devices, "HID Compliant Phone". But it (and its properties) does not mention the Nexus 5X by name.

    * Formerly the Nexus 5x did at least appear somewhere in Device Manager but only in reference to an SMS driver (?) ... but that seems to have changed after the Google USB driver and/or Microsoft media feature pack installs.

    I'm at a loss -- Google Nexus Support has not helped -- their final advice was to perform a factory reset of the phone, which I am about to do. And beyond that I know of nothing else I can do but reinstall Windows 10. But I just did that this year and really should not need to, I haven't tweaked anything important on the system or installed any weird drivers or unusual software.
    07-03-2017 01:09 AM
  6. Sedp23's Avatar
    Noticed this on my axon 7 yesterday it installed the drivers and the phone shows up on the computer. When I try to click the phone or the arrow next to the phone nothing opens up showing the contents on the phone
    07-14-2017 05:39 AM
  7. skyeden's Avatar
    Enabling developer options works almost 100% surely. I think your phone memory is getting low. If it’s getting low, it will become slower or unresponsive. The best way to deal with it is to free up some memory.
    Here is what you need to do:
    -You can install some Android app killer.
    -Use the built-in feature that lets you kill apps and optimize your device. This feature is present by default in all newer phones running Android 7.0 if you don’t have it download a good one. All you need to do is go to Settings > Device maintenance and apply the fix.
    07-18-2017 01:35 AM

Similar Threads

  1. Android central app. Can't login.
    By Karl Krasnowsky in forum Android Central Apps
    Replies: 5
    Last Post: 07-10-2017, 10:45 AM
  2. Why is my song download not stopping?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-03-2017, 02:52 PM
  3. Why i can't find emoji button on my s7 edge keyboard
    By Summertime_sadness in forum Samsung Galaxy S7 edge
    Replies: 3
    Last Post: 07-03-2017, 10:51 AM
  4. Can I connect my Android 7 phone to powered USB-hub?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-02-2017, 04:51 PM
  5. Why does no call recording app work for my honor 6x
    By Matnetmat in forum Android Apps
    Replies: 0
    Last Post: 07-02-2017, 01:29 PM