1. UglyStuff's Avatar

    Dunno what happened to the "old" layout and how I can enter my credentials, so I'm posting here, trusting the moderators to do the right thing by me...

    (My fate is in your capable hands!)

    The title of the question/post/thread says it all, and yes, I've searched everywhere, here and anywhere else, and yes, I've tried everything that's already been suggested (clearing caches, rebooting, in safe mode or not, reinstalling Google Play Store--this one didn't work, due to a "corrupted package"--, etc...): the downloads and updates are all "pending" in the Google Play Store, and I've been unable to change that.

    Strangely enough, I was able to update some (not all) of the apps via Leagoo's own App Store (my phone is a Leagoo T5c), but the store itself enjoys a dubious reputation, and I'd rather use Google's.

    I've tried to update Google Play Store to its newest version, the one released a few days ago (can't remember the exact version number) with APKPure and APKMirror websites, only to learn that the packages were "corrupted", and the app hadn't been updated.

    Basically, I'm stuck, and that's an understatement. Ideas, anyone, please-please-please-pretty-please...?

    (Posting now, not sure I'll be able to edit afterwards, so please excuse any misspellings and/or incomplete explanations.)
    03-06-2018 09:35 AM
  2. B. Diddy's Avatar
    Did the phone come with the Play Store app, or did you have to install it yourself? If the latter, that means the phone isn't certified for Google Play, and so there's always a good chance something won't work right.

    Have you also tried clearing the cache and data for Download Manager in the Settings>Apps​ menu?
    03-06-2018 11:17 AM
  3. UglyStuff's Avatar


    My phone came with the Google Play Store pre-installed, along with Leagoo's own App Store, of which I've been suspicious all along, but I had to install several apps through it because of this "download pending" issue with the Play Store.

    I've tried to clear all the caches I could find mention of during my Google searches, but I found out that one of three security apps I'd installed were in fact blocking updates and downloads: Avast, MalwareBytes and Stubborn Trojan Killer.

    I don't know exactly which one did it, because I uninstalled them one after the other without trying to make the Play Store work between each uninstall.

    All I know is, All is well now. Thanks for taking the time!
    B. Diddy and slackermark like this.
    03-06-2018 01:18 PM
  4. slackermark's Avatar
    Hi, I had a similar problem. Phone is a Blackview P2 so pretty rare and obscure. Last week the phone got an Android update (then do tend to arrive late) since when no apps would update (or download new ones) - said it was downloading but nothing happened. Tried everything under the sun that I could think off - phone off/on, reset WiFi, WiFi off and try mobile data, clear Play Store data and cache, clear Play Services data and cache, even turn auto updates off then uninstall all Play Store updates (i.e. take the Play Store app back to the original one supplied from factory which clearly has worked in past otherwise I'd have no apps!) Nothing. Tried Blackview site/forums but totally useless (assume pretty much no support!). Anyway the only two things left were to try to reboot in safe mode and if that failed a very reluctant full factory hard reset...... then I read your post.

    I too have MalwareBytes so forced a stop. No difference. Don't really use it so uninstalled it; again no difference. I also have AVG (rather than your Avast) so forced stop on that. Power off/on and bingo, can update the apps. I did them by hand rather than take too many chances but it's done.

    My best guess is there's some sort of conflict between that Nougat update and the anti-virus - like I say support from Blackview is all but non-existent so any updates seem to come very late: after the recent one the phone says it's Android security patch level 5th April 2017, Kernel 3.18.5 (Mon Jun 2017 18:06:04 CST) which doesn't sound too recent to me!

    Anyway, thanks again for the 'solution' - temporarily disable the anti-virus then update! Cheers, Mark
    03-07-2018 05:44 AM
  5. tube517's Avatar
    Why have 2 AV apps. I'd keep MalwareBytes and ditch AVG.

    And actually you don't even need an AV as long as you are using Google Play Store to download apps and not from any other sources.
    03-07-2018 05:51 AM
  6. slackermark's Avatar
    As far as I was aware the Malware and AV did different things even though there might be some overlap - having used AVG and MalwareBytes on PCs for best part of 20 years I've never had a virus, spyware, advert issue I could clear easily/quickly even on the very rare occasion anything's got 'infected' in the first place.... but you are probably right in that they are unnecessary here; just old habits die hard.

    I've deleted/uninstalled the MalWareBytes as it was a trial copy and it's expired - downloading a new copy doesn't seem to fool it so it doesn't do anything (anything else I should consider in it's place?) and the AVG, well it's peace of mind - it does check everything else not just what you download from the Play Store.... and the number of times I've heard in the past that 'xxxx is perfectly safe, security can't be broken' then it's proved otherwise, I don't care to mention. Better safe than sorry even if it means I have to disable it temporarily now and again - it's not like Blackview provide fabulous, bang up to date security support so the AVG makes me feel more comfortable.
    03-07-2018 06:20 AM
  7. UglyStuff's Avatar
    I uninstalled MalwareBytes *before* the trial license expired, and reinstalled it from the Play Store without a hitch this morning, so I suppose you can use it for the duration of the trial license minus one day, uninstall it and reinstall it the next day and so on, and so forth, until they start monitoring this forum and realize their mistake...

    As for the rest, AVG is now property of Avast, so I assume they share a lot of components, which could explain why they'd both block traffic to and fro the Play Store on different phones, regardless of which one you're running.

    I'm also proud to advertise that I finally got rid of the malware that came installed with the OEM ROM on my Leagoo T5c, thanks to ADB, sans root: I got rid of the OEM launcher once and for all (until the next OEM update...), and with it, some Trojan labeled as "Android/Guerrilla.AM" by various antivirus vendors.
    03-07-2018 06:28 AM
  8. UglyStuff's Avatar
    I thought I was in the clear, and I was, well, not completely right: the problem occurred again this afternoon while I was trying to update two apps. Sure enough, I got the "download pending" message again, and nothing would budge.

    I went to Settings > Applications, selected Google Play Store, and deactivated it, then force quit it.

    I was prompted to install the "factory version" of it then; I accepted, got a build number that's something like 8.43 (as opposed to 9.23 for the current version, I think), and this unlocked all my pending downloads (two updates plus a fresh install).

    Go figure...
    03-07-2018 09:35 AM
  9. B. Diddy's Avatar
    I've seen posts about Google Play Store problems with other phones as well, like the HTC 10, which might have been caused by the latest update. If it works with the factory version, see if the problem comes back after updating again to the latest version. (You probably can't prevent the Play Store from auto-updating anyway.)

    Also, can you confirm that you already tried clearing the cache/data from Download Manager? This isn't always easily found, since it's a system app. On more recent phones, to find system apps, you have to go to Settings>Apps​, then tap Menu>Show System.
    03-07-2018 09:50 AM
  10. slackermark's Avatar
    At the risk of confusing the 'solution', it was forcing a stop on the Anti Virus that cleared the way for the apps to update on my phone. I'd tried clearing caches everywhere including the download manager in the system apps without joy. Winding the Play Store app back to the 'original' version supplied with the phone (V 7.4.12 was what it went back to) didn't do the trick either although it has solved similar problems for me in the past on other android devices; not this time. Disabling/Force Stop of AVG did work - as I said I had turned off auto updates first so had to do them by hand. Note that, with my phone, the AVG restarted itself on power off, back on which I wasn't expecting so, at the moment, I'll have to disable it whenever I have apps I need to update. Strangely the Google Play Store app did automatically update itself to a more current version, V 9.0.15, without me doing anything - not sure exactly when but I think on a power up. Don't know if it helps or confuses the issue but FYI; maybe it will help someone witha similar problem.
    03-08-2018 05:42 AM
  11. UglyStuff's Avatar
    @B.Diddy: yes, I cleared all the caches mentioned in my numerous Google searches on the subject, including the one in Download Manager, and it didn't work. I too thought that with Avast/AVG out of the way, I was in the clear, but the problem arose again.

    Only reverting to the factory version of Play Store solved that issue for me, and I agree, I probably won't be able to prevent it from auto-updating, so you'll probably hear me rant again in a couple days...
    03-08-2018 01:42 PM
  12. Hirak Sarkar's Avatar
    In the Google Play Store settings you'll find device certification at the end
    In Leagoo T5c it is an uncertified device!
    And an uncertified device apps won't download nor update.
    I'm a Leagoo T5c owner, I diagnose the problem. Now give me solution
    03-09-2018 09:31 AM
  13. UglyStuff's Avatar
    In my case, the problem was (past tense) solved, though I'd still get those warning "toasts" to tell me that updating or installing over the GPRS is going to consume data (duh).

    I updated two apps yesterday, and it went without a hitch, but then Google Play Store got updated too, and all things went to hell again. I had to deactivate Google Play Store, and let Android reinstall the factory version (8.43 in my case), then I emptied the caches again, and now, it's not updating anymore, though the one app to be updated is Google's own Play Films.

    Do you get those GPRS warnings too?

    EDIT: since I use USB tethering a lot, I thought this had to do with that, so I deactivated it, but it didn't change a thing...
    03-09-2018 12:36 PM
  14. UglyStuff's Avatar
    Updating via Leagoo's App Store now, and it's working... There's something wrong with the Play Store, IMO.
    03-09-2018 12:39 PM

Similar Threads

  1. Huwaei Ascend G620S: stuck in Fastboot&Rescue mode
    By hristox in forum Huawei Ascend G6
    Replies: 1
    Last Post: 03-08-2018, 01:50 PM
  2. Got a playestore account on sim,got a wifi device but cantget into account
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-06-2018, 04:11 PM
  3. In which condition is my mobile battery
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-06-2018, 02:22 PM
  4. my samsung tab is not updating
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-06-2018, 02:10 PM
  5. Google Play Services keeps growing madly - no options to make it stop?!
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-06-2018, 11:24 AM