1. WheelmanM80's Avatar
    My ZTE Axon 7 suddenly began compressing pictures and gifs received via MMS to no more than 30 kb, which means picture quality is terrible and gifs don't play. Unfortunately, I don't recall exactly when this started happening... Sent pictures and gifs appear fine on the recipient's phone. The compression happens when I'm using the default texting app Messaging, Google's Messages, Textra, or Signal, etc. HOWEVER, the phone does not compress media received through WhatsApp. I've ruled out an issue with the Verizon network by switching SIM cards with my wife and sending a gif to her number, which is then received by my phone. The received gif is still compressed to 30 kb. I've performed several hard resets to restore all settings to factory, and nothing's worked. Can anyone here help troubleshoot this please? I'm running Android 7.1.1, kernel version 3.18.31, build number A2017UV1.1.0B35.
    01-15-2019 04:48 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is there any kind of data-saver app or feature on the phone? Who's your carrier?
    01-15-2019 05:05 PM
  3. WheelmanM80's Avatar
    Thanks for the quick reply - Data Saver is off, and I'm on Verizon.
    01-15-2019 09:08 PM
  4. B. Diddy's Avatar
    Does it happen in Safe Mode as well? How do I put my device in Safe Mode?
    01-15-2019 09:45 PM
  5. WheelmanM80's Avatar
    Yes it does still happen in safe mode
    01-15-2019 11:27 PM
  6. ManiacJoe's Avatar
    Are you sure this compression is happening on your phone when you receive the message?

    Normally any compression is done on the sender's phone during the sending of the message. If you actually receive the message, there is no need for any added compression because you already received the message.
    01-15-2019 11:39 PM
  7. B. Diddy's Avatar
    When you receive the image or gif, what happens if you save it to your device? Is that what you're doing already when you notice it's only 30 KB in size? Are you certain you're not looking at the thumbnail instead of the full image file?
    01-16-2019 02:49 AM
  8. WheelmanM80's Avatar
    @B. Diddy: In Google's Messenger, a small bubble pops up at first that says 30 kb while it's downloading, but yes, if I miss that I save the received image and view the details. Gifs are supposed to play in Messenger, too, and gifs sent to the phone don't play unless the original gif was under 30 kb prior to sending. In Messaging, I can long press the image and choose details to see the file size. I've saved sopictures I've received to my device to verify that it's 30 kb. If I'm sending an image to myself to test, I can long press the image I've sent to see that it's much larger. Verizon has also verified that the full image size has been delivered to my phone via MMS.
    01-16-2019 07:53 AM
  9. WheelmanM80's Avatar
    @ManiacJoe: When I spoke to a Verizon tech (who gave me the idea to switch SIM cards per above), he said that data from the network showed that the full-size MMS files were being delivered to my phone. Yes, I'm trusting Verizon, but I don't know how to confirm any more certainly than that.
    01-16-2019 07:58 AM
  10. B. Diddy's Avatar
    Hmm, strange. You've already tried Safe Mode and a factory reset, so I doubt this will help -- but try the Reset Network Settings option, if present in the Settings>Network​ menu.
    01-16-2019 11:26 AM
  11. WheelmanM80's Avatar
    Nope - same effect... At one point in the past, this wasn't happening. Is there a way to roll back all updates on my phone?
    01-16-2019 02:55 PM
  12. B. Diddy's Avatar
    It's not easy if there isn't a firmware flashing program for the phone, like Odin for Samsung phones. You'd have to root the phone and find the original stock firmware to install.

    What happens if you temporarily delete all other 3rd party messaging apps, and just use the stock messaging app?
    01-16-2019 10:51 PM
  13. WheelmanM80's Avatar
    Immediately after my hard resets, I'd try receiving MMS's, but they were still all 30 KB. Just deleted Signal, Messages, and Textra, but not WhatsApp, then restarted the phone, and the gif I sent myself is still received as less than 30 KB.
    01-16-2019 11:14 PM
  14. B. Diddy's Avatar
    If you're willing, delete WhatsApp as well. I'd be interested to see how the native messaging app functions without any other potential interference.
    01-17-2019 12:10 AM
  15. WheelmanM80's Avatar
    Alright, uninstalled, but no dice. Tried sending the same 121 KB Jonah Jameson laughing gif to myself and the phone receives it at 8 KB.
    01-17-2019 08:05 AM
  16. WheelmanM80's Avatar
    I've also reset Messaging to default settings, cleared data in app settings, cleared its cache, and made sure [allow] "unrestricted data usage" [when data saver is on] is set to on, too. Restarted, tried again, same.
    01-17-2019 08:15 AM
  17. WheelmanM80's Avatar
    Is there any way this would be permissions related?
    01-17-2019 08:17 AM
  18. B. Diddy's Avatar
    Since the app seems to be saving something, it probably wouldn't be a permissions thing. Just to be sure, check to make sure it has Storage permission turned on.
    01-17-2019 11:30 AM
  19. WheelmanM80's Avatar
    Yep, Storage, Contact, Phone, and SMS permissions. "All Permission" shows that it can receive text messages (MMS). Is there a system app that may have that permission that needs it?
    01-17-2019 12:55 PM
  20. B. Diddy's Avatar
    Running out of ideas here. Are you able to check the APN settings to make sure they're correct for Verizon? https://bestmvno.com/apn-settings/ve...-apn-settings/
    01-17-2019 09:30 PM
  21. WheelmanM80's Avatar
    Tried adding three times and after pressing save, nothing shows up in the APN list. Restarted and tried adding the APN again but nothing. This happens with both "settings" and "alternate settings". Any idea how I can add it?
    01-17-2019 09:59 PM
  22. B. Diddy's Avatar
    APN's are always tricky with Verizon phones -- many times, people say they're unable to edit their APNs on Verizon. I haven't been on Verizon for a long time, so I can't provide any direct guidance. You could see if the VZAccess Manager program does anything.
    01-17-2019 11:55 PM
  23. WheelmanM80's Avatar
    I'm working on using VZAccess Manager, but I thought I'd try something else quickly. So this is interesting... I first create a new APN with the settings APN, APN Name, APN Type, and MMSC, then save it, and it shows up in the APN list. By default, an MMS port is not set (could be the issue?), MCC is set to 311, and MNC is set to 480. Your previous link says those settings should be 80, 310, and 12, respectively. When I try to edit any of them and save it, the APN disappears from the list...
    01-18-2019 10:19 AM
  24. WheelmanM80's Avatar
    I just got the suggestion to use Verizon's Messages+ app from the guys over at BESTmvno.com. I've tried to diagnose it with Message+, too, when talking to Verizon. That's actually the first thing they make you do, but it didn't change anything before. But of course, since I just downloaded it to check again, somehow I can receive MMS messages normally with Message+ now but not with any other texting app that sends MMS messages. This is still a bizarre issue that didn't exist when I bought the phone years ago, but it's definitely not as urgent to find a solution.

    @B. Diddy and @ManiacJoe, Thank you very much for your time.
    B. Diddy likes this.
    01-19-2019 03:27 PM

Similar Threads

  1. Pictures taken with the camera continuously loading in photo app
    By Android Central Question in forum Ask a Question
    Replies: 22
    Last Post: 01-29-2019, 08:47 AM
  2. can't send a picture in sms
    By robinhelenehebert in forum Google Pixel 3 & Pixel 3 XL
    Replies: 13
    Last Post: 01-15-2019, 04:37 PM
  3. I am on a group message,they received my messagr but i di not receive theres
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-15-2019, 11:30 AM
  4. ZTE: Apps won't download/update while on WiFi
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-15-2019, 07:43 AM
  5. why wont my zte blade download an app immediately?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-15-2019, 12:09 AM
LINK TO POST COPIED TO CLIPBOARD