1. Goznya's Avatar
    I just got the OTA for Oreo on my Pixel XL and every time I get a message through Facebook messenger a vital sign icon pops up and says messenger is running in the background, tap for details about battery and data usage. Does anyone know how to stop this and is anyone else having these problems?
    08-23-2017 02:41 PM
  2. N4Newbie's Avatar
    There is no way to get rid of those "background process" notifications. Better to get rid of Facebook Messenger, anyway, since it is a notoriously troublesome app.
    Goznya likes this.
    08-23-2017 03:17 PM
  3. Goznya's Avatar
    Well that sucks. I just don't understand why it does that and only for that app. Am I not on the official version of Oreo? This is the build number I'm running OPR6.170623.012. is it a beta version?
    08-23-2017 07:14 PM
  4. N4Newbie's Avatar
    Well that sucks. I just don't understand why it does that and only for that app. Am I not on the official version of Oreo? This is the build number I'm running OPR6.170623.012. is it a beta version?
    It is not just that app.

    I use an app called Stay Alive and another called PIA VPN and I have persistent notifications for both because both run constantly in the background.
    Goznya likes this.
    08-23-2017 07:16 PM
  5. rbell2915's Avatar
    I have this as well and it's incredibly annoying.
    Goznya likes this.
    08-24-2017 02:48 AM
  6. Goznya's Avatar
    yes it's very annoying! I'm glad I have it just on 1 app so far and this new Oreo isn't very stable, I've had quite a lot problems since I gotten it or maybe it's just the apps not being fully supported yet. who knows. it seems like everytime I update an app or my OS, I have a lot of issues until the next update come out. after all this time you'd think they'd have it figured out by now. lol
    08-24-2017 03:07 AM
  7. kuykendallc's Avatar
    You can change the notification channel settings for apps running into the background to low. Which will change the setting to No sound or visual interruption. This will remove that persistent notification.
    08-29-2017 02:09 PM
  8. N4Newbie's Avatar
    You can change the notification channel settings for apps running into the background to low. Which will change the setting to No sound or visual interruption. This will remove that persistent notification.
    I don't see any such option - can you explain further?
    08-29-2017 02:16 PM
  9. KrisYYC's Avatar
    I'm having the same problem except the warning is for the Gmail app.

    I actually don't use Gmail anymore after I switch to Outlook. But since Oreo Gmail has been going bonkers. Every 5 mins giving me an new email notification even though it was already read etc. Had to force stop it once. I turned off notifications for Gmail, then the app had an update which seemed to solve the notification problem from Gmail, however I'm still getting the system notification about Gmail running in the background. I'd rather not have an app I don't use constantly run in the background. Is is safe to disable Gmail?
    08-31-2017 04:52 AM
  10. N4Newbie's Avatar
    One thing I don't understand - why are you getting notifications about Gmail running in the background? I do use Gmail but have never seen such a notification - just new mail alerts.
    08-31-2017 04:56 AM
  11. Goznya's Avatar
    I've looked everywhere and found nothing to silence it. I can other apps just not messenger.
    08-31-2017 04:57 AM
  12. N4Newbie's Avatar
    Kris - did you delete your account from Gmail? If not, that would be why you continue to receive new email alerts.
    08-31-2017 05:00 AM
  13. Goznya's Avatar
    I figured it out! Thank you.
    08-31-2017 12:29 PM
  14. KrisYYC's Avatar
    One thing I don't understand - why are you getting notifications about Gmail running in the background? I do use Gmail but have never seen such a notification - just new mail alerts.
    I don't know why I was either. And it was pushing the same notification over and over again, even when I wasn't getting new emails. I never had this problem with Nougat.

    Anyway I disabled Gmail and that seems to have fixed it. I'm no longer getting the system warnings about Gmail in the background and the Gmail app has been reset to factory.
    08-31-2017 03:10 PM
  15. jerrod6's Avatar
    You figured it out, so what was causing this problem?
    08-31-2017 03:12 PM
  16. Tommy3141's Avatar
    Here's how you change SYSTEM notifications.. Settings, Apps & Notifications, click Notifications, then Notifications (yes again) upper right 3 dot menu - click "show system" (will display "hide system") , find Android System, Notifications, then find the offending function and set priority to LOW... I did it with both the background tasks notification and the Lost Data Connection ones.
    09-03-2017 09:31 AM

Similar Threads

  1. Notification Access-Android System on Honor 9
    By AC Question in forum Honor 9
    Replies: 6
    Last Post: 09-14-2017, 12:09 AM
  2. Mic issue in Moto m after system update
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-23-2017, 10:32 PM
  3. Replies: 2
    Last Post: 08-23-2017, 04:29 PM
  4. voice mail cuts off-service or Samsung issue?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-23-2017, 02:32 PM
LINK TO POST COPIED TO CLIPBOARD