1. Natenotnat's Avatar
    My company uses an Exchange email server and I use the outlook app on my phone. After upgrading to Android 8.0 Oreo my work contacts no longer sync, so the call log and text messages just show phone numbers. Prior to Oreo, Outlook showed up in Settings -> Accounts, and that's where the setting was to sync contacts, but now Outlook is not there. Other accounts show up like Gmail, Dropbox and Twitter.

    I've tried adding the account from within the Outlook app and by using "+ Add Account" under the list of android accounts. When I use this second method with the account already added I get a brief message saying that the account already exists. When I use the second method without the account already added, it goes back to the home screen with no message. Outlook email then works but the account doesn't show up in settings and I can't sync contacts.

    Outlook support wasn't able to help, claims it must be Google Android 8.

    Using Pixel with Verizon. Thanks in advance.
    09-23-2017 03:48 PM
  2. PJRed2008's Avatar
    Is the Exchange account secured? I would assume it is, have you checked with your work IS&T department to see if their account is compatible with Oreo?
    09-23-2017 03:52 PM
  3. matty032's Avatar
    This isn't an answer to your problem, but have you tried using GMail for your Exchange account? The contacts, tasks, and calendar events all sync correctly with the apps on the phone. And you can quickly flip from GMail to Exchange Inboxes, or combine the two. I never could get Outlook app to fully integrate with the phone.
    09-28-2017 01:52 AM
  4. davessh's Avatar
    Hello! Had to joint this forum as I'm having the same problem but with Android 7.0 had to re-install the Outlook app and it doesn't appear in settings anymore. Gives me the same message about it already existing if I try to add it. Not sure what's wrong but without the menu item I can't sync the contacts with my phone.
    09-29-2017 03:33 PM
  5. thelordsmurf's Avatar
    This is the same issue I'm having on the Pixel 2 XL - wasn't an issue in the previous android!!!!
    11-17-2017 07:30 PM
  6. Brian Child's Avatar
    Same issue that I am having on all Pixel 2 XL phones. I assume it is an issue between android 8.0 and the outlook app. Not sure if Microsoft or Google needs to fix this problem.
    11-29-2017 04:25 PM
  7. Scott Brenneisen's Avatar
    Im having same issue. my solution for myself is to add work account to gmail app and simply not use gmail app for my work email account which is accessible through outlook app because i dont like the way my settings are with gmail on work emails. so I dont access that account when using gmail for personal emails. not very good prose but wanted to share this quickly without proofreading every damn word. sorry. hope it helps.
    12-14-2017 04:56 PM
  8. jleebiker's Avatar
    Had a similar issue. Thought I would share my experience.
    We were on a hosted Exchange server. I was able to use Outlook for Droid and then all of a sudden, it didn't work. Deleted the account and added as a Gmail account and boom, it worked again.
    We then moved to O365 which is in the cloud and off the hosted Exchange server. Deleted the Gmail account and re-added as an Outlook account and it works great now.

    It would seem that the Gmail account will connect to an Exchange server provided that the security settings allow it.
    12-26-2017 04:17 PM
  9. Alan Hanssen's Avatar
    Had a similar issue. Thought I would share my experience.
    We were on a hosted Exchange server. I was able to use Outlook for Droid and then all of a sudden, it didn't work. Deleted the account and added as a Gmail account and boom, it worked again.
    We then moved to O365 which is in the cloud and off the hosted Exchange server. Deleted the Gmail account and re-added as an Outlook account and it works great now.

    It would seem that the Gmail account will connect to an Exchange server provided that the security settings allow it.
    I solved by going to the Outlook app, tap on settings, then I picked the account with the contacts I wanted to sync by tapping on it [account info] and here there was.. An unselected option to sync contacts.
    All my contacts appeared afterwards, I just had to do some extra steps to set it as the default account.

    I just recently moved from EMUI to pure android, and I didn't have to do this extra steps.
    01-27-2018 01:42 PM
  10. nitinpatel1117's Avatar
    I had the same problem on my huawai p20 pro. I moved from using a windows phone to android phone
    after a few painful hours of head scratching managed to solve it.

    The below worked for me.

    On andriod phone I went to setting >> user and account And then removed all references of my hotmail email address that I had already setup.

    Next I signed into hotmail using a web browser and when to Options >> Mail >> Accounts >> POP and IMAP
    And then selected ‘Yes’ for ‘let devices and apps use Pop’
    And also selected ‘yes’ for ‘let apps and devices delete messages from outlook’
    Then press SAVE.

    Then go back to android phone and in contacts app, go to link via account, and select exchange.
    Enter your email and password. And then HOLA next screen will ask if you want to sync your contacts and calendar entries along with your email.

    Anyway hope that helps someone, I spent hours trying to figure this thing out.
    07-04-2018 05:42 PM

Similar Threads

  1. Huawei Mate 9 to receive Android 8.0 Oreo update soon.
    By Gayle Lynn in forum Huawei Mate 9
    Replies: 67
    Last Post: 12-07-2017, 01:49 AM
  2. Passport not working in browser
    By Rinsun in forum Site Feedback & Help
    Replies: 16
    Last Post: 09-23-2017, 09:51 PM
  3. Android Auto, Where is it
    By dlcpa in forum Android Auto
    Replies: 2
    Last Post: 09-23-2017, 06:55 PM
  4. Phone won't stay in MTP mode
    By hzemall in forum General Help and How To
    Replies: 1
    Last Post: 09-23-2017, 06:29 PM
  5. Replies: 0
    Last Post: 09-23-2017, 02:26 PM
LINK TO POST COPIED TO CLIPBOARD