1. Markocerce's Avatar
    Not sure why but since the update to 8.0, my phone works slower. I'm on Huawei p10 pro, and I even factory reset the phone shortly before doing this update with the intention to get flawless performance. Performance optimisation got to 95% before, post update I haven't seen it go above 81%. What could be causing this?
    10-18-2018 11:23 AM
  2. methodman89's Avatar
    After the update, clear the cache partition and reboot.
    10-18-2018 12:09 PM
  3. Dspopieux's Avatar
    Usually it's better to factory reset after the updates.
    10-18-2018 12:10 PM
  4. methodman89's Avatar
    Why would you go straight to a factory reset with all that entails without first taking 2 minutes to follow the algorithm and clear the cache partition? That's alot of potentially wasted time.
    Usually it's better to factory reset after the updates.
    10-18-2018 12:19 PM
  5. Morty2264's Avatar
    I see you are a new user here - welcome to Android Central! I too recommend clearing the cache and then restarting your phone. See if the issue still persists in Safe Mode.

    Keep us posted on what happens!
    10-18-2018 12:20 PM
  6. Dspopieux's Avatar
    Well it's an extreme measure but it works most of the times.
    Why would you go straight to a factory reset with all that entails without first taking 2 minutes to follow the algorithm and clear the cache partition? That's alot of potentially wasted time.
    10-18-2018 12:25 PM
  7. Markocerce's Avatar
    Hmm, first time I hear of clear the cache partition. Will do it, as soon as I get the power button fixed as it's currently not working so I can't access that menu at the moment. Thanks for the advice.
    10-18-2018 02:15 PM
  8. methodman89's Avatar
    Hmm, first time I hear of clear the cache partition. Will do it, as soon as I get the power button fixed as it's currently not working so I can't access that menu at the moment. Thanks for the advice.
    That would have been good to know in the op
    10-18-2018 02:21 PM
  9. Markocerce's Avatar
    Ok, cleared the cache partition now and the result is the same. Still doesn't go above 80%.

    Any other ideas?

    Edit: Strange, just went through the phones performance optimisation where it scans for viruses and after it found 0 and finished the process, performance showed 98%. I'll update on this tomorrow when I see if apps like Instagram or Line still respond as slow as they have last couple of weeks.
    10-24-2018 12:05 PM

Similar Threads

  1. why does my phone have a greyish screen overlay on all screens?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2018, 02:34 AM
  2. Chrome is missing from my phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-19-2018, 12:22 PM
  3. USB debugging and new files on my phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-19-2018, 12:12 PM
  4. Issue related to not factory reseting the phone and google account
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-18-2018, 06:54 AM
  5. How can I figure out if my android phone and data has been hacked or redirected?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-18-2018, 01:30 AM
LINK TO POST COPIED TO CLIPBOARD