1. salanester's Avatar
    I keep getting an error message when I try to add a picture and sound file that it can't send to the phone. Everything else shows up on the phone just fine (labels, buttons) so I am connected. Anyone else having any problems? (using mac version btw)
    08-18-2010 09:29 PM
  2. Kyle Gibb's Avatar
    Me too. I looked up the FAQs and I think the issue is that OSX automatically mounts your SD card. App Inventor requires access to the SD card to store resources. Not sure how to prevent it... any ideas?
    08-18-2010 09:33 PM
  3. salanester's Avatar
    Me too. I looked up the FAQs and I think the issue is that OSX automatically mounts your SD card. App Inventor requires access to the SD card to store resources. Not sure how to prevent it... any ideas?
    I just noticed the SD card issue; I have no idea! I joined the group suggested and am looking now for a fix. Let me know if you find anything.
    08-18-2010 09:35 PM
  4. Jerry Hildenbrand's Avatar
    Try this
    Connect phone to your computer.
    Turn off USB storage
    Turn off USB Debugging
    Turn ON USB Debugging
    open app inventor
    open the block editor

    Had to do this when using doubletwist and having it set to auto mount and sync when plugged in
    salanester likes this.
    08-18-2010 09:45 PM
  5. Kyle Gibb's Avatar
    Just posted a new thread on the issue. Hopefully I will get a solution soon.
    salanester likes this.
    08-18-2010 09:48 PM
  6. salanester's Avatar
    Tried that...no luck.

    I did just learn and test it that if you package app and install it works fine since the media gets included in the .apk. Problem with this will be testing before packaging and sending to phone.
    08-18-2010 09:48 PM
  7. Kyle Gibb's Avatar
    Try this
    Connect phone to your computer.
    Turn off USB storage
    Turn off USB Debugging
    Turn ON USB Debugging
    open app inventor
    open the block editor

    Had to do this when using doubletwist and having it set to auto mount and sync when plugged in
    I have the phone set to "charge only" already. It only prevents the internal 8GB from being mounted, not the external.
    08-18-2010 09:51 PM
  8. Jerry Hildenbrand's Avatar
    idea #2
    Does MacOS use udev rules?
    if so, they may need edited. Look for /etc/udev/rules.d/ and see if xx-android.rules. exists. (xx = 51 on linux, may be different on a Mac)
    08-18-2010 10:03 PM
  9. salanester's Avatar
    Try this
    Connect phone to your computer.
    Turn off USB storage
    Turn off USB Debugging
    Turn ON USB Debugging
    open app inventor
    open the block editor

    Had to do this when using doubletwist and having it set to auto mount and sync when plugged in
    I stand corrected; this just worked perfectly for me!
    08-18-2010 10:10 PM
  10. Jerry Hildenbrand's Avatar
    I stand corrected; this just worked perfectly for me!
    Sweet. I think Kyle's going to have to do this AND figure out how to keep both SD card and internal storage from mounting, since he is using a Dinc
    08-18-2010 10:19 PM
  11. Kyle Gibb's Avatar
    Sweet. I think Kyle's going to have to do this AND figure out how to keep both SD card and internal storage from mounting, since he is using a Dinc
    Lol such a ridiculous issue "how to I force my computer not to access storage devices when I plug them into the USB ports".
    08-18-2010 10:31 PM
  12. Sonicaholic's Avatar
    Lol such a ridiculous issue "how to I force my computer not to access storage devices when I plug them into the USB ports".
    Try threataning it with being replaced with a vista machine they hate reading anythink including there own OS :O
    08-19-2010 08:24 PM
LINK TO POST COPIED TO CLIPBOARD