1. Trekker's Avatar
    I have a Sprint Epic 4G and I just updated to Gingerbread and then rooted the phone.

    I'm showing that I have an update in the Android Market for Sprint TeleNav GPS Navigator but when I click on the update it says my device is not compatible with this item.

    Anyone else have this issue?
    11-12-2011 11:17 AM
LINK TO POST COPIED TO CLIPBOARD