1. katie_dee's Avatar
    I recently bought galaxy s2 off my friend, and I cannot log into the Facebook app. Everytime I try to log in it says Facebook authentication failed. When I try to log into facebook through the internet app, it says access denied and it has a long message about verifying my age and that the app is unsuitable for under 15s. I looked everywhere but there is no place where I can set my age. I tried to delete and install the app again but nothing works...any suggestions how to fix it?
    12-29-2011 01:23 PM
  2. RUSH's Avatar
    I had this problem happening to me the other day...it was really annoying. Are you using the Facebook for Android app? If so, then follow my steps to get this problem eradicated. Step (1) Log into your Facebook account via desktop/pc version. Step (2) Request a password change (your password has somehow been compromised - doesn't necessarily means that it was hacked). Step (3) Uninstall/reinstall any Facebook application you're currently using (it's better to use the facebook for android application). Step (4) Sign into your Facebook account and enjoy! You're welcome.
    12-29-2011 07:13 PM
  3. Sunxchyn's Avatar
    I have the same problem, but I tried this and it still doesn't work. My fiance can log on to his account from my phone, I just can't log on mine.
    02-03-2012 11:03 AM
  4. jb12780's Avatar
    They updated a version on the 2nd, and it I got the same message. Cleared data, cache, the whole 9 yards. Any suggestions?
    02-04-2012 04:00 PM
  5. mtkregs's Avatar
    I was having the same problem on my Galaxy Nexus...very frustrating.

    Here's what I did to get mine to work again...I installed Seesmic. Then, I added my FB account to Seesmic, signed in, and authorized access permissions. That worked. I was then able to successfully log into my Facebook for Android app without receiving the "authentication failed" error.

    I don't know why it worked...but, it worked. Oh, also, I uninstalled Seesmic and everything still works fine with the Facebook for Android app.

    Edit: Feb 8...it started failing again today. I have come to the conclusion that the FB app sucks.
    02-05-2012 08:20 AM
  6. Ravi Suthar's Avatar
    same happening with anroid fb app , anybody can log in from that app but every times i tries authentication failed.....changed password, uninstalled and installed application but is not happening .........so pls suggest me some way to get rid if this!!
    08-26-2013 08:14 PM
  7. phils801's Avatar
    Does anyone play slotomania on droid raxor m??????
    08-26-2013 08:21 PM