1. stormed's Avatar
    I'm having a heck of a time trying to get the INC to utilize K9's IDLE push feature against my IMAP server.

    IMAP server: imapd-wu and I have confirmed that IDLE is implemented:
    K9 version: 2710

    When I telnet to the imap server and login I get the following capability reading:

    001 OK [CAPABILITY IMAP4REV1 I18NLEVEL=1 LITERAL+ IDLE UIDPLUS NAMESPACE CHILDREN MAILBOX-REFERRALS BINARY UNSELECT ESEARCH WITHIN SCAN SORT THREAD=REFERENCES THREAD=ORDEREDSUBJECT MULTIAPPEND] User blahblah authenticated

    I then select my INBOX then do an IDLE check:

    004 IDLE
    + Waiting for DONE

    * 3487 EXISTS
    * 1 RECENT


    So from that, it looks like idle works fine.


    However, from K9 with the following settings:

    Account settings->Syncing folders
    Folder polling check frequency = never
    Folder to check with poll = none
    Folder to check with push = Only 1st class folders

    Folder settings -> INBOX ->
    Folder display class = 1st
    Folder sync class = 1st
    Folder push class = 1st

    With these settings, I was hoping that my test email to this account would go through but the only way I can get a new message to come through is by doing a manual "check mail"


    Anyone see what I may be doing incorrectly?


    Thanks
    06-09-2010 04:23 PM
  2. icebike's Avatar
    First, make sure you removed all the settings from the stock mail app.
    Then pop to airplane mode to kill off any sockets open to your mail server.

    When you look at your folder list the word Push should appear under the folder name in gray print.

    Set a default account.
    Make sure Max folders to check with Push is some positive number, maybe 5.
    Make sure to check New Mail notifications, set a ring tone and maybe vibrate.
    Check Sync notifications (not actually necessary but nice).

    Then run a test, send yourself some mail from some other account, gmail or something.
    Look at your k9 Mail-errors for obvious symptoms.
    06-09-2010 06:28 PM
  3. stormed's Avatar
    Thanks for the help

    I've done most of what you have said. I did have a question about

    "Make sure Max folders to check with Push is some positive number, maybe 5"

    Where can I find this? The closet thing I see is "Folders to check with push" but the only selections there deal with folder classes


    One other thing, do you have to set anything special for the section Background sync to have this work automatically?
    06-09-2010 08:19 PM
  4. icebike's Avatar
    On my N1, Under Account Settings / Sync Folders I have:

    Folder Poll Check Frequency
    Folders to check with polling
    Folders to check with push
    Max folders th check with Push <-----
    When I delete...
    Expunge messages
    Incoming server


    Those are listed in that order.
    My version says Version 2.600 in Application Info under Manage Applications.
    Perhaps we have different versions.

    I see you have 2710.

    I generally don't install release they don't think enough of to even write up a release note.
    06-09-2010 08:33 PM
  5. stormed's Avatar
    Yea, should be similar though - I just pulled the latest build off of the dev site Downloads - k9mail - Project Hosting on Google Code

    Possibly something broke at this version...I'll try downgrading

    Thanks again
    06-09-2010 08:38 PM
LINK TO POST COPIED TO CLIPBOARD