1. its_lucky's Avatar
    when I try to make an in-app purchase it wont let me change the google account.
    anyone know how to fix this?

    why it matters, I want to use the account that still has some available google play credits.
    every time I try to do the in-app purchase it defaults to one of my other google accounts without the option to change it...

    Thanks in advance for any help!
    08-27-2012 06:43 PM
  2. Tami50's Avatar
    How to pays for it apps purchase my debit card how to find them
    09-05-2012 12:55 PM
  3. SquareWide's Avatar
    I think you're linked by your phone.
    You'd have to use the other phone.
    09-14-2012 04:12 PM
  4. sashreekrd7's Avatar
    Try these,
    1.Download the app from the google account with the credits.
    2.Delete the google account without credits so that it is forced to use the only google account.
    its_lucky likes this.
    10-16-2012 12:36 PM
  5. its_lucky's Avatar
    Try these,
    1.Download the app from the google account with the credits.
    2.Delete the google account without credits so that it is forced to use the only google account.
    thanks for the advice sashreekrd7!
    I did something similar to that. but since it's an "in-app" purchase my only work-around was to remove the account it keep defaulting to, then go into the app to make the purchase, then just re-added the account again. I need to do that every time I want to make an in-app purchase from that specific account, it doesn't 'stick' to the other account. for some reason it really like that one account. lol.

    unnecessary extra info: the reason it was such a pain is because many of my clients use Google apps and i've just been too busy/lazy (depending on how you want to look at it, haha) to setup forwarding/merging all the accounts. I have at least 6 different email accounts I manage on this phone. lol.
    10-18-2012 06:31 PM
  6. squibby99's Avatar
    Hey there, did you find an answer to your question? I'm having the same issue and haven't found an effective solution!
    06-28-2013 09:29 AM
  7. YehoshuaL's Avatar
    1) uninstall the app
    2) go to play store and switch to the account you want to use to pay from
    3) find the app in play store and install again
    4) make your in-app purchase
    06-30-2014 04:49 PM
  8. FlexDominoNet's Avatar
    Doesn't work for me. After re-installation under correct account the in-app dialog still selects wrong account.
    11-21-2014 04:19 AM
  9. keymaster89's Avatar
    Late to the party... I was having the same issue. Then I tried uninstalling it, and installing the app, in my case NiLS, using play.google.com rather than from within the phone. It worked for me.
    02-06-2015 12:24 PM
  10. djrobinn's Avatar
    I had the same issue and it seems that if you install using the account with the credits from a BROWSER, it works okay... I used my PC to 'push' it to my phone and it worked well... Just don't use the Play store app on the phone and it'll be okay. Good luck!
    05-01-2015 07:47 AM
  11. aarud's Avatar
    In case anyone finds this in the future, here's a solution to get to your main account if it's defaulting to a subsidiary, without uninstalling. Note that this may adversely affect games...try just doing cache if you're afraid of erasing data
    -go into settings
    -clear cache AND data for both the offending app and Google Play Store
    -force both apps to stop
    -reenter app. Play Store will default the main account for your phone
    06-11-2016 12:06 PM
  12. Angeliqu3's Avatar
    I'm aware that this topic is old but I did recently came across this same problem. I have a Samsung galaxy s4. What I did was..

    Went into settings> account tab....
    Then deleted that account so that my phone would make the account I want as primary. Then tried to checked out, drop down menu showed the correct email account to use so I can Inga me purchase.

    Unfortunately, i have not figured out how else to switch/make the correct account want as primary without deleting it yet. Goodluck.
    07-25-2016 01:07 AM
  13. Blue Ciper's Avatar
    This worked for me:

    Unistall on android device.
    Signon Web Google Play with account you want to charge.
    Select App on Web and, Install there.
    Android device will now load the app and account used on web is the in-app payment account

    (btw: great way to get points of abandoned accounts you have)
    do above with old account to get the account to point to old account
    unistall again,
    re-install from web with current account.
    08-07-2016 07:03 PM
  14. Memes40284's Avatar
    try the app parrlall space
    11-21-2016 04:04 AM
  15. NoteNoPower's Avatar
    try the app parrlall space
    I tried Parallel Space, DO Multiple Accounts, and Multi Parallel, but none worked. Specifically, I installed the apps through play.google.com using the secondary account (the one I want to use for the in-app purchase). When I tried to do an IAP inside the cloned app, an "Initiating payment" bubble appears and disappears, then nothing. I suspect it is not possible to do in-app purchases from inside any cloned app.
    11-21-2019 08:29 PM