1. jnick#AC's Avatar
    I am using K-9 Mail to deal with my personal RoadRunner Account (POP3). It is receiving messages beautifully...However, sending messages is another story.

    If I am NOT connected to my home network (wifi) I am not able to send any messages through RoadRunner. This is because RoadRunner only allows the use of their SMTP server if you are on their network. Therefore, If I am out and about, or at my parents house, I am not able to send emails. Is there a default SMTP server that verizon allows mobile users to use? Or is there a way to use GMAILs SMTP server to send my roadrunner emails?

    I never had this issue when on my Storm, using my roadrunner account...this would tell me Verizon has to have some default SMTP server fo mobile customers?

    Any help is appreciated...

    Thank you,
    07-09-2010 12:52 PM
  2. Qazme's Avatar
    Redirect and verify your roadrunner account with Gmail. It's in the settings for gmail. Then you can send and receive from Gmail, still send email as your Roadrunner account and get the benefits from gmail push!
    07-09-2010 01:24 PM
  3. jnick#AC's Avatar
    Eh...I tried doing that and it totally screwed things up with my hotmail account. I also use Outlook as my client for my Desktop PC. When it I redirected hotmail to GMail...It polled to frequently and wound up locking me out of my account for 25ish minutes. also, I REALLY like the K-9 app and would rather use that than the GMail app. There's no way to only use GMail to SEND messages as my roadrunner account instead of receive as well?

    Or if I have to use GMail as my server, can I still setup and use K-9 instead of the GMail app on the phone?
    07-09-2010 05:11 PM
  4. jnick#AC's Avatar
    Anyone?
    07-11-2010 10:35 AM
  5. PhantomPhreak53's Avatar
    Cell phone providers won't have a smtp server to use. You can do a Google search for free smtp servers or find a friend that has an open one. I run my own email server so I just use mine.
    07-11-2010 10:44 AM
  6. jnick#AC's Avatar
    Thanks for the response. I guess I could turn my server into an email server as well, but I wasn't quiet ready to dive into that project yet, hehe. Is there anyway to use gmail, but only their smtp server? I really don't want to forward all of my mail too gmail unless I have to. Plus, I absolutely love K-9 mail and don't really want to stop using it.

    There's no way to somehow strictly send my roadrunners email through gmail but still receive mail through RRs pop-server?
    07-11-2010 10:50 AM
  7. Geezer Squid's Avatar
    Have you tried using port 587?
    07-11-2010 11:04 AM
  8. jnick#AC's Avatar
    Through roadrunners smtp server?
    07-11-2010 08:34 PM
  9. nneptune's Avatar
    I'm sorry for not being very helpful here, but I also LOVE K-9... just wish it wasn't so hard on the battery (though it could be a LOT worse!).

    I tried the forwarding to GMail in order to get push e-mail, but I just had to go back to K-9. I like getting my mail asap!

    Good luck with the server issue. I would think Roadrunner would have an outgoing server. It's probably a matter of finding the correct port.
    07-11-2010 10:51 PM
  10. lostinspace's Avatar
    I'm also using K9 for 3 accounts, two on my own pop3 server, one on gmail. I do NOT use the gmail push, but that account is configured in gmail so I can treat it like a "regular" pop email account. As a test I changed the account settings for one of the pop3 accounts to use the gmail server for outgoing mail, then composed and sent an email from K9 and it sent successfully. When received on my desktop that email showed it was from my pop3 address, but the headers show it was actually by the gmail account. I used the following outgoing server settings on the pop3 account:

    Server: smtp.gmail.com
    Sec: TLS
    Port: 25
    Requires sign in checked
    Authentication: CRAM_MD5
    Username
    Password
    07-12-2010 10:04 AM
  11. PhantomPhreak53's Avatar
    I'm pretty sure RoadRunner is like Comcast and they won't let you use there SMTP server unless you are on there network.

    Gmail SMTP server does work but I'm pretty sure no matter what email address you send from, it changes your email address to your google email address.
    07-12-2010 11:04 AM
  12. jnick#AC's Avatar
    I'm also using K9 for 3 accounts, two on my own pop3 server, one on gmail. I do NOT use the gmail push, but that account is configured in gmail so I can treat it like a "regular" pop email account. As a test I changed the account settings for one of the pop3 accounts to use the gmail server for outgoing mail, then composed and sent an email from K9 and it sent successfully. When received on my desktop that email showed it was from my pop3 address, but the headers show it was actually by the gmail account. I used the following outgoing server settings on the pop3 account:

    Server: smtp.gmail.com
    Sec: TLS
    Port: 25
    Requires sign in checked
    Authentication: CRAM_MD5
    Username
    Password
    Thank you for the walkthrough! I'll try it out...when you say username and password I'm assuming you are referring to my gmail account
    ?
    07-12-2010 08:44 PM
  13. nightfishing#AC's Avatar
    Thanks for the response. I guess I could turn my server into an email server as well, but I wasn't quiet ready to dive into that project yet, hehe. Is there anyway to use gmail, but only their smtp server? I really don't want to forward all of my mail too gmail unless I have to. Plus, I absolutely love K-9 mail and don't really want to stop using it.

    There's no way to somehow strictly send my roadrunners email through gmail but still receive mail through RRs pop-server?
    Any reason you want to keep using the rr account?

    As mentioned, It is not a K-9 or an Android issue, the same issue is present with many rr accounts when not on a rr network (I used to see it all the time on hotel/public wifi's etc.)

    I long since just stopped using the rr mail accounts. gmail is free, you can have unlimited accounts and it fully supports IMAP Idle, so there are no PUSH issues.

    If you want to keep the rr mail account, I would suggest setting up one of your gmail account s to poll your roadrunner account see SETTINGS>ACCOUNTS "check mail using POP3"

    That way the mail will come in "normally" but when you compose/reply/forward you will be using the gmail servers.
    07-17-2010 09:19 AM
  14. jnick#AC's Avatar
    My concern is that I've had my rr account for roughly 8 or so years now. I dont want to have to switch all of my information over to gmail. so, if I am forced to use gmail...

    1. Can I set it up so it does not impact my pc with Outlook configured, or my Macbook with mail configured? Can I make it so only the incredible sends through gmail? also, can I configure it so gmail does not pull messages OFF of RRs servers? Otherwise it will hinder the operation of my PC and Macbook.

    2. Can I still use K-9 mail instead of gmail app?

    Sorry for the plethora of questions. as much as I am an IT technician, I have had zero experience with using gmail with other accounts and I really cannot take the chance of losing any email data in the migration.

    Also, if I were to use gmail why would I want to NOT use PUSH? I would think push email would give better battery performance than polling every 10 minutes...?

    Thank you!
    07-17-2010 12:36 PM
  15. Hoppy's Avatar
    I was having the same issue setting up my Roadrunner email account on my LG Ally but then I remembered that Roadrunner doesn't require SMTP authenication. I unchecked the "Require sign-in" under Outgoing server settings and that fixed my issue. See if that works for you.
    07-18-2010 01:53 PM
  16. jnick#AC's Avatar
    I already had it set that way...

    You can send messages through RRs SMTP server while roaming (meaning on 3G, NOT on your home WiFi network)?
    07-21-2010 08:02 PM
  17. maildroiddev's Avatar
    OK, I am more of a fan of MailDroid ;-) But really, if you like k-9 that is great :-) Try this setting for rr smtp:

    smtp-server.si.rr.com
    port 587
    ssl true
    07-21-2010 10:04 PM
  18. takeshi's Avatar
    I never had this issue when on my Storm, using my roadrunner account...this would tell me Verizon has to have some default SMTP server fo mobile customers?
    Not quite. BIS doesn't use your SMTP server. It's not really relevant.
    07-22-2010 09:06 AM
  19. jbudilov's Avatar
    I'm trying to set this up using my work 2003 MS exchange server. I'm having no trouble getting the emails to come into my account. It syncs quickly and the emails are coming in fine. The problems I am having are with sending mail from the account. For some reason they just SIT in the outbox and never get sent. Even if I try and manually push "send mail." HELP! If I can't get this to work I'll have to return the phone. I'm willing to download and pay for an exchange app from the marketplace too but can't get any of those to work either. SOS!
    11-01-2010 07:21 AM
  20. takeshi's Avatar
    Exchange is a completely different topic unless you're accessing your Exchange server via POP. You really should start a new thread.
    11-01-2010 07:31 AM
LINK TO POST COPIED TO CLIPBOARD