1. noshooz's Avatar
    I installed the SiriusXM online app for my Evo and have noticed that it will only play content if I'm on wi-fi. When on 3G it keeps saying there is no data connection, but the channel content will update. I uninstalled/reinstalled, and the glitch persists. Does this mean that the app will only play on wi-fi? If so, this sucks, because I was hoping to use it on the drive to work to listen to a channel that's not available on the radio (Viva).
    07-20-2010 08:56 PM
  2. Chillout80s's Avatar
    I have the sirius app and it plays over 3G just fine on my droid. I use it all the time when Im in my truck (my car has the sirius radio in it but the truck doesn't).
    07-20-2010 08:57 PM
  3. terpitude71's Avatar
    works fine on 3g here too. are you sure youre getting a good 3g connection?
    07-20-2010 09:14 PM
  4. jaihawk's Avatar
    I use this app on a daily basis from my office, which gets 1-2 bars on the 3G network and has no wireless network. I stream it all day long and have only the occasional drop-out (maybe 1 every hour), but otherwise it works perfectly for me.
    07-21-2010 10:22 AM
  5. noshooz's Avatar
    OK, then this is strange. It won't even work on 3G when I have four bars. Keeps saying there is no data connection. Very frustrating!! There obviously is a fix for this issue, I just have to find it. Perhaps there is a folder on the SD card that contains data from the app that I need to erase when uninstalling it.
    07-21-2010 03:11 PM
  6. dfine1966's Avatar
    I have an EVO and no problems with 3G at all with the Sirius App. It sounds like a problem with your phone. Did you restart your phone and then try to connect to the internet first, just to make sure 3G is working. If that works then try the Sirius App. Also, try updating your phone's profile and PRL update and see if that works.
    07-21-2010 04:57 PM
  7. noshooz's Avatar
    I've restarted, 3G works for everything else. As I mentioned, I can see the song listings updating, but when I try to play anything I get a pop up saying "Data Connection Lost. Trying to Reacquire Connection." And it just cycles that when I tap OK. It will eventually give up and say there is no data network available, which is crap, because I'm using 3G at the time on other apps.
    07-21-2010 05:10 PM
  8. tada1096's Avatar
    a lil off topic but does anyone know why this app isnt in the market?
    07-21-2010 06:03 PM
  9. jaihawk's Avatar
    I'm not sure. Probably to make users that are interested actually go to their site, where they may be able to tempt you with other things.

    Noshooz, have you tried uninstalling the app and then re-installing it? Also, I assume you're running this on Android 2.1?
    07-22-2010 10:40 AM
  10. cobra302's Avatar
    a lil off topic but does anyone know why this app isnt in the market?
    thanks for asking this! i couldnt find it either! thanks for the information on where to find as well
    07-23-2010 12:08 AM
  11. cobra302's Avatar
    well, nevermind, wont install on the captivate....
    07-23-2010 12:11 AM
  12. Corey's Avatar
    The app "works" on 3G on my Droid, but man does it suck. It'll play about ten minutes of content and then get stuck in a loop. It doesn't seem to matter how many bars I have, it just sucks. I tried using it in the car on a trip recently, and even though the route had nearly consistent full service, it would get stuck in the same ten minute loop. I've uninstalled and reinstalled the app, but the problem still persists. It works fine on WiFi, but is all but useless otherwise for me.
    07-23-2010 04:55 AM
  13. jaihawk's Avatar
    The app "works" on 3G on my Droid, but man does it suck. It'll play about ten minutes of content and then get stuck in a loop. It doesn't seem to matter how many bars I have, it just sucks. I tried using it in the car on a trip recently, and even though the route had nearly consistent full service, it would get stuck in the same ten minute loop. I've uninstalled and reinstalled the app, but the problem still persists. It works fine on WiFi, but is all but useless otherwise for me.
    Out of curiosity, are you running Cyogen's Froyo? I have an Evo and SirusXM's app was working perfectly for me. I had never experienced the cycle that you and others have talked about. Last week, I installed Froyo. When I reinstalled the app, I kept getting the cycling problem you referred to. I tried uninstalling and installing the app, but kept getting the same problem.

    I recently went back to a stock rom and installed the SiriuxXM app and it works perfectly again and I haven't experienced the cycle problem once.
    07-23-2010 11:16 AM
  14. Corey's Avatar
    Out of curiosity, are you running Cyogen's Froyo? I have an Evo and SirusXM's app was working perfectly for me. I had never experienced the cycle that you and others have talked about. Last week, I installed Froyo. When I reinstalled the app, I kept getting the cycling problem you referred to. I tried uninstalling and installing the app, but kept getting the same problem.

    I recently went back to a stock rom and installed the SiriuxXM app and it works perfectly again and I haven't experienced the cycle problem once.
    I'm running Kangerade 5.0.9 (CM 6 has been way too buggy for me), but found the problem on Bugless Beast and Simply Stunning as well. If the solution is go back to a stock rom, I'll pass. I'm spoiled by the other roms and have a dedicated XM unit and internet access that I'll be fine with.
    07-23-2010 11:21 AM
  15. tucsonstan's Avatar
    Folks, I've looked on the Market and AppBrain sites and cannot find the xm app, Where am I going wrong??
    07-23-2010 01:51 PM
  16. Corey's Avatar
    Folks, I've looked on the Market and AppBrain sites and cannot find the xm app, Where am I going wrong??
    From your mobile browser, go to http://forums.androidcentral.com/e?l...token=fiXYTY3I and you'll be directed to the link to download the application.
    07-23-2010 02:23 PM
  17. tucsonstan's Avatar
    Corey, thanks a bunch. Thought I might have to do that but was not sure.
    07-23-2010 08:32 PM
  18. risk235's Avatar
    It does the loop with all froyo roms. Sirius XM needs to update their app.
    07-23-2010 09:31 PM
  19. therealwags's Avatar
    FWIW - I spoke with Sirius Customer Service yesterday about getting a credit because their app isn't working and they advised that the updated Android version should be available 8/20...only time will tell though.
    08-17-2010 11:29 AM
  20. KB3MMX's Avatar
    I have the Sirius app on my HTC Droid incredible and it works great, I use it daily on 3G.

    Have you messed with any of your phone settings like mobile network that would cause the 3G data problem?? Seems like you have a great signal but no data connection.
    08-19-2010 08:22 PM
  21. apexi350z's Avatar
    I have the Sirius app on my HTC Droid incredible and it works great, I use it daily on 3G.

    Have you messed with any of your phone settings like mobile network that would cause the 3G data problem?? Seems like you have a great signal but no data connection.
    Is your Droid Incredible still on Rom 2.1? It works fine with 2.1.
    08-20-2010 09:09 PM
  22. KB3MMX's Avatar
    Yes, 2.2 is taking forever to be released on the Incredible for some reason
    08-20-2010 10:17 PM
  23. moosc's Avatar
    My xm app works on my Droid x with 2.2. &i can stream via wifi or 3g.
    08-21-2010 08:45 AM
  24. therealwags's Avatar
    FWIW - I spoke with Sirius Customer Service yesterday about getting a credit because their app isn't working and they advised that the updated Android version should be available 8/20...only time will tell though.
    Needless to say, the updated version isn't out there yet
    08-23-2010 02:24 PM
  25. moosc's Avatar
    What is wrong with the app? It works on my Droid X rooted running 2.2.
    Needless to say, the updated version isn't out there yet
    08-23-2010 02:28 PM
LINK TO POST COPIED TO CLIPBOARD