1. RIncon's Avatar
    One of my favorite features of modern smartphones is the ability to listen to internet radio while I drive/work out.

    Unfortunately, with the EVO, be it on 3g or 4g (I'm in Dallas), I'm unable to maintain a consistent connection through the internet radio apps that I've found (Xiialive, Streamfurious, TuneIn Radio).

    The stream will work for 2 minutes or so and then lose connection.

    The kicker is when I access the radio station through it's website page, it plays uninterruptedly (this is less than ideal, however, as it will stop playing if I turn the screen off).

    Do you guys have any thoughts or ways to get around this? I never had this issue with iPhone apps and my EVO's connection seems better.

    The radio stream in question, if you are interested, is http://listen.radionomy.com/one-summer.m3u .
    09-09-2010 10:55 AM
  2. Gekko's Avatar
    09-09-2010 11:13 AM
  3. HYDE's Avatar
    Unfortunately, with the EVO, be it on 3g or 4g (I'm in Dallas), I'm unable to maintain a consistent connection through the internet radio apps that I've found (Xiialive, Streamfurious, TuneIn Radio).
    It isn't the EVO or the application. I listen to Xiia on my EVO for hours a day and don't have the issues that you mention.
    09-09-2010 11:16 AM
  4. stevied3's Avatar
    I have the same issue with my radio apps on my Evo. I'm using RadioTime and also very bad disconnections on the ESPN Radio App.
    09-09-2010 11:19 AM
  5. RIncon's Avatar
    It isn't the EVO or the application. I listen to Xiia on my EVO for hours a day and don't have the issues that you mention.
    The strange part is that through the web browser the connection is maintained indefinitely but not through the radio.
    09-09-2010 11:53 AM
  6. HYDE's Avatar
    The strange part is that through the web browser the connection is maintained indefinitely but not through the radio.
    Hmmm, is your signal strong in Dallas? I drive 75 miles to work each way and it is very rare that I lose connection on Xiia using 3G.
    09-09-2010 12:03 PM
  7. dagold99's Avatar
    It happens a lot when I am listening to WFAN with Cherry rplayer and yahoo music applications. Does not matter if using wifi or sprint internet.Kind of frustrating.I go to the web too
    09-09-2010 12:22 PM
  8. RIncon's Avatar
    Hmmm, is your signal strong in Dallas? I drive 75 miles to work each way and it is very rare that I lose connection on Xiia using 3G.
    I have a strong signal. I generally keep 4g off to save battery but the 3g connection is very good here... better than the AT&T signal (which is able to keep internet radio connections).

    Again, the thing that is causing me to believe it is some type of App Architecture issue is that it works fine when streamed from the web browser.
    09-09-2010 01:02 PM
  9. shadowgod's Avatar
    RIncon what Android version you have on your EVO with this problem? 2.2 or 2.1?
    09-10-2010 02:56 AM
  10. RIncon's Avatar
    I use version 2.2
    09-16-2010 12:22 PM
  11. shrimpster's Avatar
    So I recently came off of T-Mobile with a G1 phone where I had very little issues with streaming radio. I stream radio in both my car and when I jog. Since I moved over to Sprint, I have noticed that the radio streams keep stopping when I jog and not when I have it in my car.

    The difference? In my car, the phone is stationary and plugged. When I jog, the phone is bouncing around and on battery power.

    Could there be a battery power saving feature that turns off the 3G connection sporadically? This is my theory now. Will have to see what happens when I drive without it plugged in.
    10-22-2010 09:08 AM
LINK TO POST COPIED TO CLIPBOARD