1. bribazy's Avatar
    I can't dial any outgoing calls from my HTC EVO using google voice. I have tried setting it to "ask every time" and "always make calls" and neither of them work. The phone calls go through but always shows my normal phone number on the caller ID. I use this number for work and I want to be able to choose when I make calls. Any help would be appreciated.
    09-09-2010 02:14 PM
  2. stacyadell's Avatar
    I think this is just for international calls.
    09-09-2010 03:02 PM
  3. bucko21's Avatar
    What you need to do is sign into your GoogleVoice account on your computer and change the setting which shows which phone number to show. It can't be done via the phone..
    bribazy likes this.
    09-09-2010 03:11 PM
LINK TO POST COPIED TO CLIPBOARD