1. jdbower's Avatar
    Has anyone had success with Orbot (Tor) on Froyo-based phones? It was working great on my X with 2.1 but since the OTA 2.2 update it appears to connect but doesn't actually proxy anything. I've tried uninstalling and reinstalling to no avail.
    09-22-2010 06:58 PM
  2. alwaysconnected's Avatar
    this is an email i was sent from the makers of Orbot:

    "We believe the issue is that there is no "iptables" installed on the
    DroidX. This is essentiall for the transproxying to work. In the next
    release of Orbot, we will include it, but for now here is the manual
    process you can follow to install.

    (take from here:
    DroidWall iptables Not Found Error on Rooted Android Motorola Droid or Milestone My Digital Life)

    1) Download and install Android WiFi Tether form
    android-wifi-tether - Project Hosting on Google Code or search for Wireless
    Tether for Root Users in Android Market.

    2) Run the Wireless Tether once.

    3) Download and install a Terminal Emulator.

    4) Run the Terminal Emulator.

    5) Log in as superuser by typing the following command:
    $ su

    6) Remount system as rw (read-write enabled) with the following command:
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

    Tip: It’s also possible to use Droid Root Helper app to achieve the
    above task.

    7) Copy the iptables installed by Wireless Tether to the /system/bin
    executables directory with following command:
    # cp /data/data/android.tether/bin/iptables /system/bin

    8) Run Orbot again with the transparent proxying enabled. Run the
    "check" menu option, and you will see if the iptables solution has worked.

    Thank you."

    it didnt work for me. if someone knows what to do from here, please respond. i am wondering this too.
    10-21-2010 03:50 AM