1. Hardcase's Avatar
    I've been timing Launcher Pro recently. It takes 25 to 35 seconds for the icons to show up on on the desktop after hitting the home key! the bottom row shows up and is functional right away, but not the desktop icons.

    Is anyone else experiencing such sluggish service from this venerable program?

    It seems as if it has gotten worse in recent weeks. It is the only launcher on my system, other than the default. I've even unloaded some programs such as Toggle Settings which could possibly conflict.

    Suggestions for a fix, other than dumping the program? I really like its form factor, but the performance is a serious drag.
    10-29-2010 03:10 PM
  2. eharty's Avatar
    No such problems with Launcher Pro on my Epic. If you have any widgets running on the stock launcher you might try removing them. I had a little lag after installing Launcher Pro that went away after removing widgets on Touch Wiz.
    10-29-2010 03:43 PM
  3. Dural's Avatar
    Did you wipe out the old widgets, shortcuts, etc. from your Stock launcher screens? If not, you need to. Download Home Switcher app from the market and use it to launch the old stock screens.

    ALL of your screens should be completely empty to ensure the phone isn't being over-tasked.
    pstellato73 likes this.
    10-29-2010 03:46 PM
  4. pstellato73's Avatar
    I am experiencing the slowness as well. Running Moto Droid with 2.2. I did as @Dural recommends so we'll see. But yeah, for the past 2 days it's been real slow. Takes about 10-15 seconds for me when I hit the home key.
    10-29-2010 10:22 PM
  5. SeeK's Avatar
    I had similar issues with it when I used it last (that was 7.6.0 though), for some reason it seems to un-cache the homescreens even though I specifically set it to not do that. I'm guessing the total re-write of LP that Fede's working on now will solve this, though.
    10-30-2010 06:01 AM
  6. Nebrclimber's Avatar
    I'm having the same problem on my D1 w/ froyo. Mine has been getting worse over the last couple weeks. I did a factory reset to attempt to fix it, but it didn't help. I'm trying out ADW and it seems to be a little better.
    10-30-2010 12:35 PM
  7. Vagrant_1's Avatar
    LP never runs sluggish for me and is extremely fast and responsive. awd launcher runs super laggy for me.

    Sent from my HTC Incredible
    10-30-2010 01:20 PM
  8. mdlissner's Avatar
    Uninstalled due to the slowness. Bought the plus version and it was slow on my rooted D1 running overclocked froyo.
    10-30-2010 03:16 PM
  9. madlaw1071's Avatar
    I installed LPP+ after a factory wipe. Smooth as silk.
    11-07-2010 10:29 AM
  10. ericizzy1's Avatar
    ZEAM launcher, free, light, and very FAST.
    11-07-2010 11:25 AM
  11. davidnc's Avatar
    I use Lp+ on dx ,its a must works great also use on dinc but more of an opt than a must works great on it to never an issue with on either device used it for at least couple months now.

    Sent using TapAtalk
    11-07-2010 11:25 AM
  12. ultravisitor's Avatar
    ZEAM launcher, free, light, and very FAST.
    Yes, Zeam is great. I installed it on Thursday or Friday wondering if it'd be better than Launcher Pro. So far, the only thing Launcher Pro is better for is the dock options. I like being able to use custom docks, and I like being able to set swipe actions for the dock icons.
    11-07-2010 11:49 AM
LINK TO POST COPIED TO CLIPBOARD